aboutsummaryrefslogtreecommitdiff
path: root/www/xshttpd-devel
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2009-01-18 14:06:08 +0000
committerJohan van Selst <johans@FreeBSD.org>2009-01-18 14:06:08 +0000
commit4271a76fcb3ef5044b8f429fa5222b901ef6e5a3 (patch)
treeae17216b74a3f46a6a571a8cb41a8607a1c1b516 /www/xshttpd-devel
parentd5c5b75ddebd1fee7a2d08599719e24ec84f90b4 (diff)
downloadports-4271a76fcb3ef5044b8f429fa5222b901ef6e5a3.tar.gz
ports-4271a76fcb3ef5044b8f429fa5222b901ef6e5a3.zip
Notes
Diffstat (limited to 'www/xshttpd-devel')
-rw-r--r--www/xshttpd-devel/Makefile25
-rw-r--r--www/xshttpd-devel/distinfo6
-rw-r--r--www/xshttpd-devel/pkg-plist4
3 files changed, 18 insertions, 17 deletions
diff --git a/www/xshttpd-devel/Makefile b/www/xshttpd-devel/Makefile
index d77a6a1cc3b9..1ff7e0002a3b 100644
--- a/www/xshttpd-devel/Makefile
+++ b/www/xshttpd-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xshttpd
-DISTVERSION= 3.6b24
+DISTVERSION= 3.7b02
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/ \
ftp://mud.stack.nl/pub/xs-httpd/release/
@@ -25,13 +25,13 @@ MAN1= clearxs.1 gfxcount.1 httpd.1 httpdc.1 imagemap.1 \
readxs.1 xschpass.1 xsindex.1 xspasswd.1
MAN5= httpd.conf.5 xsauth.5 xsconf.5 xsscripts.5 xsredir.5
MAN7= httpd_cgi.7 httpd_ssi.7
+USE_OPENSSL= yes
USE_BZIP2= yes
USE_RC_SUBR= xshttpd.sh
GNU_CONFIGURE= yes
-OPTIONS= SSL "Enable https support" On \
- PCRE "Enable pcre rewriting support" On \
+OPTIONS= PCRE "Enable pcre rewriting support" On \
LDAP "Enable ldap support" Off \
CURL "Enable curl (proxy) support" Off \
M4_CONFIG "Enable m4 configuration preprocessor" Off \
@@ -42,21 +42,15 @@ PORTDOCS= README COPYING ChangeLog
.include <bsd.port.pre.mk>
# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
WWWDIR?= ${PREFIX}/www/${PORTNAME}
-CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
-
-.if !defined(WITHOUT_SSL)
-.include <${PORTSDIR}/Mk/bsd.openssl.mk>
-#USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-ssl
-.else
-CONFIGURE_ARGS+=--without-ssl
-.endif
+CONFIGURE_ARGS+=--with-rootdir=${WWWDIR} --with-ssl --with-pcre
.if defined(WITH_LDAP)
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
+PLIST_SUB+= LDAP=""
.else
CONFIGURE_ARGS+=--without-ldap
+PLIST_SUB+= LDAP="@comment "
.endif
.if defined(WITH_M4_CONFIG)
@@ -68,8 +62,10 @@ CONFIGURE_ARGS+=--without-preprocessor
.if defined(WITH_PERSISTENT_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+=--with-perl
+PLIST_SUB+= PERL=""
.else
CONFIGURE_ARGS+=--without-perl
+PLIST_SUB+= PERL="@comment "
.endif
.if defined(WITH_PCRE)
@@ -81,9 +77,9 @@ CONFIGURE_ARGS+=--with-pcre=no
.if defined(WITH_CURL)
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+=--with-curl=yes
+CONFIGURE_ARGS+=--with-curl
.else
-CONFIGURE_ARGS+=--with-curl=no
+CONFIGURE_ARGS+=--without-curl
.endif
post-patch:
@@ -103,6 +99,7 @@ post-patch:
${WRKSRC}/config/Makefile.in
post-install:
+ @${TOUCH} ${WWWDIR}/module/.keepme
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
diff --git a/www/xshttpd-devel/distinfo b/www/xshttpd-devel/distinfo
index c163446722f4..ebbe2d2cb5a5 100644
--- a/www/xshttpd-devel/distinfo
+++ b/www/xshttpd-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (xshttpd-36b24.tar.bz2) = 59526f3af2333a78b39ba11e87936b12
-SHA256 (xshttpd-36b24.tar.bz2) = 89904d61133042d16090abc614035355e3f2a967c531913d3f5ac51385684373
-SIZE (xshttpd-36b24.tar.bz2) = 241758
+MD5 (xshttpd-37b02.tar.bz2) = a973cd27ae95c884ccaf028cc4b3e61a
+SHA256 (xshttpd-37b02.tar.bz2) = 29fc1755a9d2efa9cb29754e7d6f3437f7e9d905d398c4456b899c2fe0ce58da
+SIZE (xshttpd-37b02.tar.bz2) = 261936
diff --git a/www/xshttpd-devel/pkg-plist b/www/xshttpd-devel/pkg-plist
index f3a5461818dc..1871495fcbfd 100644
--- a/www/xshttpd-devel/pkg-plist
+++ b/www/xshttpd-devel/pkg-plist
@@ -64,6 +64,9 @@ bin/xspasswd
%%WWWDIR%%/icons/xs-unknown.gif
%%WWWDIR%%/icons/xs-video.gif
%%WWWDIR%%/icons/xs-zip.gif
+%%WWWDIR%%/module/.keepme
+%%PERL%%%%WWWDIR%%/module/mod_perl.so
+%%LDAP%%%%WWWDIR%%/module/mod_ldap.so
@exec mkdir -p %%WWWDIR%%/htdocs
@dirrm %%WWWDIR%%/contrib
@dirrm %%WWWDIR%%/gfxcount
@@ -72,4 +75,5 @@ bin/xspasswd
@dirrmtry %%WWWDIR%%/htdocs
@dirrmtry %%WWWDIR%%/icons
@dirrmtry %%WWWDIR%%/logs
+@dirrmtry %%WWWDIR%%/module
@dirrmtry %%WWWDIR%%