aboutsummaryrefslogtreecommitdiff
path: root/www/yahoo-ui
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 11:53:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 11:53:34 +0000
commit606c17b9c8ceebf3bba34704094912556f260836 (patch)
tree5f0dbe9212a3377e7182c77ac610d48050fcb2b0 /www/yahoo-ui
parent919430dbf0343ab4fb4c8362bb4b711509b3981b (diff)
downloadports-606c17b9c8ceebf3bba34704094912556f260836.tar.gz
ports-606c17b9c8ceebf3bba34704094912556f260836.zip
Notes
Diffstat (limited to 'www/yahoo-ui')
-rw-r--r--www/yahoo-ui/Makefile31
1 files changed, 13 insertions, 18 deletions
diff --git a/www/yahoo-ui/Makefile b/www/yahoo-ui/Makefile
index 4a264a1fd9b2..2bd572aa6516 100644
--- a/www/yahoo-ui/Makefile
+++ b/www/yahoo-ui/Makefile
@@ -22,17 +22,11 @@ USE_ZIP= yes
WRKSRC= ${WRKDIR}/yui
NO_BUILD= yes
-OPTIONS= APACHE "Configure for Apache-2.x" off \
- MINIMAL "Do not install documentation and examples" off
+OPTIONS_DEFINE= APACHE DOCS EXAMPLES
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MINIMAL)
-NOPORTDOCS= yes
-NOPORTEXAMPLES= yes
-.endif
-
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE_RUN= 22+
CONFDIR= ${PREFIX}/${CONFDIR_REL}
CONFDIR_REL= ${APACHEETCDIR}/Includes
@@ -41,17 +35,18 @@ PLIST_SUB+= NOAPACHE="" CONFDIR=${CONFDIR_REL}
CONF= yui.conf
SUB_FILES+= pkg-message ${CONF}
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
+SUB_LIST+= HASHMARK1=
SUB_LIST+= HASHMARK1=\#
.else
-SUB_LIST+= HASHMARK1=
.endif
-.if defined(NOPORTEXAMPLES)
-SUB_LIST+= HASHMARK2=\#
-.else
+.if ${PORT_OPTIONS:MEXAMPLES}
SUB_LIST+= HASHMARK2=
+.else
+SUB_LIST+= HASHMARK2=\#
.endif
+
.else
PLIST_SUB+= NOAPACHE="@comment "
.endif
@@ -81,7 +76,7 @@ do-install:
${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
post-install:
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
.if !defined(MAINTAINER_MODE)
@if [ -d "${CONFDIR}" ]; then \
${CP} ${WRKDIR}/${CONF} ${CONFDIR}; \
@@ -96,11 +91,11 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MNLS}
@cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>