aboutsummaryrefslogtreecommitdiff
path: root/www/yahoo-ui
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-20 18:00:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-20 18:00:47 +0000
commit792e7640744bd5dec930c657217cb3a0ae8acb49 (patch)
treea0cc364987e7ec57928286947ff34b22178e3068 /www/yahoo-ui
parent07d5e942dbbe5a39580a73ec1d0da4fd9aa0e8b8 (diff)
downloadports-792e7640744bd5dec930c657217cb3a0ae8acb49.tar.gz
ports-792e7640744bd5dec930c657217cb3a0ae8acb49.zip
Notes
Diffstat (limited to 'www/yahoo-ui')
-rw-r--r--www/yahoo-ui/Makefile28
-rw-r--r--www/yahoo-ui/distinfo6
-rw-r--r--www/yahoo-ui/files/pkg-message.in3
-rw-r--r--www/yahoo-ui/files/yui.conf.in4
-rw-r--r--www/yahoo-ui/pkg-plist13
5 files changed, 42 insertions, 12 deletions
diff --git a/www/yahoo-ui/Makefile b/www/yahoo-ui/Makefile
index 67430ee8aece..27a26246a7d5 100644
--- a/www/yahoo-ui/Makefile
+++ b/www/yahoo-ui/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= yahoo
-PORTVERSION= 2.5.1
+PORTVERSION= 2.5.2
CATEGORIES= www
MASTER_SITES= SF
MASTER_SITE_SUBDIR= yui
@@ -21,10 +21,16 @@ USE_ZIP= yes
WRKSRC= ${WRKDIR}/yui
NO_BUILD= yes
-OPTIONS= APACHE "Configure for Apache-2.x" off
+OPTIONS= APACHE "Configure for Apache-2.x" off \
+ MINIMAL "Do not install documentation and examples" off
.include <bsd.port.pre.mk>
+.if defined(WITH_MINIMAL)
+NOPORTDOCS= yes
+NOPORTEXAMPLES= yes
+.endif
+
.if defined(WITH_APACHE)
USE_APACHE= 2.0+
CONFDIR= ${PREFIX}/${CONFDIR_REL}
@@ -33,6 +39,18 @@ PLIST_SUB+= NOAPACHE="" CONFDIR=${CONFDIR_REL}
CONF= yui.conf
SUB_FILES+= pkg-message ${CONF}
+
+.if defined(NOPORTDOCS)
+SUB_LIST+= HASHMARK1=\#
+.else
+SUB_LIST+= HASHMARK1=
+.endif
+
+.if defined(NOPORTEXAMPLES)
+SUB_LIST+= HASHMARK2=\#
+.else
+SUB_LIST+= HASHMARK2=
+.endif
.else
PLIST_SUB+= NOAPACHE="@comment "
.endif
@@ -40,13 +58,13 @@ PLIST_SUB+= NOAPACHE="@comment "
do-install:
@cd ${WRKSRC} && ${COPYTREE_SHARE} "assets build index.html \
tests" ${WWWDIR}
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
@${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
${WWWDIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
- ${FIND} ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @${FIND} ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
@${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type f -print0 | \
${XARGS} -0 ${CHMOD} 644' >> ${TMPPLIST}
- ${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
@${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type d -print0 | \
${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
diff --git a/www/yahoo-ui/distinfo b/www/yahoo-ui/distinfo
index 6c1bd2946979..763b4b949263 100644
--- a/www/yahoo-ui/distinfo
+++ b/www/yahoo-ui/distinfo
@@ -1,3 +1,3 @@
-MD5 (yui_2.5.1.zip) = 7416914904daa7d953583483db67609c
-SHA256 (yui_2.5.1.zip) = a87d3596c5bde3c1f5ca3f6a3956e5d38ffeb0aa36f4e032e213a353a0b201d9
-SIZE (yui_2.5.1.zip) = 9287362
+MD5 (yui_2.5.2.zip) = eaadfcbcb651c50092bb679266aa3c20
+SHA256 (yui_2.5.2.zip) = 0d81f219a25c4b4b560b8c912317407e4450e5b6260b548a0aec1c271eb40af7
+SIZE (yui_2.5.2.zip) = 9974867
diff --git a/www/yahoo-ui/files/pkg-message.in b/www/yahoo-ui/files/pkg-message.in
index 65dee8776e2e..ea9d82e0b655 100644
--- a/www/yahoo-ui/files/pkg-message.in
+++ b/www/yahoo-ui/files/pkg-message.in
@@ -4,3 +4,6 @@ You have just installed the Yahoo YUI toolkit.
Note that you should restart your Apache web server to ensure that
the YUI configuration file is loaded.
+
+Then browse to http://localhost/yahoo/ for documentation and examples,
+if you've installed them.
diff --git a/www/yahoo-ui/files/yui.conf.in b/www/yahoo-ui/files/yui.conf.in
index 0cfdf7f67599..369e22b14c55 100644
--- a/www/yahoo-ui/files/yui.conf.in
+++ b/www/yahoo-ui/files/yui.conf.in
@@ -1,5 +1,5 @@
-Alias /yahoo/docs %%DOCSDIR%%
-Alias /yahoo/examples %%EXAMPLESDIR%%
+%%HASHMARK1%%Alias /yahoo/docs %%DOCSDIR%%
+%%HASHMARK2%%Alias /yahoo/examples %%EXAMPLESDIR%%
Alias /yahoo %%WWWDIR%%
<Location /yahoo>
diff --git a/www/yahoo-ui/pkg-plist b/www/yahoo-ui/pkg-plist
index 3bfc37e386e6..7940b99bbde8 100644
--- a/www/yahoo-ui/pkg-plist
+++ b/www/yahoo-ui/pkg-plist
@@ -1,4 +1,4 @@
-%%PORTDOCS%%%%DOCSDIR%%/README
+%%NOAPACHE%%%%CONFDIR%%/yui.conf
%%PORTDOCS%%%%DOCSDIR%%/Anim.js.html
%%PORTDOCS%%%%DOCSDIR%%/AnimMgr.js.html
%%PORTDOCS%%%%DOCSDIR%%/ArrayAssert.js.html
@@ -64,6 +64,7 @@
%%PORTDOCS%%%%DOCSDIR%%/Panel.js.html
%%PORTDOCS%%%%DOCSDIR%%/PieChart.js.html
%%PORTDOCS%%%%DOCSDIR%%/Profiler.js.html
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/RecordSet.js.html
%%PORTDOCS%%%%DOCSDIR%%/Region.js.html
%%PORTDOCS%%%%DOCSDIR%%/RootNode.js.html
@@ -659,6 +660,9 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datatable/dt_nestedheaders.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datatable/dt_nestedheaders_clean.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datatable/dt_nestedheaders_log.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datatable/dt_row_coloring.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datatable/dt_row_coloring_clean.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datatable/dt_row_coloring_log.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datatable/dt_rowadddelete.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datatable/dt_rowadddelete_clean.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datatable/dt_rowadddelete_log.html
@@ -1307,6 +1311,7 @@
%%WWWDIR%%/build/assets/skins/sam/split-button-arrow.png
%%WWWDIR%%/build/assets/skins/sam/sprite.png
%%WWWDIR%%/build/assets/skins/sam/tabview.css
+%%WWWDIR%%/build/assets/skins/sam/transparent.gif
%%WWWDIR%%/build/assets/skins/sam/treeview-loading.gif
%%WWWDIR%%/build/assets/skins/sam/treeview-sprite.gif
%%WWWDIR%%/build/assets/skins/sam/treeview.css
@@ -1402,6 +1407,7 @@
%%WWWDIR%%/build/datatable/assets/skins/sam/datatable.css
%%WWWDIR%%/build/datatable/assets/skins/sam/dt-arrow-dn.png
%%WWWDIR%%/build/datatable/assets/skins/sam/dt-arrow-up.png
+%%WWWDIR%%/build/datatable/assets/skins/sam/transparent.gif
%%WWWDIR%%/build/datatable/datatable-beta-debug.js
%%WWWDIR%%/build/datatable/datatable-beta-min.js
%%WWWDIR%%/build/datatable/datatable-beta.js
@@ -1630,7 +1636,6 @@
%%WWWDIR%%/tests/yuiloader_config.html
%%WWWDIR%%/tests/yuiloader_rollup.html
%%WWWDIR%%/tests/yuitest.html
-%%NOAPACHE%%%%CONFDIR%%/yui.conf
@dirrm %%WWWDIR%%/tests/assets
@dirrm %%WWWDIR%%/tests
@dirrm %%WWWDIR%%/build/yuitest/assets/skins/sam
@@ -1796,6 +1801,7 @@
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/datatable/assets/img
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/datatable/assets/images
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/datatable/assets/html
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/datatable/assets/css
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/datatable/assets
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/datatable
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/cookie
@@ -1815,9 +1821,12 @@
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/base
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/autocomplete/assets/php
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/autocomplete/assets/js
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/autocomplete/assets/css
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/autocomplete/assets
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/autocomplete
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/animation
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/assets
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@exec mkdir -p %D/%%EXAMPLESDIR%%/datatable/assets/css
+%%PORTEXAMPLES%%@exec mkdir -p %D/%%EXAMPLESDIR%%/autocomplete/assets/css