aboutsummaryrefslogtreecommitdiff
path: root/www/yanopaste
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-23 08:13:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-23 08:13:17 +0000
commitebcf9e25c667fcea4bc3cbe64c59c0aaa69f558d (patch)
tree481b0c0dd93031f0cc2147b9dd00880d425a377c /www/yanopaste
parenta7ab62f02d66cdebce5dc85fab03a324ffe69691 (diff)
downloadports-ebcf9e25c667fcea4bc3cbe64c59c0aaa69f558d.tar.gz
ports-ebcf9e25c667fcea4bc3cbe64c59c0aaa69f558d.zip
Notes
Diffstat (limited to 'www/yanopaste')
-rw-r--r--www/yanopaste/Makefile41
-rw-r--r--www/yanopaste/distinfo3
-rw-r--r--www/yanopaste/files/pkg-message.in10
-rw-r--r--www/yanopaste/pkg-descr6
-rw-r--r--www/yanopaste/pkg-plist125
5 files changed, 185 insertions, 0 deletions
diff --git a/www/yanopaste/Makefile b/www/yanopaste/Makefile
new file mode 100644
index 000000000000..c01785f545f9
--- /dev/null
+++ b/www/yanopaste/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: yanopaste
+# Date created: 2008-09-15
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yanopaste
+PORTVERSION= 1.2.0
+CATEGORIES= www
+MASTER_SITES= SF
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Yet Another Nopaste
+
+NO_BUILD= yes
+USE_PHP= xsl
+SUB_FILES= pkg-message
+WWWDIR?= ${PREFIX}/www/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${FIND} ${WRKSRC} -name .svn -type d | ${XARGS} ${RM} -rf
+
+do-install:
+ @${MKDIR} ${WWWDIR}
+ ${CP} -R ${WRKSRC}/ ${WWWDIR}
+ @${TOUCH} ${WWWDIR}/config.php
+ @${CHOWN} ${WWWOWN} ${WWWDIR}/config.php
+ @${CAT} ${PKGMESSAGE}
+
+create-plist:
+ @${FIND} -s ${WRKSRC}/${file} -not -type d \
+ | ${SED} -e 's,^${WRKSRC},%%WWWDIR%%,' > ${PLIST}
+ @${ECHO_CMD} '@exec touch %D/%%WWWDIR%%/config.php;chown ${WWWOWN} %D/%%WWWDIR%%/config.php' >> ${PLIST}
+ @${ECHO_CMD} '@unexec if [ ! -s %D/%%WWWDIR%%/config.php ];then rm -f %D/%%WWWDIR%%/config.php;fi' >> ${PLIST}
+ @${FIND} -ds ${WRKSRC}/${file} -type d \
+ | ${SED} -e 's,^${WRKSRC},@dirrm %%WWWDIR%%,' >> ${PLIST}
+
+.include <bsd.port.post.mk>
diff --git a/www/yanopaste/distinfo b/www/yanopaste/distinfo
new file mode 100644
index 000000000000..b30e4ca13bc4
--- /dev/null
+++ b/www/yanopaste/distinfo
@@ -0,0 +1,3 @@
+MD5 (yanopaste-1.2.0.tar.gz) = 093e5e9e0391f06cf1a21ee6ce2322c3
+SHA256 (yanopaste-1.2.0.tar.gz) = 4e325fd4ec10686f9c4ed576bf173f75728e429fff9dc6b364bacb54dc09bda9
+SIZE (yanopaste-1.2.0.tar.gz) = 762701
diff --git a/www/yanopaste/files/pkg-message.in b/www/yanopaste/files/pkg-message.in
new file mode 100644
index 000000000000..63c44b12b7b0
--- /dev/null
+++ b/www/yanopaste/files/pkg-message.in
@@ -0,0 +1,10 @@
+yanopaste has been installed into:
+
+ %%WWWDIR%%
+
+You will probably want to add an alias to your httpd.conf file,
+somethinglike this:
+
+ Alias /yanopaste "%%WWWDIR%%"
+
+And restart Apache.
diff --git a/www/yanopaste/pkg-descr b/www/yanopaste/pkg-descr
new file mode 100644
index 000000000000..e27b12f2350e
--- /dev/null
+++ b/www/yanopaste/pkg-descr
@@ -0,0 +1,6 @@
+Yet Another Nopaste is a PHP implementation of nopaste, allowing copy / paste
+of piece of code from numerous language to share it using a simple URL,
+optionally protected using a password. It uses GeSHi as highlighter back-end.
+It does not use database.
+
+WWW: http://sourceforge.net/projects/yanopaste/
diff --git a/www/yanopaste/pkg-plist b/www/yanopaste/pkg-plist
new file mode 100644
index 000000000000..4af129d841a8
--- /dev/null
+++ b/www/yanopaste/pkg-plist
@@ -0,0 +1,125 @@
+%%WWWDIR%%/INSTALL
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/common.js
+%%WWWDIR%%/config.php
+%%WWWDIR%%/functions.php
+%%WWWDIR%%/header.jpg
+%%WWWDIR%%/includes/geshi/abap.php
+%%WWWDIR%%/includes/geshi/actionscript.php
+%%WWWDIR%%/includes/geshi/actionscript3.php
+%%WWWDIR%%/includes/geshi/ada.php
+%%WWWDIR%%/includes/geshi/apache.php
+%%WWWDIR%%/includes/geshi/applescript.php
+%%WWWDIR%%/includes/geshi/apt_sources.php
+%%WWWDIR%%/includes/geshi/asm.php
+%%WWWDIR%%/includes/geshi/asp.php
+%%WWWDIR%%/includes/geshi/autoit.php
+%%WWWDIR%%/includes/geshi/bash.php
+%%WWWDIR%%/includes/geshi/basic4gl.php
+%%WWWDIR%%/includes/geshi/blitzbasic.php
+%%WWWDIR%%/includes/geshi/bnf.php
+%%WWWDIR%%/includes/geshi/boo.php
+%%WWWDIR%%/includes/geshi/c.php
+%%WWWDIR%%/includes/geshi/c_mac.php
+%%WWWDIR%%/includes/geshi/caddcl.php
+%%WWWDIR%%/includes/geshi/cadlisp.php
+%%WWWDIR%%/includes/geshi/cfdg.php
+%%WWWDIR%%/includes/geshi/cfm.php
+%%WWWDIR%%/includes/geshi/cil.php
+%%WWWDIR%%/includes/geshi/cobol.php
+%%WWWDIR%%/includes/geshi/cpp-qt.php
+%%WWWDIR%%/includes/geshi/cpp.php
+%%WWWDIR%%/includes/geshi/csharp.php
+%%WWWDIR%%/includes/geshi/css.php
+%%WWWDIR%%/includes/geshi/d.php
+%%WWWDIR%%/includes/geshi/delphi.php
+%%WWWDIR%%/includes/geshi/diff.php
+%%WWWDIR%%/includes/geshi/div.php
+%%WWWDIR%%/includes/geshi/dos.php
+%%WWWDIR%%/includes/geshi/dot.php
+%%WWWDIR%%/includes/geshi/eiffel.php
+%%WWWDIR%%/includes/geshi/fortran.php
+%%WWWDIR%%/includes/geshi/freebasic.php
+%%WWWDIR%%/includes/geshi/genero.php
+%%WWWDIR%%/includes/geshi/gettext.php
+%%WWWDIR%%/includes/geshi/glsl.php
+%%WWWDIR%%/includes/geshi/gml.php
+%%WWWDIR%%/includes/geshi/gnuplot.php
+%%WWWDIR%%/includes/geshi/groovy.php
+%%WWWDIR%%/includes/geshi/haskell.php
+%%WWWDIR%%/includes/geshi/html4strict.php
+%%WWWDIR%%/includes/geshi/idl.php
+%%WWWDIR%%/includes/geshi/ini.php
+%%WWWDIR%%/includes/geshi/inno.php
+%%WWWDIR%%/includes/geshi/io.php
+%%WWWDIR%%/includes/geshi/java.php
+%%WWWDIR%%/includes/geshi/java5.php
+%%WWWDIR%%/includes/geshi/javascript.php
+%%WWWDIR%%/includes/geshi/kixtart.php
+%%WWWDIR%%/includes/geshi/klonec.php
+%%WWWDIR%%/includes/geshi/klonecpp.php
+%%WWWDIR%%/includes/geshi/latex.php
+%%WWWDIR%%/includes/geshi/lisp.php
+%%WWWDIR%%/includes/geshi/lotusformulas.php
+%%WWWDIR%%/includes/geshi/lotusscript.php
+%%WWWDIR%%/includes/geshi/lua.php
+%%WWWDIR%%/includes/geshi/m68k.php
+%%WWWDIR%%/includes/geshi/matlab.php
+%%WWWDIR%%/includes/geshi/mirc.php
+%%WWWDIR%%/includes/geshi/mpasm.php
+%%WWWDIR%%/includes/geshi/mxml.php
+%%WWWDIR%%/includes/geshi/mysql.php
+%%WWWDIR%%/includes/geshi/nsis.php
+%%WWWDIR%%/includes/geshi/objc.php
+%%WWWDIR%%/includes/geshi/ocaml-brief.php
+%%WWWDIR%%/includes/geshi/ocaml.php
+%%WWWDIR%%/includes/geshi/oobas.php
+%%WWWDIR%%/includes/geshi/oracle8.php
+%%WWWDIR%%/includes/geshi/pascal.php
+%%WWWDIR%%/includes/geshi/per.php
+%%WWWDIR%%/includes/geshi/perl.php
+%%WWWDIR%%/includes/geshi/php-brief.php
+%%WWWDIR%%/includes/geshi/php.php
+%%WWWDIR%%/includes/geshi/pic16.php
+%%WWWDIR%%/includes/geshi/plsql.php
+%%WWWDIR%%/includes/geshi/povray.php
+%%WWWDIR%%/includes/geshi/powershell.php
+%%WWWDIR%%/includes/geshi/progress.php
+%%WWWDIR%%/includes/geshi/python.php
+%%WWWDIR%%/includes/geshi/qbasic.php
+%%WWWDIR%%/includes/geshi/rails.php
+%%WWWDIR%%/includes/geshi/reg.php
+%%WWWDIR%%/includes/geshi/robots.php
+%%WWWDIR%%/includes/geshi/ruby.php
+%%WWWDIR%%/includes/geshi/sas.php
+%%WWWDIR%%/includes/geshi/scala.php
+%%WWWDIR%%/includes/geshi/scheme.php
+%%WWWDIR%%/includes/geshi/sdlbasic.php
+%%WWWDIR%%/includes/geshi/smalltalk.php
+%%WWWDIR%%/includes/geshi/smarty.php
+%%WWWDIR%%/includes/geshi/sql.php
+%%WWWDIR%%/includes/geshi/tcl.php
+%%WWWDIR%%/includes/geshi/text.php
+%%WWWDIR%%/includes/geshi/thinbasic.php
+%%WWWDIR%%/includes/geshi/tsql.php
+%%WWWDIR%%/includes/geshi/typoscript.php
+%%WWWDIR%%/includes/geshi/vb.php
+%%WWWDIR%%/includes/geshi/vbnet.php
+%%WWWDIR%%/includes/geshi/verilog.php
+%%WWWDIR%%/includes/geshi/vhdl.php
+%%WWWDIR%%/includes/geshi/visualfoxpro.php
+%%WWWDIR%%/includes/geshi/winbatch.php
+%%WWWDIR%%/includes/geshi/xml.php
+%%WWWDIR%%/includes/geshi/xorg_conf.php
+%%WWWDIR%%/includes/geshi/xpp.php
+%%WWWDIR%%/includes/geshi/z80.php
+%%WWWDIR%%/includes/geshi.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/paste.xsl
+%%WWWDIR%%/screen.css
+@exec touch %D/%%WWWDIR%%/config.php;chown www %D/%%WWWDIR%%/config.php
+@unexec if [ ! -s %D/%%WWWDIR%%/config.php ];then rm -f %D/%%WWWDIR%%/config.php;fi
+@dirrm %%WWWDIR%%/includes/geshi
+@dirrm %%WWWDIR%%/includes
+@dirrm %%WWWDIR%%/repository
+@dirrm %%WWWDIR%%/