aboutsummaryrefslogtreecommitdiff
path: root/www/yaws
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2013-04-23 14:53:51 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2013-04-23 14:53:51 +0000
commit576a3643fbf7e0d3d4adabd4338e051f747441c7 (patch)
tree282a2a43e3e84dc20d0d232456bd2c9aa30dc4bb /www/yaws
parent987864fc3b712a88a14c03fbcc5f55eff16e284a (diff)
downloadports-576a3643fbf7e0d3d4adabd4338e051f747441c7.tar.gz
ports-576a3643fbf7e0d3d4adabd4338e051f747441c7.zip
Notes
Diffstat (limited to 'www/yaws')
-rw-r--r--www/yaws/Makefile10
-rw-r--r--www/yaws/files/patch-scripts__gen-yaws22
-rw-r--r--www/yaws/pkg-plist2
3 files changed, 14 insertions, 20 deletions
diff --git a/www/yaws/Makefile b/www/yaws/Makefile
index 1f80f29a00a7..0354f66abb48 100644
--- a/www/yaws/Makefile
+++ b/www/yaws/Makefile
@@ -2,7 +2,8 @@
PORTNAME= yaws
PORTVERSION= 1.96
-CATEGORIES= www
+PORTREVISION= 1
+CATEGORIES= www devel
MASTER_SITES= http://yaws.hyber.org/download/
MAINTAINER= olgeni@FreeBSD.org
@@ -20,7 +21,7 @@ WRKSRC= ${WRKDIR}/yaws-${PORTVERSION}
MAN1= yaws.1
MAN5= yaws.conf.5 yaws_api.5 yaws_soap_lib.5
-APPDIR=${PREFIX}/lib/erlang/lib/yaws-${PORTVERSION}
+APPDIR= ${PREFIX}/lib/erlang/lib/yaws-${PORTVERSION}
SUB_FILES= pkg-message
@@ -34,7 +35,9 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|!!PREFIX!!|${PREFIX}|g' \
${WRKSRC}/man/yaws_api.5 ${WRKSRC}/man/yaws.conf.5 \
- ${WRKSRC}/README
+ ${WRKSRC}/README ${WRKSRC}/scripts/gen-yaws
+ @${REINPLACE_CMD} -e 's|!!VERSION!!|${PORTVERSION}|g' \
+ ${WRKSRC}/scripts/gen-yaws
@${FIND} ${WRKSRC} \( -name \*.orig -or -name \*.bak \) -delete
do-install:
@@ -66,7 +69,6 @@ do-install:
@${INSTALL_MAN} ${WRKSRC}/man/*.5 ${MANPREFIX}/man/man5
post-install:
- @${LN} -sf ${PORTNAME}-${PORTVERSION} ${PREFIX}/lib/erlang/lib/${PORTNAME}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/yaws/files/patch-scripts__gen-yaws b/www/yaws/files/patch-scripts__gen-yaws
index 50a73527ccf3..f46a931e04e9 100644
--- a/www/yaws/files/patch-scripts__gen-yaws
+++ b/www/yaws/files/patch-scripts__gen-yaws
@@ -1,20 +1,14 @@
---- scripts/gen-yaws.ORIG 2012-06-24 15:27:11.000000000 +0900
-+++ scripts/gen-yaws 2012-06-24 15:33:26.000000000 +0900
-@@ -1,13 +1,15 @@
- #!/bin/sh
-
-+# CAUTION: Modified for FreeBSD Port installation
-+# referring yawsdir in the installed yaws library
-+
- # Used by scripts/Makefile and scripts/rebar-pre-script to generate
- # the yaws execution script
+
+$FreeBSD$
+
+--- scripts/gen-yaws.orig
++++ scripts/gen-yaws
+@@ -5,7 +5,7 @@
set -e
-topdir=`cd .. && pwd`
++topdir=!!PREFIX!!/lib/erlang/lib/yaws-!!VERSION!!
cat yaws.template | \
-- ./Subst %yawsdir% "${topdir}" | \
-+ ./Subst %yawsdir% "/usr/local/lib/erlang/lib/yaws" | \
+ ./Subst %yawsdir% "${topdir}" | \
./Subst %vardir% "${VARDIR}" | \
- ./Subst %run_erl% "${ERLBINDIR}/run_erl" | \
- ./Subst %to_erl% "${ERLBINDIR}/to_erl" | \
diff --git a/www/yaws/pkg-plist b/www/yaws/pkg-plist
index fdfc29ab16be..801471ebf72d 100644
--- a/www/yaws/pkg-plist
+++ b/www/yaws/pkg-plist
@@ -378,5 +378,3 @@ bin/yaws
@dirrm %%LIB32DIR%%/erlang/lib/yaws-%%VERSION%%/ebin
@dirrm %%LIB32DIR%%/erlang/lib/yaws-%%VERSION%%
@dirrm %%ETCDIR%%
-@exec ln -sf yaws-%%VERSION%% %D/lib/erlang/lib/yaws
-@unexec rm -f %D/lib/erlang/lib/yaws