aboutsummaryrefslogtreecommitdiff
path: root/www/youtube_dl
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2014-11-25 08:23:04 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2014-11-25 08:23:04 +0000
commitd495ed5eefbffc070eb053524f82de8a36a47a59 (patch)
tree296ace38aa9d9eb999fec2b8c8d4d0624b66e3b7 /www/youtube_dl
parent31075c4986850eaf400546fade12c47c89e96786 (diff)
downloadports-d495ed5eefbffc070eb053524f82de8a36a47a59.tar.gz
ports-d495ed5eefbffc070eb053524f82de8a36a47a59.zip
Notes
Diffstat (limited to 'www/youtube_dl')
-rw-r--r--www/youtube_dl/Makefile2
-rw-r--r--www/youtube_dl/distinfo4
-rw-r--r--www/youtube_dl/files/patch-youtube_dl____init__.py16
-rw-r--r--www/youtube_dl/files/patch-youtube_dl__options.py24
4 files changed, 24 insertions, 22 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index e3890aa2d69d..21e57a315dd2 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= youtube_dl
-PORTVERSION= 2014.09.29.2
+PORTVERSION= 2014.11.24
CATEGORIES= www
MASTER_SITES= https://yt-dl.org/downloads/${PORTVERSION}/
DISTNAME= youtube-dl-${PORTVERSION}
diff --git a/www/youtube_dl/distinfo b/www/youtube_dl/distinfo
index 44da9f3613d3..df0ba2cdff00 100644
--- a/www/youtube_dl/distinfo
+++ b/www/youtube_dl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (youtube-dl-2014.09.29.2.tar.gz) = 4192ad648e21e8ab1a4e9b4fe130e47623834407737fd40a0197c61fe38b50f1
-SIZE (youtube-dl-2014.09.29.2.tar.gz) = 1072137
+SHA256 (youtube-dl-2014.11.24.tar.gz) = 3bae2155e429c3409bfac431330a86c931ea36d87c4c07e793bf0ea0cbfc1cbf
+SIZE (youtube-dl-2014.11.24.tar.gz) = 1149666
diff --git a/www/youtube_dl/files/patch-youtube_dl____init__.py b/www/youtube_dl/files/patch-youtube_dl____init__.py
index 8797417a4558..e32e60f4eeb1 100644
--- a/www/youtube_dl/files/patch-youtube_dl____init__.py
+++ b/www/youtube_dl/files/patch-youtube_dl____init__.py
@@ -1,6 +1,6 @@
---- youtube_dl/__init__.py.orig 2014-09-27 21:51:19 UTC
-+++ youtube_dl/__init__.py
-@@ -108,7 +108,6 @@
+--- youtube_dl/__init__.py.orig 2014-11-23 17:50:21.000000000 +0800
++++ youtube_dl/__init__.py 2014-11-23 21:17:37.918929006 +0800
+@@ -34,7 +34,6 @@
std_headers,
write_string,
)
@@ -8,7 +8,7 @@
from .downloader import (
FileDownloader,
)
-@@ -399,17 +398,13 @@
+@@ -324,17 +323,13 @@
ydl.add_post_processor(ExecAfterDownloadPP(
verboseOutput=opts.verbose, exec_cmd=opts.exec_cmd))
@@ -22,8 +22,8 @@
# Maybe do nothing
if (len(all_urls) < 1) and (opts.load_info_filename is None):
-- if not (opts.update_self or opts.rm_cachedir):
-+ if not (opts.rm_cachedir):
- parser.error(u'you must provide at least one URL')
- else:
+- if opts.update_self or opts.rm_cachedir:
++ if opts.rm_cachedir:
sys.exit()
+
+ ydl.warn_if_short_id(sys.argv[1:] if argv is None else argv)
diff --git a/www/youtube_dl/files/patch-youtube_dl__options.py b/www/youtube_dl/files/patch-youtube_dl__options.py
index c09c76974a4d..69419b774cea 100644
--- a/www/youtube_dl/files/patch-youtube_dl__options.py
+++ b/www/youtube_dl/files/patch-youtube_dl__options.py
@@ -1,11 +1,13 @@
---- youtube_dl/options.py.orig 2014-10-01 13:10:09 UTC
-+++ youtube_dl/options.py
-@@ -127,8 +127,6 @@
- action='help', help='print this help text and exit')
- general.add_option('-v', '--version',
- action='version', help='print program version and exit')
-- general.add_option('-U', '--update',
-- action='store_true', dest='update_self', help='update this program to latest version. Make sure that you have sufficient permissions (run with sudo if needed)')
- general.add_option('-i', '--ignore-errors',
- action='store_true', dest='ignoreerrors', help='continue on download errors, for example to skip unavailable videos in a playlist', default=False)
- general.add_option('--abort-on-error',
+--- youtube_dl/options.py.orig 2014-11-15 22:16:23.000000000 +0800
++++ youtube_dl/options.py 2014-11-22 12:34:15.188052389 +0800
+@@ -125,10 +125,6 @@
+ action='version',
+ help='print program version and exit')
+ general.add_option(
+- '-U', '--update',
+- action='store_true', dest='update_self',
+- help='update this program to latest version. Make sure that you have sufficient permissions (run with sudo if needed)')
+- general.add_option(
+ '-i', '--ignore-errors',
+ action='store_true', dest='ignoreerrors', default=False,
+ help='continue on download errors, for example to skip unavailable videos in a playlist')