aboutsummaryrefslogtreecommitdiff
path: root/www/youtube_dl
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2012-03-06 11:43:58 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2012-03-06 11:43:58 +0000
commit336c5e2d4e991802727754a4701ea51eb4326a95 (patch)
treedea443596833726c6c206c24b4fc3f4107c00cb5 /www/youtube_dl
parentc31233454a47cc02f3ca5c0534520f828f70c7dd (diff)
downloadports-336c5e2d4e991802727754a4701ea51eb4326a95.tar.gz
ports-336c5e2d4e991802727754a4701ea51eb4326a95.zip
Notes
Diffstat (limited to 'www/youtube_dl')
-rw-r--r--www/youtube_dl/Makefile22
-rw-r--r--www/youtube_dl/pkg-descr2
-rw-r--r--www/youtube_dl/pkg-message6
3 files changed, 28 insertions, 2 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index 3e9c4cba1e57..9f5b93c885b8 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -8,7 +8,8 @@
PORTNAME= youtube_dl
PORTVERSION= 2012.02.27
CATEGORIES= www
-MASTER_SITES= https://raw.github.com/rg3/youtube-dl/${PORTVERSION}/
+MASTER_SITES= https://raw.github.com/rg3/youtube-dl/${PORTVERSION}/ \
+ CRITICAL
DISTNAME= youtube-dl
EXTRACT_SUFX= # empty
DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -17,13 +18,16 @@ EXTRACT_ONLY= # empty
MAINTAINER= araujo@FreeBSD.org
COMMENT= A program for downloading videos from YouTube.com
+LICENSE= GPLv2
+
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PYTHON_RUN= 2.5-2.7
PLIST_FILES= bin/youtube-dl
-OPTIONS= RTMPDUMP "Use RTMPDUMP to download rtmp video streams" on
+OPTIONS= RTMPDUMP "Use RTMPDUMP to download rtmp video streams" on \
+ FFMPEG "Use ffmpeg (required for audio conversion)" off
.include <bsd.port.options.mk>
@@ -31,10 +35,24 @@ OPTIONS= RTMPDUMP "Use RTMPDUMP to download rtmp video streams" on
RUN_DEPENDS+= rtmpdump:${PORTSDIR}/multimedia/rtmpdump
.endif
+.if defined(WITH_FFMPEG)
+# allow either multimedia/ffmpeg or multimedia/ffmpeg-devel
+. if exists(${LOCALBASE}/include/libavcodec/vda.h)
+RUN_DEPENDS+= ffprobe:${PORTSDIR}/multimedia/ffmpeg-devel
+. else
+RUN_DEPENDS+= ffprobe:${PORTSDIR}/multimedia/ffmpeg
+. endif
+.endif
+
post-extract:
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}/youtube-dl
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/youtube-dl ${PREFIX}/bin/youtube-dl
+.if defined(WITH_FFMPEG)
+post-install:
+ @${CAT} ${PKGMESSAGE}
+.endif
+
.include <bsd.port.mk>
diff --git a/www/youtube_dl/pkg-descr b/www/youtube_dl/pkg-descr
index badae7a97b2e..ce3495ffc103 100644
--- a/www/youtube_dl/pkg-descr
+++ b/www/youtube_dl/pkg-descr
@@ -1,3 +1,5 @@
youtube-dl is a small command-line program for downloading videos
from YouTube.com, metacafe.com, google video, photobucket videos,
yahoo videos, dailymotion and others
+
+WWW: https://github.com/rg3/youtube-dl
diff --git a/www/youtube_dl/pkg-message b/www/youtube_dl/pkg-message
new file mode 100644
index 000000000000..2bc3d068d784
--- /dev/null
+++ b/www/youtube_dl/pkg-message
@@ -0,0 +1,6 @@
+==============================================================================
+
+If you want to use mp3 audio conversion please make sure multimedia/ffmpeg or
+multimedia/ffmpeg-devel is built with the "LAME" option enabled.
+
+==============================================================================