aboutsummaryrefslogtreecommitdiff
path: root/www/youtube_dl
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-16 12:51:40 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-16 12:51:40 +0000
commit44d992cd7b29632577d04b8a4107dc3aa1b1062a (patch)
tree16d7d7efc97205c3cb023dfcb7608c0c16f09a9c /www/youtube_dl
parentd68f065c6695f4e8189b39b8d5ee4f47c307e452 (diff)
downloadports-44d992cd7b29632577d04b8a4107dc3aa1b1062a.tar.gz
ports-44d992cd7b29632577d04b8a4107dc3aa1b1062a.zip
Notes
Diffstat (limited to 'www/youtube_dl')
-rw-r--r--www/youtube_dl/Makefile34
-rw-r--r--www/youtube_dl/distinfo3
-rw-r--r--www/youtube_dl/files/patch-youtube-dl8
-rw-r--r--www/youtube_dl/pkg-descr4
4 files changed, 49 insertions, 0 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
new file mode 100644
index 000000000000..d4767f8fba03
--- /dev/null
+++ b/www/youtube_dl/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: youtube_dl
+# Date created: 2006-08-12
+# Whom: Pankov Pavel <pankov_p@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= youtube_dl
+PORTVERSION= 2006.08.13
+CATEGORIES= www
+MASTER_SITES= http://www.arrakis.es/~rggi3/youtube-dl/
+DISTFILES= youtube-dl-${PORTVERSION}
+EXTRACT_ONLY=
+
+MAINTAINER= pankov_p@mail.ru
+COMMENT= A program for downloading videos from YouTube.com
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+USE_PYTHON= 2.4+
+
+PLIST_FILES= bin/youtube-dl
+
+post-extract:
+ @${CP} ${DISTDIR}/youtube-dl-${PORTVERSION} ${WRKSRC}/youtube-dl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|g' ${WRKSRC}/youtube-dl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/youtube-dl ${TARGETDIR}/bin/youtube-dl
+
+.include <bsd.port.mk>
diff --git a/www/youtube_dl/distinfo b/www/youtube_dl/distinfo
new file mode 100644
index 000000000000..0c5a752f94cb
--- /dev/null
+++ b/www/youtube_dl/distinfo
@@ -0,0 +1,3 @@
+MD5 (youtube-dl-2006.08.13) = 383d8aa4f54127c62a0e4d898f77dbff
+SHA256 (youtube-dl-2006.08.13) = 15c1d75183383693d93010767c2baffc8922146fd0939629ef6d2853ca1ab274
+SIZE (youtube-dl-2006.08.13) = 9843
diff --git a/www/youtube_dl/files/patch-youtube-dl b/www/youtube_dl/files/patch-youtube-dl
new file mode 100644
index 000000000000..96338d469f27
--- /dev/null
+++ b/www/youtube_dl/files/patch-youtube-dl
@@ -0,0 +1,8 @@
+--- youtube-dl-orig Fri Aug 11 01:00:08 2006
++++ youtube-dl Sat Aug 12 13:46:38 2006
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!%%PYTHON_CMD%%
+ #
+ # Copyright (c) 2006 Ricardo Garcia Gonzalez
+ #
diff --git a/www/youtube_dl/pkg-descr b/www/youtube_dl/pkg-descr
new file mode 100644
index 000000000000..6ba1ee144dfe
--- /dev/null
+++ b/www/youtube_dl/pkg-descr
@@ -0,0 +1,4 @@
+youtube-dl is a small command-line program for downloading videos
+from YouTube.com.
+
+WWW: http://www.arrakis.es/~rggi3/youtube-dl/