aboutsummaryrefslogtreecommitdiff
path: root/www/zend-framework/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-03-11 19:12:02 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-03-11 19:12:02 +0000
commit4afd3f7f60de895230dca87c32867acc50dde1c7 (patch)
tree897bb0c9ed3ed152a41be96680de38de3351d732 /www/zend-framework/Makefile
parentf7c728bb1ece4bb48100dca7912e60677303e72f (diff)
downloadports-4afd3f7f60de895230dca87c32867acc50dde1c7.tar.gz
ports-4afd3f7f60de895230dca87c32867acc50dde1c7.zip
Notes
Diffstat (limited to 'www/zend-framework/Makefile')
-rw-r--r--www/zend-framework/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/www/zend-framework/Makefile b/www/zend-framework/Makefile
index be321a9ccb2b..930abf84b96f 100644
--- a/www/zend-framework/Makefile
+++ b/www/zend-framework/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ZendFramework
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= www
MASTER_SITES= http://framework.zend.com/releases/${DISTNAME}/ GENTOO/distfiles
@@ -16,8 +16,6 @@ COMMENT= A framework for developing PHP web applications
NO_BUILD= yes
USE_PHP= pcre spl
WANT_PHP_WEB= yes
-IGNORE_WITH_PHP=4
-
USE_GETTEXT= yes
SUB_FILES= pkg-message
@@ -33,6 +31,8 @@ OPTIONS= MYSQL "Install MySQL PDO support" Off \
.include <bsd.port.pre.mk>
+IGNORE_WITH_PHP=4
+
# Add all of the required and/or optional PHP extension dependencies,
# if chosen by the user.
#
@@ -40,15 +40,16 @@ OPTIONS= MYSQL "Install MySQL PDO support" Off \
# a table of what PHP extensions are required for what ZF classes.
.if defined(WITH_REQPHP)
-USE_PHP+= ctype curl dom gd iconv mbstring memcache \
- session simplexml soap xml zlib
+USE_PHP+= ctype curl dom gd hash iconv mbstring \
+ memcache pdo session simplexml soap xml zlib
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/apc.so:${PORTSDIR}/www/pecl-APC
.endif
.if defined(WITH_OPTPHP)
USE_PHP+= bcmath bitset json posix
.endif
.if defined(WITH_MYSQL)
-RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_mysql.so:${PORTSDIR}/databases/php5-pdo_mysql
+USE_PHP+= pdo_mysql
.endif
.if defined(WITH_DBLIB)
@@ -72,11 +73,16 @@ USE_PHP+= pdo_sqlite
.endif
do-install:
- @${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/ ${DATADIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${DATADIR}
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${DATADIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
+ ${DATADIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @${ECHO_CMD} '@exec ${FIND} ${DATADIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 644' >> ${TMPPLIST}
${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @${ECHO_CMD} '@exec ${FIND} ${DATADIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
post-install:
@${CAT} ${PKGMESSAGE}