aboutsummaryrefslogtreecommitdiff
path: root/www/ziproxy
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-05-02 16:52:11 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-05-02 16:52:11 +0000
commit1bdde3408d09f5a179d5e89b29109be29e889af3 (patch)
treee85ac7ec081dccdc168672150478516dbb4a64f3 /www/ziproxy
parenta42c5a148edeb6fef7898cab7e4116b9759f8b4f (diff)
Notes
Diffstat (limited to 'www/ziproxy')
-rw-r--r--www/ziproxy/Makefile27
-rw-r--r--www/ziproxy/distinfo6
-rw-r--r--www/ziproxy/files/patch-ziproxy.conf33
-rw-r--r--www/ziproxy/files/ziproxy.in2
-rw-r--r--www/ziproxy/pkg-plist9
5 files changed, 37 insertions, 40 deletions
diff --git a/www/ziproxy/Makefile b/www/ziproxy/Makefile
index 89d4dcad69cd..694a3c7e67ba 100644
--- a/www/ziproxy/Makefile
+++ b/www/ziproxy/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= ziproxy
-PORTVERSION= 2.7.2
-PORTREVISION= 2
+PORTVERSION= 3.0.0
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -21,17 +20,15 @@ USE_BZIP2= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-ERRORFILES= 400.html 403.html 404.html 407.html 408.html 409.html 500.html 503.html
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-cfgfile="${PREFIX}/etc/ziproxy/ziproxy.conf"
-PORTDOCS= README README.ru README.tools README.tools.ru JPEG2000.txt JPEG2000.ru.txt
+PORTDOCS= README README.tools JPEG2000.txt
MAN1= ziproxy.1 ziproxylogtool.1
-MANLANG= "" ru
MANCOMPRESSED= no
USE_RC_SUBR= ziproxy
@@ -40,24 +37,22 @@ SUB_FILES+= pkg-message
OPTIONS+= JPEG2000 "Build with JPEG2000 support" on
+ERROR_FILES= 400.html 403.html 404.html 407.html 408.html 409.html \
+ 500.html 503.html
+SAMPLE_CONFIG_FILES= bo_exception.list change_tos.list deny.list http.passwd \
+ noprocess.list replace.list replace_ct.list \
+ ziproxy.conf
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%DATADIR%%|${DATADIR}|g' \
${WRKSRC}/etc/ziproxy/ziproxy.conf
- @${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/src/image.c
- @${REINPLACE_CMD} -e 's|png_check_sig|png_sig_cmp|' \
- ${WRKSRC}/configure
post-install:
@${MKDIR} ${PREFIX}/etc/ziproxy
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/bo_exception.list ${PREFIX}/etc/ziproxy/bo_exception.list.sample
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/deny.list ${PREFIX}/etc/ziproxy/deny.list.sample
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/http.passwd ${PREFIX}/etc/ziproxy/http.passwd.sample
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/noprocess.list ${PREFIX}/etc/ziproxy/noprocess.list.sample
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/replace.list ${PREFIX}/etc/ziproxy/replace.list.sample
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/replace_ct.list ${PREFIX}/etc/ziproxy/replace_ct.list.sample
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/ziproxy.conf ${PREFIX}/etc/ziproxy/ziproxy.conf.sample
+.for FILE in ${SAMPLE_CONFIG_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/${FILE} ${PREFIX}/etc/ziproxy/${FILE}.sample
+.endfor
@if [ ! -f ${PREFIX}/etc/ziproxy/ziproxy.conf ]; then \
${CP} -p ${WRKSRC}/etc/ziproxy/ziproxy.conf ${PREFIX}/etc/ziproxy/ziproxy.conf ; \
fi
diff --git a/www/ziproxy/distinfo b/www/ziproxy/distinfo
index 9d4d1b3697ae..4b39616e7575 100644
--- a/www/ziproxy/distinfo
+++ b/www/ziproxy/distinfo
@@ -1,3 +1,3 @@
-MD5 (ziproxy-2.7.2.tar.bz2) = a0bc2e60a9c9e29556245b3f38faca0b
-SHA256 (ziproxy-2.7.2.tar.bz2) = 697e589343d2f7a145182511cdbc46c52e9e30a4f420e82f18e6549ced7b129a
-SIZE (ziproxy-2.7.2.tar.bz2) = 258257
+MD5 (ziproxy-3.0.0.tar.bz2) = f72c3859475fe8b119040f5f5f659ca0
+SHA256 (ziproxy-3.0.0.tar.bz2) = 05e74181d265e764a565a9f3567f53c254d364bb176bac0f5fa1bfe3facd7cb8
+SIZE (ziproxy-3.0.0.tar.bz2) = 257263
diff --git a/www/ziproxy/files/patch-ziproxy.conf b/www/ziproxy/files/patch-ziproxy.conf
index d4225c3764ff..10253c5661e2 100644
--- a/www/ziproxy/files/patch-ziproxy.conf
+++ b/www/ziproxy/files/patch-ziproxy.conf
@@ -1,5 +1,5 @@
---- etc/ziproxy/ziproxy.conf.orig 2009-03-13 17:41:27.000000000 +0300
-+++ etc/ziproxy/ziproxy.conf 2009-04-15 10:41:25.000000000 +0400
+--- etc/ziproxy/ziproxy.conf.orig 2010-03-08 12:23:20.000000000 +0300
++++ etc/ziproxy/ziproxy.conf 2010-03-12 23:51:38.000000000 +0300
@@ -12,12 +12,12 @@
## If you have more than one network interface,
## it's useful for restricting to which interface you want to bind to.
@@ -13,9 +13,18 @@
-# OnlyFrom = "127.0.0.1"
+OnlyFrom = "127.0.0.1"
- ## Inactivity timeout before closing the daemon (0 = no timeout)
- ## default: 0 (no timeout)
-@@ -82,7 +82,7 @@
+ ## Limits the number of simultaneous active user connections.
+ ## This does not affect the connection queue (see: SOMAXCONN).
+@@ -120,7 +120,7 @@
+ ## In order to match a whole site: "http://www.examplehost.xyz/*"
+ ##
+ ## Default: none
+-# TOSMarkAsDiffURL = "/etc/ziproxy/change_tos.list"
++# TOSMarkAsDiffURL = "%%PREFIX%%/etc/ziproxy/change_tos.list"
+
+ ## This is the content-type list of data that should
+ ## have their traffic "differentiated"
+@@ -261,7 +261,7 @@
## HTTP auth file
## Should contain user:pass pairs, lines no longer than 128 chars
## Password is unencrypted
@@ -24,7 +33,7 @@
## Forward everything to another proxy server.
## Modifications/compression is still applied.
-@@ -120,7 +120,7 @@
+@@ -299,7 +299,7 @@
## This option has no effect if BindOutgoing is not used.
## Default: empty, no hosts are exempted.
## See also: BindOutgoingExAddr
@@ -33,7 +42,7 @@
## Defines a specific IP to be bound to for hosts specified in BindOutgoingExList.
## As with BindOutgoing, this IP must be a local IP from the server running Ziproxy.
-@@ -429,7 +429,7 @@
+@@ -664,7 +664,7 @@
## *** THIS IS NOT SUPPOSED TO BE A DEFINITIVE SOLUTION TO INCOMPATIBILITIES ***
##
## Default: empty (no file specified, inactive)
@@ -42,7 +51,7 @@
## This option specifies a file containing a list of URLs which its
## data should be intercepted and replaced by another.
-@@ -448,7 +448,7 @@
+@@ -683,7 +683,7 @@
##
## Default: empty (no file specified, inactive)
## See also: URLReplaceDataCT
@@ -51,7 +60,7 @@
## Same as URLReplaceData, except it will only replace the data
## from matching URLs if the content-type matches
-@@ -462,7 +462,7 @@
+@@ -697,7 +697,7 @@
##
## Default: empty (no file specified, inactive)
## See also: URLReplaceDataCTList, URLReplaceData
@@ -59,8 +68,8 @@
+# URLReplaceDataCT = "%%PREFIX%%/etc/ziproxy/replace_ct.list"
## List of content-types to use with the URLReplaceDataCT option.
- ## Default: empty (no content-type specified, inactive)
-@@ -474,7 +474,7 @@
+ ## This option is required by URLReplaceDataCT.
+@@ -723,7 +723,7 @@
## A "access denied" 403 error will be returned when trying to access
## one of those URLs.
## Default: empty (no file specified, inactive)
@@ -69,7 +78,7 @@
## Custom HTTP Error Messages
## Define here the full path to the HTML file which should be
-@@ -482,21 +482,21 @@
+@@ -731,21 +731,21 @@
## Note: The internal defaults give more precise error messages.
##
## 400 - Bad request (malformed URL, or unknown URL type)
diff --git a/www/ziproxy/files/ziproxy.in b/www/ziproxy/files/ziproxy.in
index b56e4f9266c4..5ac45785b5e5 100644
--- a/www/ziproxy/files/ziproxy.in
+++ b/www/ziproxy/files/ziproxy.in
@@ -25,6 +25,6 @@ load_rc_config $name
: ${ziproxy_enable="NO"}
: ${ziproxy_config="%%PREFIX%%/etc/ziproxy/ziproxy.conf"}
-command_args="-d -c ${ziproxy_config} > ${pidfile}"
+command_args="-d -c ${ziproxy_config} --pid-file ${pidfile}"
run_rc_command "$1"
diff --git a/www/ziproxy/pkg-plist b/www/ziproxy/pkg-plist
index 78a6b26d5fb1..2bf307d498f1 100644
--- a/www/ziproxy/pkg-plist
+++ b/www/ziproxy/pkg-plist
@@ -3,6 +3,7 @@ bin/ziproxylogtool
bin/ziproxy_genhtml_stats.sh
@exec mkdir -p %D/etc/ziproxy
etc/ziproxy/bo_exception.list.sample
+etc/ziproxy/change_tos.list.sample
etc/ziproxy/deny.list.sample
etc/ziproxy/http.passwd.sample
etc/ziproxy/noprocess.list.sample
@@ -12,13 +13,5 @@ etc/ziproxy/replace_ct.list.sample
@exec if [ ! -f %D/etc/ziproxy/ziproxy.conf ] ; then cp -p %D/%F %B/ziproxy.conf; fi
etc/ziproxy/ziproxy.conf.sample
@dirrmtry etc/ziproxy
-%%DATADIR%%/error/400.html
-%%DATADIR%%/error/403.html
-%%DATADIR%%/error/404.html
-%%DATADIR%%/error/407.html
-%%DATADIR%%/error/408.html
-%%DATADIR%%/error/409.html
-%%DATADIR%%/error/500.html
-%%DATADIR%%/error/503.html
@dirrm %%DATADIR%%/error
@dirrm %%DATADIR%%