aboutsummaryrefslogtreecommitdiff
path: root/www/ziproxy
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-02-01 02:02:45 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-02-01 02:02:45 +0000
commit3321ddea240e8fe7af18c4320cc57f8234938a99 (patch)
treea7952e7de78bac26f8d59f1a9d6a26e6f8f94e62 /www/ziproxy
parent9fcf7c41ac6e393e55e2adba7272aaae73963598 (diff)
downloadports-3321ddea240e8fe7af18c4320cc57f8234938a99.tar.gz
ports-3321ddea240e8fe7af18c4320cc57f8234938a99.zip
Notes
Diffstat (limited to 'www/ziproxy')
-rw-r--r--www/ziproxy/Makefile20
-rw-r--r--www/ziproxy/distinfo6
-rw-r--r--www/ziproxy/files/patch-ziproxy.conf29
-rw-r--r--www/ziproxy/files/pkg-message.in14
-rw-r--r--www/ziproxy/files/ziproxy.in4
-rw-r--r--www/ziproxy/pkg-descr9
-rw-r--r--www/ziproxy/pkg-plist8
7 files changed, 46 insertions, 44 deletions
diff --git a/www/ziproxy/Makefile b/www/ziproxy/Makefile
index 1d90074e5098..aee55bd2376b 100644
--- a/www/ziproxy/Makefile
+++ b/www/ziproxy/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= ziproxy
-PORTVERSION= 2.4.3
+PORTVERSION= 2.5.0
CATEGORIES= www
MASTER_SITES= SF
@@ -26,12 +26,15 @@ ERRORFILES= 400.html 404.html 408.html 500.html 503.html
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-cfgfile="${PREFIX}/etc/ziproxy.conf"
+CONFIGURE_ARGS+= --with-cfgfile="${PREFIX}/etc/ziproxy/ziproxy.conf"
.if !defined(NOPORTDOCS)
PORTDOCS= README
.endif
+MAN1= ziproxy.1 ziproxylogtool.1
+MANCOMPRESSED= no
+
USE_RC_SUBR= ziproxy
SUB_FILES+= pkg-message
@@ -41,16 +44,13 @@ OPTIONS+= JPEG2000 "Build with JPEG2000 support" on
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%DATADIR%%|${DATADIR}|g' \
- ${WRKSRC}/etc/ziproxy.conf
-
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
+ ${WRKSRC}/etc/ziproxy/ziproxy.conf
post-install:
- @${MKDIR} ${PREFIX}/etc
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy.conf ${PREFIX}/etc/ziproxy.conf.sample
- @if [ ! -f ${PREFIX}/etc/ziproxy.conf ]; then \
- ${CP} -p ${WRKSRC}/etc/ziproxy.conf ${PREFIX}/etc/ziproxy.conf ; \
+ @${MKDIR} ${PREFIX}/etc/ziproxy
+ @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/ziproxy.conf ${PREFIX}/etc/ziproxy/ziproxy.conf.sample
+ @if [ ! -f ${PREFIX}/etc/ziproxy/ziproxy.conf ]; then \
+ ${CP} -p ${WRKSRC}/etc/ziproxy/ziproxy.conf ${PREFIX}/etc/ziproxy/ziproxy.conf ; \
fi
.if !defined(NOPORTDOCS)
diff --git a/www/ziproxy/distinfo b/www/ziproxy/distinfo
index ae7e6cce89d4..9008d58b61b2 100644
--- a/www/ziproxy/distinfo
+++ b/www/ziproxy/distinfo
@@ -1,3 +1,3 @@
-MD5 (ziproxy-2.4.3.tar.bz2) = ae174253ac582f6e2554b9325849de02
-SHA256 (ziproxy-2.4.3.tar.bz2) = 784cf1bc95190383af698719f505716f6bc66f8548011ac80460364d59231cfc
-SIZE (ziproxy-2.4.3.tar.bz2) = 177422
+MD5 (ziproxy-2.5.0.tar.bz2) = fc923195ef8dbb199d0d4b7e6061cf99
+SHA256 (ziproxy-2.5.0.tar.bz2) = 498fccdcdaa368a707b5f9780350db016a3dba90b4c1f764b0d00e0ae84d5765
+SIZE (ziproxy-2.5.0.tar.bz2) = 211216
diff --git a/www/ziproxy/files/patch-ziproxy.conf b/www/ziproxy/files/patch-ziproxy.conf
index 45e03311bae8..c6ca24b16e95 100644
--- a/www/ziproxy/files/patch-ziproxy.conf
+++ b/www/ziproxy/files/patch-ziproxy.conf
@@ -1,6 +1,6 @@
---- etc/ziproxy.conf.orig 2007-09-06 07:51:42.000000000 +0400
-+++ etc/ziproxy.conf 2007-09-15 13:31:16.000000000 +0400
-@@ -11,12 +11,12 @@
+--- etc/ziproxy/ziproxy.conf.orig Thu Jan 24 20:41:01 2008
++++ etc/ziproxy/ziproxy.conf Fri Feb 1 00:34:04 2008
+@@ -12,12 +12,12 @@
## If you have more than one network interface,
## it's useful for restricting to which interface you want to bind to.
## By default Ziproxy binds to all interfaces.
@@ -13,18 +13,27 @@
-# OnlyFrom = "127.0.0.1"
+OnlyFrom = "127.0.0.1"
- # Inactivity timeout before closing the daemon (0 = no timeout)
- NetdTimeout = 0
-@@ -50,7 +50,7 @@
+ ## Inactivity timeout before closing the daemon (0 = no timeout)
+ ## default: 0 (no timeout)
+@@ -67,7 +67,7 @@
## HTTP auth file
## Should contain user:pass pairs, lines no longer than 128 chars
## Password is unencrypted
--# PasswdFile="/usr/local/ziproxy/ziproxy.passwd"
-+# PasswdFile="%%PREFIX%%/etc/ziproxy.passwd"
+-# PasswdFile="/etc/ziproxy/http.passwd"
++# PasswdFile="%%PREFIX%%/etc/ziproxy/http.passwd"
## Forward everything to another proxy server.
## Modifications/compression is still applied.
-@@ -263,13 +263,13 @@
+@@ -371,7 +371,7 @@
+ ## *** THIS IS NOT SUPPOSED TO BE A DEFINITIVE SOLUTION TO INCOMPATIBILITIES ***
+ ##
+ ## Defauly: empty (no file specified, inactive)
+-# URLNoProcessing = "/etc/ziproxy/noprocess.list"
++# URLNoProcessing = "%%PREFIX%%/etc/ziproxy/noprocess.list"
+
+ ## Custom HTTP Error Messages
+ ## Define here the full path to the HTML file which should be
+@@ -379,15 +379,15 @@
## Note: The internal defaults give more precise error messages.
##
## 400 - Bad request (malformed URL, or unknown URL type)
@@ -43,3 +52,5 @@
-# CustomError503="/var/ziproxy/error/503.html"
+# CustomError503="%%DATADIR%%/error/503.html"
+
+
diff --git a/www/ziproxy/files/pkg-message.in b/www/ziproxy/files/pkg-message.in
index 9efb3ae7ab5d..4989f0ae8c4d 100644
--- a/www/ziproxy/files/pkg-message.in
+++ b/www/ziproxy/files/pkg-message.in
@@ -1,14 +1,2 @@
By default ziproxy is configured to accept connections on localhost only.
-Edit %%PREFIX%%/etc/ziproxy.conf to allow remote access.
-
-There is no man page yet, but information can be found in
-%%DOCSDIR%%/README.
-
-ziproxy can be started the following ways:
-o daemon mode:
- * add ziproxy_enable="YES" to your /etc/rc.conf
- * use rc(8) script %%PREFIX%%/etc/rc.d/ziproxy.sh
-o inetd mode:
- * add ``http-proxy 8080/tcp #HTTP Proxy'' to /etc/services
- * add ``http-proxy stream tcp nowait nobody /usr/local/bin/ziproxy ziproxy -i'' to your /etc/inetd.conf
- * reload inetd(8) config files by doing `/etc/rc.d/inetd reload`
+Edit %%PREFIX%%/etc/ziproxy/ziproxy.conf to allow remote access.
diff --git a/www/ziproxy/files/ziproxy.in b/www/ziproxy/files/ziproxy.in
index f2d766fd1df8..854c0e336a5a 100644
--- a/www/ziproxy/files/ziproxy.in
+++ b/www/ziproxy/files/ziproxy.in
@@ -8,7 +8,7 @@
#
# ziproxy_enable (bool): Set to NO by default.
# Set it to YES to enable ziproxy.
-# ziproxy_config (path): Set to %%PREFIX%%/etc/ziproxy.conf
+# ziproxy_config (path): Set to %%PREFIX%%/etc/ziproxy/ziproxy.conf
# by default.
#
@@ -23,7 +23,7 @@ pidfile=/var/run/${name}.pid
load_rc_config $name
: ${ziproxy_enable="NO"}
-: ${ziproxy_config="%%PREFIX%%/etc/ziproxy.conf"}
+: ${ziproxy_config="%%PREFIX%%/etc/ziproxy/ziproxy.conf"}
command_args="-d -c ${ziproxy_config} > ${pidfile}"
diff --git a/www/ziproxy/pkg-descr b/www/ziproxy/pkg-descr
index 2fff2d5615b0..a33b18194319 100644
--- a/www/ziproxy/pkg-descr
+++ b/www/ziproxy/pkg-descr
@@ -1,6 +1,7 @@
-Ziproxy is forwarding, non-caching, compressing proxy server. It
-squeezes images by converting them to low quality jpegs and
-optionally can also gzip HTML and other text-like data. It is
-intended to free bandwidth on dialup connections.
+Ziproxy is forwarding, non-caching, compressing HTTP proxy server.
+Basically it squeezes images by converting them to lower quality JPEGs or
+JPEG 2000 and compresses (gzip) HTML and other text-like data.
+It also provides other features such as: HTML/JS/CSS optimization, preemptive
+hostname resolution, transparent proxying and more.
WWW: http://ziproxy.sourceforge.net/
diff --git a/www/ziproxy/pkg-plist b/www/ziproxy/pkg-plist
index 65439e57ce4d..f74032e9c71b 100644
--- a/www/ziproxy/pkg-plist
+++ b/www/ziproxy/pkg-plist
@@ -1,9 +1,11 @@
bin/ziproxy
bin/ziproxylogtool
bin/ziproxy_genhtml_stats.sh
-@unexec if cmp -s %D/etc/ziproxy.conf.sample %D/etc/ziproxy.conf; then rm -f %D/etc/ziproxy.conf; fi
-@exec if [ ! -f %D/etc/ziproxy.conf ] ; then cp -p %D/%F %B/ziproxy.conf; fi
-etc/ziproxy.conf.sample
+@exec mkdir -p %D/etc/ziproxy
+@unexec if cmp -s %D/etc/ziproxy/ziproxy.conf.sample %D/etc/ziproxy/ziproxy.conf; then rm -f %D/etc/ziproxy/ziproxy.conf; fi
+@exec if [ ! -f %D/etc/ziproxy/ziproxy.conf ] ; then cp -p %D/%F %B/ziproxy.conf; fi
+etc/ziproxy/ziproxy.conf.sample
+@dirrmtry etc/ziproxy
%%DATADIR%%/error/400.html
%%DATADIR%%/error/404.html
%%DATADIR%%/error/408.html