aboutsummaryrefslogtreecommitdiff
path: root/www/zope-annotations/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-02 21:30:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-02 21:30:46 +0000
commitf109a281bf99109c4b9083f55a301509e87de591 (patch)
tree19e94f0b83ca3ab83962ff58ea0ff6bb012fd6a3 /www/zope-annotations/Makefile
parentdd97b75cb2a89ca5df4d296b6f7e62ab98c41b7a (diff)
downloadports-f109a281bf99109c4b9083f55a301509e87de591.tar.gz
ports-f109a281bf99109c4b9083f55a301509e87de591.zip
Notes
Diffstat (limited to 'www/zope-annotations/Makefile')
-rw-r--r--www/zope-annotations/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/www/zope-annotations/Makefile b/www/zope-annotations/Makefile
new file mode 100644
index 000000000000..ea13a3644364
--- /dev/null
+++ b/www/zope-annotations/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: Annotations
+# Date created: 30 Dec 2003
+# Whom: Tim Middleton
+#
+# $FreeBSD$
+#
+
+PORTNAME= annotations
+PORTVERSION= 0.4.3
+CATEGORIES= www zope
+MASTER_SITES= http://zope.org/Members/infrae/Annotations/Annotations-${PORTVERSION}/
+PKGNAMEPREFIX= zope-
+DISTNAME= Annotations-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= x@Vex.Net
+COMMENT= A generic way to add information to arbitrary Zope objects
+
+USE_PYTHON= yes
+USE_ZOPE= yes
+DIST_SUBDIR= zope
+
+ZOPEPRODUCTNAME=Annotations
+
+# yes, some of us are running zope on python 2.3
+#PYTHON_VERSION= python2.3
+
+# You can change this in the environment if you like.
+#SZOPEBASEDIR?= www/Zope
+
+PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTNAME}
+CPIO= cpio --quiet -pdum -R
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @ ${CHMOD} -R og+rX ${WRKSRC}/
+ @ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+ @ cd ${WRKSRC} && ${FIND} . \
+ | ${CPIO} ${BINOWN}:${BINGRP} \
+ ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>