aboutsummaryrefslogtreecommitdiff
path: root/www/zope-plonelanguagetool
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-05 18:20:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-05 18:20:25 +0000
commit1fc0a0157b2d48a3ce3a638cd309b253fcd73bb7 (patch)
treeadf40bca492415f5733a185991b5a4fe9151e31e /www/zope-plonelanguagetool
parent9975fcf45cfd292f1687d356e451f07d8ab70388 (diff)
downloadports-1fc0a0157b2d48a3ce3a638cd309b253fcd73bb7.tar.gz
ports-1fc0a0157b2d48a3ce3a638cd309b253fcd73bb7.zip
Notes
Diffstat (limited to 'www/zope-plonelanguagetool')
-rw-r--r--www/zope-plonelanguagetool/Makefile59
-rw-r--r--www/zope-plonelanguagetool/distinfo2
-rw-r--r--www/zope-plonelanguagetool/pkg-descr10
-rw-r--r--www/zope-plonelanguagetool/pkg-message24
4 files changed, 95 insertions, 0 deletions
diff --git a/www/zope-plonelanguagetool/Makefile b/www/zope-plonelanguagetool/Makefile
new file mode 100644
index 000000000000..44c7e3d13cd3
--- /dev/null
+++ b/www/zope-plonelanguagetool/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: zope-plonelanguagetool
+# Date created: July 4 2004
+# Whom: Khairil Yusof <kaeru@inigo-tech.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plonelanguagetool
+PORTVERSION= 0.4
+CATEGORIES= www zope
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= collective
+PKGNAMEPREFIX= zope-
+DISTNAME= PloneLanguageTool-${PORTVERSION}
+
+MAINTAINER= kaeru@inigo-tech.com
+COMMENT= PloneLanguageTool product for Zope
+
+RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/${ZOPEPRODUCTDIR}/CMFPlone/__init__.py:${PORTSDIR}/www/plone \
+ ${LOCALBASE}/${SZOPEBASEDIR}/${ZOPEPRODUCTDIR}/I18NLayer/__init__.py:${PORTSDIR}/www/zope-i18nlayer
+
+USE_PYTHON= yes
+USE_ZOPE= yes
+DIST_SUBDIR= zope
+
+EXTRACT_CMD= tar
+EXTRACT_BEFORE_ARGS= -zxvf
+EXTRACT_AFTER_ARGS= --exclude CVS
+
+ZOPEPRODUCTNAME= PloneLanguageTool
+
+PLIST= ${WRKDIR}/pkg-plist
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTNAME}
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -x skins ${WRKSRC}
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @${TOUCH} ${PLIST}
+ @cd ${WRKDIR} && \
+ for f in `${FIND} ${ZOPEPRODUCTNAME} -type f`; do \
+ ${ECHO_CMD} %%ZOPEPRODUCTDIR%%/$${f} >> ${PLIST}; \
+ done; \
+ for d in `${FIND} -d ${ZOPEPRODUCTNAME} -type d`; do \
+ ${ECHO_CMD} @dirrm %%ZOPEPRODUCTDIR%%/$${d} >> ${PLIST}; \
+ done; \
+
+do-install:
+ @${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/
+ @${CHMOD} -R og+rX ${WRKSRC}/
+ @${CP} -R ${WRKSRC} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/zope-plonelanguagetool/distinfo b/www/zope-plonelanguagetool/distinfo
new file mode 100644
index 000000000000..882d720f09da
--- /dev/null
+++ b/www/zope-plonelanguagetool/distinfo
@@ -0,0 +1,2 @@
+MD5 (zope/PloneLanguageTool-0.4.tar.gz) = 68505b6ec1ccad90c3992b51df9e231b
+SIZE (zope/PloneLanguageTool-0.4.tar.gz) = 51490
diff --git a/www/zope-plonelanguagetool/pkg-descr b/www/zope-plonelanguagetool/pkg-descr
new file mode 100644
index 000000000000..a95e02127586
--- /dev/null
+++ b/www/zope-plonelanguagetool/pkg-descr
@@ -0,0 +1,10 @@
+PloneLanguageTool is a product for Zope/CMF
+
+Provides a portal_languages tool that you can add to your Plone site in the
+ZMI. You can select the allowed and default languages and choose from a number
+of negotiation schemes.
+
+WWW: http://plone.org/collective
+
+- Khairil Yusof
+kaeru@inigo-tech.com
diff --git a/www/zope-plonelanguagetool/pkg-message b/www/zope-plonelanguagetool/pkg-message
new file mode 100644
index 000000000000..d0fb3f69fc46
--- /dev/null
+++ b/www/zope-plonelanguagetool/pkg-message
@@ -0,0 +1,24 @@
+To complete the installation of PloneLanguageTool:
+
+- Restart Zope. This may be done from the Zope Control Panel.
+
+With Plone (optional)
+
+- Use Plone Setup, to install PloneLanguageTool product.
+
+With CMFQuickInstaller (optional)
+
+- Use the QuickInstaller tool to register PloneLanguageTool in your portal
+ instance
+
+Without CMFQuickInstaller
+
+ - Create an ExternalMethod object inside your portal object with the
+ following data:
+
+ Id: install_PloneLanguageTool
+ Title: installs PloneLanguageTool to this portal
+ Module Name: PloneLanguageTool.Install
+ Function Name: install
+
+ - Run this newly created ExternalMethod by clicking on the test tab.