aboutsummaryrefslogtreecommitdiff
path: root/www/zope-xmlwidgets
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 05:01:56 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 05:01:56 +0000
commit497f3442f5f3253226f4d3d810bbf21adedb44a4 (patch)
tree0d44d55935a5a63ba4bfd6ca782eb3a950d99106 /www/zope-xmlwidgets
parent287542580099d95410013d2412d44ec60135be85 (diff)
downloadports-497f3442f5f3253226f4d3d810bbf21adedb44a4.tar.gz
ports-497f3442f5f3253226f4d3d810bbf21adedb44a4.zip
Notes
Diffstat (limited to 'www/zope-xmlwidgets')
-rw-r--r--www/zope-xmlwidgets/Makefile49
-rw-r--r--www/zope-xmlwidgets/distinfo1
-rw-r--r--www/zope-xmlwidgets/pkg-descr6
-rw-r--r--www/zope-xmlwidgets/pkg-message6
-rw-r--r--www/zope-xmlwidgets/pkg-plist36
5 files changed, 98 insertions, 0 deletions
diff --git a/www/zope-xmlwidgets/Makefile b/www/zope-xmlwidgets/Makefile
new file mode 100644
index 000000000000..76827d61f2ad
--- /dev/null
+++ b/www/zope-xmlwidgets/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: XMLWidgets
+# Date created: 3 Jul 2003
+# Whom: Tim Middleton
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlwidgets
+PORTVERSION= 0.9
+CATEGORIES= www zope
+MASTER_SITES= http://www.zope.org/Members/faassen/XMLWidgets/${PORTVERSION}/
+PKGNAMEPREFIX= zope-
+DISTNAME= XMLWidgets-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= x@Vex.Net
+COMMENT= XMLWidgets - dynamic translations of ParsedXML to HTML pages
+
+RUN_DEPENDS= ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/ParsedXML/__init__.py:${PORTSDIR}/www/zope-parsedxml
+
+USE_PYTHON= yes
+USE_ZOPE= yes
+DIST_SUBDIR= zope
+
+ZOPEPRODUCTNAME=XMLWidgets
+
+# yes, some of us are running zope on python 2.2
+PYTHON_VERSION= python2.2
+
+PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTNAME}
+CPIO= cpio --quiet -pdum -R
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @ ${CHMOD} -R og+rX ${WRKSRC}/
+ @ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+ @ cd ${WRKSRC} && ${FIND} . \
+ | ${CPIO} ${BINOWN}:${BINGRP} \
+ ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/zope-xmlwidgets/distinfo b/www/zope-xmlwidgets/distinfo
new file mode 100644
index 000000000000..3ec0705141e6
--- /dev/null
+++ b/www/zope-xmlwidgets/distinfo
@@ -0,0 +1 @@
+MD5 (zope/XMLWidgets-0.9.tgz) = 7272e9d95ba94b63ccd2a07f01ead805
diff --git a/www/zope-xmlwidgets/pkg-descr b/www/zope-xmlwidgets/pkg-descr
new file mode 100644
index 000000000000..031e1034901c
--- /dev/null
+++ b/www/zope-xmlwidgets/pkg-descr
@@ -0,0 +1,6 @@
+XMLWidgets is a Zope Product/Framework to create dynamic translations of
+ParsedXML documents to HTML pages. Each XML node is represented by a widget.
+A widget can display itself (to HTML), and handle user events (clicks, form
+submits) in the same HTML page.
+
+WWW: http://www.zope.org/Members/faassen/XMLWidgets
diff --git a/www/zope-xmlwidgets/pkg-message b/www/zope-xmlwidgets/pkg-message
new file mode 100644
index 000000000000..a16dcd690981
--- /dev/null
+++ b/www/zope-xmlwidgets/pkg-message
@@ -0,0 +1,6 @@
+To complete the installation of XMLWidgets:
+
+ - Restart Zope. This may be done from the Zope Control Panel.
+
+ - Verify that the XMLWidgets product is loaded properly by
+ examining them in Control_Panel/Products.
diff --git a/www/zope-xmlwidgets/pkg-plist b/www/zope-xmlwidgets/pkg-plist
new file mode 100644
index 000000000000..a59f8ebdd56d
--- /dev/null
+++ b/www/zope-xmlwidgets/pkg-plist
@@ -0,0 +1,36 @@
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/CREDITS.txt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/EditorService.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/HISTORY.txt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/INSTALL.txt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/LICENSE.txt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/README.txt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/WidgetDOM.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/WidgetPathScheme.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/WidgetRegistry.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/__init__.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/helpers.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/tests/__init__.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/tests/test_EditorCache.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/tests/test_EditorService.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/tests/test_all.py
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/tests/__init__.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/tests/test_EditorCache.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/tests/test_EditorService.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/tests/test_all.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/EditorService.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/WidgetDOM.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/WidgetPathScheme.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/WidgetRegistry.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/__init__.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/helpers.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/version.txt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/www/editorServiceAdd.zpt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/www/editorServiceInfoTab.zpt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/www/editor_service.gif
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/www/widgetRegistryAdd.zpt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/www/widgetRegistryInfoTab.zpt
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/www/widget_registry.gif
+%%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/www/widget_service.gif
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/www
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets/tests
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/XMLWidgets