aboutsummaryrefslogtreecommitdiff
path: root/www/zope211/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-16 00:02:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-16 00:02:25 +0000
commitbf01faeea1f0011fc692da98ed6e8541fe42d6b5 (patch)
tree9505b7a8dbeea040d613c8cda0914bda67e16412 /www/zope211/Makefile
parent397de7caa2daaa1144cddbfb10fa2e5d1fefc0d9 (diff)
downloadports-bf01faeea1f0011fc692da98ed6e8541fe42d6b5.tar.gz
ports-bf01faeea1f0011fc692da98ed6e8541fe42d6b5.zip
Notes
Diffstat (limited to 'www/zope211/Makefile')
-rw-r--r--www/zope211/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/www/zope211/Makefile b/www/zope211/Makefile
index 3d316c47ff12..1c4a6cdc148d 100644
--- a/www/zope211/Makefile
+++ b/www/zope211/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zope
-PORTVERSION= 2.7.2
+PORTVERSION= 2.7.3
CATEGORIES= www python zope
MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-0
@@ -73,6 +73,9 @@ post-install:
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/zope.sh > ${PREFIX}/etc/rc.d/zope.sh
@${CHMOD} ${BINMODE} ${PREFIX}/etc/rc.d/zope.sh
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/zeo.sh > ${PREFIX}/etc/rc.d/zeo.sh
+ @${CHMOD} ${BINMODE} ${PREFIX}/etc/rc.d/zeo.sh
@${MKDIR} ${ZOPEBASEDIR}/Products
@${CP} ${FILESDIR}/Products_00readme-freebsd.txt ${ZOPEBASEDIR}/Products/00readme-freebsd.txt
@${CAT} ${PKGMESSAGE}
@@ -88,6 +91,12 @@ instance:
@${SED} ${CONFIG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${FILESDIR}/instance_message
@${RM} -f ${ZOPEBASEDIR}/bin/copyzopeskel.pyc
+zeo:
+ @${ZOPEBASEDIR}/bin/mkzeoinstance.py ${ZOPEINSTANCEDIR}
+ @${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/var
+ @${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/log
+ @${SED} ${CONFIG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${FILESDIR}/zeo_message
+
pre-package:
@${SED} ${CONFIG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} < ${FILESDIR}/pkg-message.package.in \
> ${PKGMESSAGE}