aboutsummaryrefslogtreecommitdiff
path: root/www/zope213/Makefile
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-18 21:33:04 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-18 21:33:04 +0000
commit6b2c94a1a249771bc753e292d208b4619fd9ca2b (patch)
treed403701da93efd12cd068f67d200a212fe8857ae /www/zope213/Makefile
parentbdd5b1bf197e3250f4aeace796d3d293f7a2a419 (diff)
downloadports-6b2c94a1a249771bc753e292d208b4619fd9ca2b.tar.gz
ports-6b2c94a1a249771bc753e292d208b4619fd9ca2b.zip
Notes
Diffstat (limited to 'www/zope213/Makefile')
-rw-r--r--www/zope213/Makefile84
1 files changed, 46 insertions, 38 deletions
diff --git a/www/zope213/Makefile b/www/zope213/Makefile
index abe14f278f8d..e2047f80bf37 100644
--- a/www/zope213/Makefile
+++ b/www/zope213/Makefile
@@ -1,24 +1,24 @@
-# New ports collection makefile for: Zope
-# Date created: Sat 21 Aug 1999
-# Whom: Peter Cornelius <pcc@gmx.net>
+# New ports collection makefile for: Zope-2.8.x
+# Date created: Tue Sep 13 11:34:24 MSD 2005
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
#
# $FreeBSD$
#
PORTNAME= zope
-PORTVERSION= 2.7.7
+PORTVERSION= 2.8.1
CATEGORIES= www python zope
MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-final
EXTRACT_SUFX= .tgz
+DIST_SUBDIR= zope
-MAINTAINER= estartu@augusta.de
+MAINTAINER= dsh@vlink.ru
COMMENT= An object-based web application platform
-USE_PYTHON= 2.3
-USE_RC_SUBR= yes
+USE_PYTHON= yes
+USE_RC_SUBR= ${PORTNAME}.sh zeo.sh
USE_REINPLACE= yes
-DIST_SUBDIR= zope
# Note: the notes that follow reflect the decisions of prior maintainers
# of this port. IOW, don't blame me if you don't like the way it's done.
@@ -46,13 +46,12 @@ USE_GMAKE= yes
ALL_TARGET= build
MAKEFILE= makefile
+PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
- RC_SUBR=${RC_SUBR}
-CONFIG_SUB= ZOPEBASEDIR=${ZOPEBASEDIR} \
+SUB_FILES= instance_message package-pkg-message pkg-message zeo_message
+SUB_LIST= ZOPEBASEDIR=${ZOPEBASEDIR} \
ZOPE_USER=${ZOPE_USER} \
ZOPEINSTANCEDIR=${ZOPEINSTANCEDIR}
-PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(BATCH)
ISBATCH= -u admin:test123
@@ -61,44 +60,53 @@ ISBATCH= ""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ ${REINPLACE_CMD} \
+ -e 's,^\(ACCEPTABLE="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
-e 's,^\(TARGET="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
-e 's,^\(EXENAMES="\).*"$$,\1${PYTHON_VERSION}",g' \
${WRKSRC}/configure
post-install:
- @${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in ${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
- @${SED} ${CONFIG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} < ${FILESDIR}/pkg-message.in \
- > ${PKGMESSAGE}
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/zope.sh > ${PREFIX}/etc/rc.d/zope.sh
- @${CHMOD} ${BINMODE} ${PREFIX}/etc/rc.d/zope.sh
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/zeo.sh > ${PREFIX}/etc/rc.d/zeo.sh
- @${CHMOD} ${BINMODE} ${PREFIX}/etc/rc.d/zeo.sh
- @${MKDIR} ${ZOPEBASEDIR}/Products
- @${CP} ${FILESDIR}/Products_00readme-freebsd.txt ${ZOPEBASEDIR}/Products/00readme-freebsd.txt
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/
+ ${INSTALL_SCRIPT} ${WRKDIR}/zeo.sh ${PREFIX}/etc/rc.d/
+
+ ${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in \
+ ${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
+
+ ${MKDIR} ${ZOPEBASEDIR}/Products
+ ${CP} ${FILESDIR}/Products_00readme-freebsd.txt \
+ ${ZOPEBASEDIR}/Products/00readme-freebsd.txt
+
+ ${FIND} ${ZOPEBASEDIR} ! -type d | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ ${FIND} -d ${ZOPEBASEDIR} -type d | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
instance:
- @${ZOPEBASEDIR}/bin/mkzopeinstance.py -d ${ZOPEINSTANCEDIR} ${ISBATCH}
- @${SED} ${CONFIG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${FILESDIR}/zope.conf_changes | \
- ${PATCH} ${ZOPEINSTANCEDIR}/etc/zope.conf.sample
- @${RM} ${ZOPEINSTANCEDIR}/etc/zope.conf.sample.orig
- @${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/var
- @${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/log
- @${SED} ${CONFIG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${FILESDIR}/instance_message
- @${RM} -f ${ZOPEBASEDIR}/bin/copyzopeskel.pyc
+ ${ZOPEBASEDIR}/bin/mkzopeinstance.py -d ${ZOPEINSTANCEDIR} ${ISBATCH}
+
+ ${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/zope.conf_changes \
+ | ${PATCH} ${ZOPEINSTANCEDIR}/etc/zope.conf.sample
+
+ ${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/var
+ ${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/log
+
+ ${RM} ${ZOPEINSTANCEDIR}/etc/zope.conf.sample.orig
+ ${RM} -f ${ZOPEBASEDIR}/bin/copyzopeskel.pyc
+
+ @${CAT} ${WRKDIR}/instance_message
zeo:
- @${ZOPEBASEDIR}/bin/mkzeoinstance.py ${ZOPEINSTANCEDIR}
- @${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/var
- @${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/log
- @${SED} ${CONFIG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${FILESDIR}/zeo_message
+ ${ZOPEBASEDIR}/bin/mkzeoinstance.py ${ZOPEINSTANCEDIR}
+ ${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/var
+ ${CHOWN} ${ZOPE_USER} ${ZOPEINSTANCEDIR}/log
+ @${CAT} ${WRKDIR}/zeo_message
pre-package:
- @${SED} ${CONFIG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} < ${FILESDIR}/pkg-message.package.in \
- > ${PKGMESSAGE}
+ ${CP} ${WRKDIR}/package-pkg-message ${PKGMESSAGE}
.include <bsd.port.mk>