aboutsummaryrefslogtreecommitdiff
path: root/www/zope3/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-04-05 01:16:11 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-04-05 01:16:11 +0000
commit52d912f09a1c406890ec3f22ef71dcf892ea93e8 (patch)
tree09087d215b2972ef294a20a49946fac09e5f48a0 /www/zope3/Makefile
parent90ef065a9afc293e32f35e64311bbe0a1f46d621 (diff)
Notes
Diffstat (limited to 'www/zope3/Makefile')
-rw-r--r--www/zope3/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/www/zope3/Makefile b/www/zope3/Makefile
index 79b62d04bdf5..93db772179fa 100644
--- a/www/zope3/Makefile
+++ b/www/zope3/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= zope
-PORTVERSION= 3.2.0
+PORTVERSION= 3.2.1
CATEGORIES= www python zope
-MASTER_SITES= http://www.zope.org/Products/Zope3/${PORTVERSION}final/
+MASTER_SITES= http://www.zope.org/Products/Zope3/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= zope
@@ -30,11 +30,12 @@ SZOPEBASEDIR?= ${WEBBASEDIR}/Zope3
# Do not change anything below this line.
-ZOPEBASEDIR= ${PREFIX}/${SZOPEBASEDIR}
+ZOPEBASEDIR= ${PREFIX}/${SZOPEBASEDIR}
-ALL_TARGET=
+ALL_TARGET= # empty
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${ZOPEBASEDIR} --force
+CONFIGURE_ARGS= --force --prefix=${ZOPEBASEDIR} \
+ --with-python=${PYTHON_CMD}
PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
@@ -43,12 +44,11 @@ SUB_LIST= ZOPEBASEDIR=${ZOPEBASEDIR}
post-patch:
.for i in zdaemon zope
- ${RM} -f ${WRKSRC}/Zope/zopeskel/etc/${i}.conf.in.orig
+ @${RM} -f ${WRKSRC}/Zope/zopeskel/etc/${i}.conf.in.orig
.endfor
post-install:
- ${FIND} ${ZOPEBASEDIR} -type f -print0 | ${XARGS} -0 -- ${CHMOD} a-w
-
+ @${FIND} ${ZOPEBASEDIR} -type f -print0 | ${XARGS} -0 -- ${CHMOD} a-w
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}