aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2011-07-07 13:54:06 +0000
committerSofian Brabez <sbz@FreeBSD.org>2011-07-07 13:54:06 +0000
commit166c6d8d6a2709e0eb9cd013a9e0c05e06e6aba2 (patch)
treea4362ad4c496e4db0b48608764c2fd9ed8c90789 /www
parent2d2f5053a0344684d91b037045d882eb35f59f9d (diff)
downloadports-166c6d8d6a2709e0eb9cd013a9e0c05e06e6aba2.tar.gz
ports-166c6d8d6a2709e0eb9cd013a9e0c05e06e6aba2.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/roundup/Makefile14
-rw-r--r--www/roundup/distinfo4
-rw-r--r--www/roundup/pkg-plist99
3 files changed, 102 insertions, 15 deletions
diff --git a/www/roundup/Makefile b/www/roundup/Makefile
index 320534599b6a..f6ecd05c3455 100644
--- a/www/roundup/Makefile
+++ b/www/roundup/Makefile
@@ -6,20 +6,23 @@
#
PORTNAME= roundup
-PORTVERSION= 1.4.16
+PORTVERSION= 1.4.18
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
MAINTAINER= sbz@FreeBSD.org
COMMENT= An Issue-Tracking System for Knowledge Workers
+LICENSE= PSFL
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-USE_GETTEXT= yes
OPTIONS= SQLITE "Support Sqlite as backend" on
OPTIONS+= PGSQL "Support posggresql as backend" off
OPTIONS+= MYSQL "Support mysql as backend" off
+OPTIONS+= NLS "Native Language Support" on
.include <bsd.port.pre.mk>
@@ -39,6 +42,13 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopgmodule.so:${PORTSDIR}/databases/py-psy
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment"
+.endif
+
.if !defined(NO_INSTALL_MANPAGES)
MAN1= roundup-admin.1 roundup-demo.1 roundup-mailgw.1 \
roundup-server.1
diff --git a/www/roundup/distinfo b/www/roundup/distinfo
index 1a0724a6c88d..9f0327e8423d 100644
--- a/www/roundup/distinfo
+++ b/www/roundup/distinfo
@@ -1,2 +1,2 @@
-SHA256 (roundup-1.4.16.tar.gz) = 496602769b8338718eb90efca7bca61bf228b4d6650533d353abb1f225345dcf
-SIZE (roundup-1.4.16.tar.gz) = 1444546
+SHA256 (roundup-1.4.18.tar.gz) = 993434286eb64e1f553c31d57b8bb3a72a5b1472a7845a0a7d40a9674a29e335
+SIZE (roundup-1.4.18.tar.gz) = 2526143
diff --git a/www/roundup/pkg-plist b/www/roundup/pkg-plist
index 89cadaae3ccd..25525140b495 100644
--- a/www/roundup/pkg-plist
+++ b/www/roundup/pkg-plist
@@ -23,6 +23,9 @@ bin/roundup-xmlrpc-server
%%PYTHON_SITELIBDIR%%/roundup/anypy/dbm_.py
%%PYTHON_SITELIBDIR%%/roundup/anypy/dbm_.pyc
%%PYTHON_SITELIBDIR%%/roundup/anypy/dbm_.pyo
+%%PYTHON_SITELIBDIR%%/roundup/anypy/email_.py
+%%PYTHON_SITELIBDIR%%/roundup/anypy/email_.pyc
+%%PYTHON_SITELIBDIR%%/roundup/anypy/email_.pyo
%%PYTHON_SITELIBDIR%%/roundup/anypy/hashlib_.py
%%PYTHON_SITELIBDIR%%/roundup/anypy/hashlib_.pyc
%%PYTHON_SITELIBDIR%%/roundup/anypy/hashlib_.pyo
@@ -197,6 +200,9 @@ bin/roundup-xmlrpc-server
%%PYTHON_SITELIBDIR%%/roundup/cgi/zLOG.py
%%PYTHON_SITELIBDIR%%/roundup/cgi/zLOG.pyc
%%PYTHON_SITELIBDIR%%/roundup/cgi/zLOG.pyo
+%%PYTHON_SITELIBDIR%%/roundup/cgi/KeywordsExpr.py
+%%PYTHON_SITELIBDIR%%/roundup/cgi/KeywordsExpr.pyc
+%%PYTHON_SITELIBDIR%%/roundup/cgi/KeywordsExpr.pyo
%%PYTHON_SITELIBDIR%%/roundup/configuration.py
%%PYTHON_SITELIBDIR%%/roundup/configuration.pyc
%%PYTHON_SITELIBDIR%%/roundup/configuration.pyo
@@ -278,17 +284,18 @@ bin/roundup-xmlrpc-server
%%PYTHON_SITELIBDIR%%/roundup/xmlrpc.py
%%PYTHON_SITELIBDIR%%/roundup/xmlrpc.pyc
%%PYTHON_SITELIBDIR%%/roundup/xmlrpc.pyo
-share/locale/de/LC_MESSAGES/roundup.mo
-share/locale/en/LC_MESSAGES/roundup.mo
-share/locale/es/LC_MESSAGES/roundup.mo
-share/locale/fr/LC_MESSAGES/roundup.mo
-share/locale/hu/LC_MESSAGES/roundup.mo
-share/locale/it/LC_MESSAGES/roundup.mo
-share/locale/ja/LC_MESSAGES/roundup.mo
-share/locale/lt/LC_MESSAGES/roundup.mo
-share/locale/ru/LC_MESSAGES/roundup.mo
-share/locale/zh_CN/LC_MESSAGES/roundup.mo
-share/locale/zh_TW/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/de/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/en/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/es/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/it/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/roundup.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/roundup.mo
%%DATADIR%%/cgi-bin/roundup.cgi
%%DATADIR%%/templates/classic/TEMPLATE-INFO.txt
%%DATADIR%%/templates/classic/detectors/messagesummary.py
@@ -306,6 +313,7 @@ share/locale/zh_TW/LC_MESSAGES/roundup.mo
%%DATADIR%%/templates/classic/html/_generic.help.html
%%DATADIR%%/templates/classic/html/_generic.index.html
%%DATADIR%%/templates/classic/html/_generic.item.html
+%%DATADIR%%/templates/classic/html/_generic.keywords_expr.html
%%DATADIR%%/templates/classic/html/file.index.html
%%DATADIR%%/templates/classic/html/file.item.html
%%DATADIR%%/templates/classic/html/help.html
@@ -332,6 +340,71 @@ share/locale/zh_TW/LC_MESSAGES/roundup.mo
%%DATADIR%%/templates/classic/html/user_utils.js
%%DATADIR%%/templates/classic/initial_data.py
%%DATADIR%%/templates/classic/schema.py
+%%DATADIR%%/templates/devel/detectors/userauditor.py
+%%DATADIR%%/templates/devel/detectors/no_texthtml.py
+%%DATADIR%%/templates/devel/detectors/nosyreaction.py
+%%DATADIR%%/templates/devel/detectors/severityauditor.py
+%%DATADIR%%/templates/devel/detectors/messagesummary.py
+%%DATADIR%%/templates/devel/detectors/statusauditor.py
+%%DATADIR%%/templates/devel/detectors/patches.py
+%%DATADIR%%/templates/devel/html/user_utils.js
+%%DATADIR%%/templates/devel/html/style.css
+%%DATADIR%%/templates/devel/html/_generic.help-submit.html
+%%DATADIR%%/templates/devel/html/bug.item.html
+%%DATADIR%%/templates/devel/html/keyword.item.html
+%%DATADIR%%/templates/devel/html/file.item.html
+%%DATADIR%%/templates/devel/html/keyword.index.html
+%%DATADIR%%/templates/devel/html/user.index.html
+%%DATADIR%%/templates/devel/html/user.help.html
+%%DATADIR%%/templates/devel/html/milestone.index.html
+%%DATADIR%%/templates/devel/html/jquery.js
+%%DATADIR%%/templates/devel/html/_generic.collision.html
+%%DATADIR%%/templates/devel/html/query.js
+%%DATADIR%%/templates/devel/html/home.classlist.html
+%%DATADIR%%/templates/devel/html/_generic.index.html
+%%DATADIR%%/templates/devel/html/_generic.help.html
+%%DATADIR%%/templates/devel/html/_generic.help-empty.html
+%%DATADIR%%/templates/devel/html/page.html
+%%DATADIR%%/templates/devel/html/task.search.html
+%%DATADIR%%/templates/devel/html/_generic.item.html
+%%DATADIR%%/templates/devel/html/home.html
+%%DATADIR%%/templates/devel/html/_generic.query.html
+%%DATADIR%%/templates/devel/html/user.rego_progress.html
+%%DATADIR%%/templates/devel/html/bug.index.html
+%%DATADIR%%/templates/devel/html/query.edit.html
+%%DATADIR%%/templates/devel/html/query.html
+%%DATADIR%%/templates/devel/html/query.item.html
+%%DATADIR%%/templates/devel/html/help.css
+%%DATADIR%%/templates/devel/html/_generic.help-list.html
+%%DATADIR%%/templates/devel/html/tracker.css
+%%DATADIR%%/templates/devel/html/user.register.html
+%%DATADIR%%/templates/devel/html/msg.item.html
+%%DATADIR%%/templates/devel/html/msg.index.html
+%%DATADIR%%/templates/devel/html/user.forgotten.html
+%%DATADIR%%/templates/devel/html/milestone.item.html
+%%DATADIR%%/templates/devel/html/patch.item.html
+%%DATADIR%%/templates/devel/html/help_controls.js
+%%DATADIR%%/templates/devel/html/user.help-search.html
+%%DATADIR%%/templates/devel/html/file.index.html
+%%DATADIR%%/templates/devel/html/task.item.html
+%%DATADIR%%/templates/devel/html/task.index.html
+%%DATADIR%%/templates/devel/html/_generic.help-search.html
+%%DATADIR%%/templates/devel/html/_generic.calendar.html
+%%DATADIR%%/templates/devel/html/favicon.ico
+%%DATADIR%%/templates/devel/html/user.item.html
+%%DATADIR%%/templates/devel/html/_generic.keywords_expr.html
+%%DATADIR%%/templates/devel/html/bug.search.html
+%%DATADIR%%/templates/devel/html/help.html
+%%DATADIR%%/templates/devel/html/_generic.404.html
+%%DATADIR%%/templates/devel/html/patch.index.html
+%%DATADIR%%/templates/devel/config.ini
+%%DATADIR%%/templates/devel/initial_data.py
+%%DATADIR%%/templates/devel/TEMPLATE-INFO.txt
+%%DATADIR%%/templates/devel/extensions/local_replace.py
+%%DATADIR%%/templates/devel/extensions/spambayes.py
+%%DATADIR%%/templates/devel/extensions/timestamp.py
+%%DATADIR%%/templates/devel/extensions/timezone.py
+%%DATADIR%%/templates/devel/schema.py
%%DATADIR%%/templates/minimal/TEMPLATE-INFO.txt
%%DATADIR%%/templates/minimal/detectors/userauditor.py
%%DATADIR%%/templates/minimal/extensions/README.txt
@@ -356,6 +429,10 @@ share/locale/zh_TW/LC_MESSAGES/roundup.mo
@dirrm %%DATADIR%%/templates/minimal/extensions
@dirrm %%DATADIR%%/templates/minimal/detectors
@dirrm %%DATADIR%%/templates/minimal
+@dirrm %%DATADIR%%/templates/devel/html
+@dirrm %%DATADIR%%/templates/devel/detectors
+@dirrm %%DATADIR%%/templates/devel/extensions
+@dirrm %%DATADIR%%/templates/devel
@dirrm %%DATADIR%%/templates/classic/html
@dirrm %%DATADIR%%/templates/classic/extensions
@dirrm %%DATADIR%%/templates/classic/detectors