aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-11-03 15:09:23 +0000
committerSteve Wills <swills@FreeBSD.org>2011-11-03 15:09:23 +0000
commit5a1afee1cd1aa43c747e225631147aea4ae257a3 (patch)
treec2bda2079269e3e8cc07b3e80405fb6057c1792d /www
parent1e3b828ac67195ea9aa938e6c816cedd9b8c1e56 (diff)
downloadports-5a1afee1cd1aa43c747e225631147aea4ae257a3.tar.gz
ports-5a1afee1cd1aa43c747e225631147aea4ae257a3.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mod_pagespeed/Makefile2
-rw-r--r--www/mod_pagespeed/distinfo4
-rw-r--r--www/mod_pagespeed/files/patch-common.h12
-rw-r--r--www/mod_pagespeed/files/patch-debugger_posix.cc11
-rw-r--r--www/mod_pagespeed/files/patch-install_apxs.sh46
-rw-r--r--www/mod_pagespeed/files/patch-libpng_image_library.cc11
-rw-r--r--www/mod_pagespeed/files/patch-make.py14
-rw-r--r--www/mod_pagespeed/files/patch-pthread_rw_lock.cc13
-rw-r--r--www/mod_pagespeed/files/patch-pthread_shared_mem.cc79
-rw-r--r--www/mod_pagespeed/files/patch-ptypes.h95
-rw-r--r--www/mod_pagespeed/files/patch-python_arch.sh11
-rw-r--r--www/mod_pagespeed/files/patch-resource_manager_test.cc11
-rw-r--r--www/mod_pagespeed/files/patch-utypes.h8
13 files changed, 98 insertions, 219 deletions
diff --git a/www/mod_pagespeed/Makefile b/www/mod_pagespeed/Makefile
index 669913c77e7a..b9825eb3dbf0 100644
--- a/www/mod_pagespeed/Makefile
+++ b/www/mod_pagespeed/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mod_pagespeed
-PORTVERSION= 20110927
+PORTVERSION= 20111031
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= swills
diff --git a/www/mod_pagespeed/distinfo b/www/mod_pagespeed/distinfo
index 087623aa204b..7df565fa4d8b 100644
--- a/www/mod_pagespeed/distinfo
+++ b/www/mod_pagespeed/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mod_pagespeed_source_20110927.tar.xz) = 6a81d2d24ad3726861b44626a259e0722bbf6ea86a78cd20ae4ceac58e596fb3
-SIZE (mod_pagespeed_source_20110927.tar.xz) = 11240812
+SHA256 (mod_pagespeed_source_20111031.tar.xz) = e81b8566ec5591aea2804637ab10492f99882e134a1b59f384fe8e0f8497b054
+SIZE (mod_pagespeed_source_20111031.tar.xz) = 12390600
diff --git a/www/mod_pagespeed/files/patch-common.h b/www/mod_pagespeed/files/patch-common.h
index 1b0cf11a6e80..cbdbc417baf0 100644
--- a/www/mod_pagespeed/files/patch-common.h
+++ b/www/mod_pagespeed/files/patch-common.h
@@ -1,11 +1,13 @@
---- third_party/protobuf/src/google/protobuf/stubs/common.h.orig
-+++ third_party/protobuf/src/google/protobuf/stubs/common.h
-@@ -47,6 +47,8 @@
+--- third_party/protobuf/src/google/protobuf/stubs/common.h.orig 2011-10-31 14:25:22.000000000 +0000
++++ third_party/protobuf/src/google/protobuf/stubs/common.h 2011-10-31 17:54:21.000000000 +0000
+@@ -47,6 +47,10 @@
#elif !defined(_MSC_VER)
#include <stdint.h>
#endif
++#if defined(__FreeBSD__)
+#undef major
+#undef minor
++#endif
- #if defined(_WIN32) && defined(GetMessage)
- // Allow GetMessage to be used as a valid method name in protobuf classes.
+ #if defined(_MSC_VER) && defined(_CPPUNWIND)
+ #define PROTOBUF_USE_EXCEPTIONS
diff --git a/www/mod_pagespeed/files/patch-debugger_posix.cc b/www/mod_pagespeed/files/patch-debugger_posix.cc
deleted file mode 100644
index f2416896535f..000000000000
--- a/www/mod_pagespeed/files/patch-debugger_posix.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- third_party/chromium/src/base/debug/debugger_posix.cc.orig
-+++ third_party/chromium/src/base/debug/debugger_posix.cc
-@@ -137,7 +137,7 @@
-
- #elif defined(OS_FREEBSD)
-
--bool DebugUtil::BeingDebugged() {
-+bool BeingDebugged() {
- // TODO(benl): can we determine this under FreeBSD?
- NOTIMPLEMENTED();
- return false;
diff --git a/www/mod_pagespeed/files/patch-install_apxs.sh b/www/mod_pagespeed/files/patch-install_apxs.sh
deleted file mode 100644
index 325535a7f8af..000000000000
--- a/www/mod_pagespeed/files/patch-install_apxs.sh
+++ /dev/null
@@ -1,46 +0,0 @@
---- install/install_apxs.sh.orig 2011-09-28 01:19:38.000000000 +0000
-+++ install/install_apxs.sh 2011-09-29 14:24:06.000000000 +0000
-@@ -84,7 +84,7 @@
- if [ ! -z "${APACHE_CONF_LINE}" ]; then
- local SED_REGEX="s/^.*${1}=?[\"\'\ ]*//"
- EXTRACTED_COMPILE_SETTING=$(echo "${APACHE_CONF_LINE}" |
-- sed -r "${SED_REGEX}" |
-+ sed -E "${SED_REGEX}" |
- sed "s/[\"\'\ ]*$//")
- fi
- }
-@@ -149,7 +149,7 @@
- APACHE_USER_LINE=$(egrep -i "^[[:blank:]]*User[[:blank:]]+" "${APACHE_CONF_FILE}")
- if [ ! -z "${APACHE_USER_LINE}" ]; then
- APACHE_USER=$(echo "${APACHE_USER_LINE}" |
-- sed -r s/^.*User[[:blank:]]+[\"\']*// |
-+ sed -E s/^.*User[[:blank:]]+[\"\']*// |
- sed s/[\"\'[:blank:]]*$//)
- fi
- fi
-@@ -159,7 +159,7 @@
- APACHE_GROUP_LINE=$(egrep -i "^[[:blank:]]*Group[[:blank:]]+" "${APACHE_CONF_FILE}")
- if [ ! -z "${APACHE_GROUP_LINE}" ]; then
- APACHE_GROUP=$(echo "${APACHE_GROUP_LINE}" |
-- sed -r s/^.*Group[[:blank:]]+[\"\']*// |
-+ sed -E s/^.*Group[[:blank:]]+[\"\']*// |
- sed s/[\"\'[:blank:]]*$//)
- fi
- fi
-@@ -180,11 +180,11 @@
-
- echo "mod_pagespeed needs to cache optimized resources on the file system."
- echo "The default location for this cache is '${MODPAGESPEED_CACHE_ROOT}'."
--read -p "Would you like to specify a different location? (y/N) " -n1 PROMPT
--if [ "${PROMPT}" = "y" -o "${PROMPT}" = "Y" ]; then
-- echo ""
-- read -p "Location for mod_pagespeed file cache: " MODPAGESPEED_CACHE_ROOT
--fi
-+#read -p "Would you like to specify a different location? (y/N) " -n1 PROMPT
-+#if [ "${PROMPT}" = "y" -o "${PROMPT}" = "Y" ]; then
-+# echo ""
-+# read -p "Location for mod_pagespeed file cache: " MODPAGESPEED_CACHE_ROOT
-+#fi
-
- if [ -z "${MODPAGESPEED_CACHE_ROOT}" ]; then
- echo ""
diff --git a/www/mod_pagespeed/files/patch-libpng_image_library.cc b/www/mod_pagespeed/files/patch-libpng_image_library.cc
index ebe8f5ae56c4..62ef3499bcd1 100644
--- a/www/mod_pagespeed/files/patch-libpng_image_library.cc
+++ b/www/mod_pagespeed/files/patch-libpng_image_library.cc
@@ -1,11 +1,14 @@
---- net/instaweb/spriter/libpng_image_library.cc.orig 2011-09-29 17:45:52.000000000 +0000
-+++ net/instaweb/spriter/libpng_image_library.cc 2011-09-29 17:46:17.000000000 +0000
-@@ -235,7 +235,7 @@
+--- net/instaweb/spriter/libpng_image_library.cc.orig 2011-10-31 14:25:06.000000000 +0000
++++ net/instaweb/spriter/libpng_image_library.cc 2011-10-31 18:18:29.000000000 +0000
+@@ -235,7 +235,11 @@
png_set_palette_to_rgb(png_struct);
}
if ((color_type == PNG_COLOR_TYPE_GRAY) && (bit_depth < 8)) {
-- png_set_gray_1_2_4_to_8(png_struct);
++#if ((PNG_LIBPNG_VER_MAJOR==1 && PNG_LIBPNG_VER_MINOR>=4) || PNG_LIBPNG_VER_MAJOR>1)
+ png_set_expand_gray_1_2_4_to_8(png_struct);
++#else
+ png_set_gray_1_2_4_to_8(png_struct);
++#endif
}
if (png_get_valid(png_struct, png_info, PNG_INFO_tRNS)) {
png_set_tRNS_to_alpha(png_struct);
diff --git a/www/mod_pagespeed/files/patch-make.py b/www/mod_pagespeed/files/patch-make.py
index 40bebca42d17..dfef3c63ec7b 100644
--- a/www/mod_pagespeed/files/patch-make.py
+++ b/www/mod_pagespeed/files/patch-make.py
@@ -1,9 +1,9 @@
---- tools/gyp/pylib/gyp/generator/make.py.orig 2011-09-29 21:00:14.000000000 +0000
-+++ tools/gyp/pylib/gyp/generator/make.py 2011-09-29 21:00:28.000000000 +0000
-@@ -153,11 +153,11 @@
- ARFLAGS.target := $(call detect_arflags,target)
- endif
-
+--- tools/gyp/pylib/gyp/generator/make.py.orig Mon Oct 31 10:37:12 2011
++++ tools/gyp/pylib/gyp/generator/make.py Mon Oct 31 10:39:06 2011
+@@ -129,11 +129,11 @@
+ # in gyp's make.py where ARFLAGS.host etc. is computed.
+ # TODO(evan): move all cross-compilation logic to gyp-time so we don't need
+ # to replicate this environment fallback in make as well.
-CC.host ?= gcc
+CC.host ?= cc
CFLAGS.host ?=
@@ -14,4 +14,4 @@
+LINK.host ?= c++
LDFLAGS.host ?=
AR.host ?= ar
- # See the description for ARFLAGS.target.
+ ARFLAGS.host := %(ARFLAGS.host)s
diff --git a/www/mod_pagespeed/files/patch-pthread_rw_lock.cc b/www/mod_pagespeed/files/patch-pthread_rw_lock.cc
new file mode 100644
index 000000000000..67fba1b2a198
--- /dev/null
+++ b/www/mod_pagespeed/files/patch-pthread_rw_lock.cc
@@ -0,0 +1,13 @@
+--- net/instaweb/util/pthread_rw_lock.cc.orig 2011-10-31 15:25:58.000000000 +0000
++++ net/instaweb/util/pthread_rw_lock.cc 2011-10-31 15:30:18.000000000 +0000
+@@ -27,8 +27,10 @@
+ // New writer lock call is given preference over existing reader lock calls,
+ // so that writer lock call will never get starved. However, it is not allowed
+ // if there exists any recursive reader lock call to prevent deadlocks.
++#ifdef PTHREAD_RWLOCK_PREFER_WRITER_NONRECURSIVE_NP
+ pthread_rwlockattr_setkind_np(&attr_,
+ PTHREAD_RWLOCK_PREFER_WRITER_NONRECURSIVE_NP);
++#endif
+ pthread_rwlock_init(&rwlock_, &attr_);
+ }
+
diff --git a/www/mod_pagespeed/files/patch-pthread_shared_mem.cc b/www/mod_pagespeed/files/patch-pthread_shared_mem.cc
index bebdf4f3fd46..ba24875fb652 100644
--- a/www/mod_pagespeed/files/patch-pthread_shared_mem.cc
+++ b/www/mod_pagespeed/files/patch-pthread_shared_mem.cc
@@ -1,19 +1,23 @@
---- net/instaweb/util/pthread_shared_mem.cc.orig
-+++ net/instaweb/util/pthread_shared_mem.cc
-@@ -24,6 +24,7 @@
+--- net/instaweb/util/pthread_shared_mem.cc.orig 2011-10-31 14:25:06.000000000 +0000
++++ net/instaweb/util/pthread_shared_mem.cc 2011-10-31 22:04:15.000000000 +0000
+@@ -24,6 +24,9 @@
#include <cstddef>
#include <map>
#include <utility>
++#if defined(__FreeBSD__)
+#include <semaphore.h>
++#endif
#include "net/instaweb/util/public/abstract_shared_mem.h"
#include "net/instaweb/util/public/abstract_mutex.h"
#include "net/instaweb/util/public/basictypes.h"
-@@ -70,12 +71,34 @@
+@@ -70,13 +73,45 @@
DISALLOW_COPY_AND_ASSIGN(PthreadSharedMemMutex);
};
++#if defined(__FreeBSD__)
+// Some OSs does not support PTHREAD_PROCESS_SHARED attribute. (ex. FreeBSD < 9R, MacOS)
-+// So, we use the semaphore instead. But nested lock is not supported.
++// FreeBSD lacks PTHREAD_PROCESS_SHARED support before 9.0R, so we use a semaphore
++// instead. But nested locking is not supported.
+class SemSharedMemMutex : public AbstractMutex {
+ public:
+ explicit SemSharedMemMutex(sem_t* sem)
@@ -31,58 +35,65 @@
+ sem_t* sem_;
+ DISALLOW_COPY_AND_ASSIGN(SemSharedMemMutex);
+};
++#endif
+
class PthreadSharedMemSegment : public AbstractSharedMemSegment {
public:
// We will be representing memory mapped in the [base, base + size) range.
-- PthreadSharedMemSegment(char* base, size_t size, MessageHandler* handler)
++#if defined(__FreeBSD__)
+ PthreadSharedMemSegment(char* base, size_t size, MessageHandler* handler, const char* name)
- : base_(base),
-- size_(size) {
++ : base_(base),
+ size_(size),
+ sem_(NULL) {
+ std::sprintf(name_, "/%s_sem", name);
++ }
++#else
+ PthreadSharedMemSegment(char* base, size_t size, MessageHandler* handler)
+ : base_(base),
+ size_(size) {
}
++#endif
virtual ~PthreadSharedMemSegment() {
-@@ -86,10 +109,15 @@
+ }
+@@ -86,10 +121,18 @@
}
virtual size_t SharedMutexSize() const {
-+#if 0
- return sizeof(pthread_mutex_t);
-+#else
++#if defined(__FreeBSD__)
+ return 0;
++#else
+ return sizeof(pthread_mutex_t);
+#endif
}
virtual bool InitializeSharedMutex(size_t offset, MessageHandler* handler) {
-+#if 0
++#if defined(__FreeBSD__)
++ sem_ = sem_open(name_, O_CREAT, 0755, 1);
++ return sem_ ? true : false;
++#else
pthread_mutexattr_t attr;
if (pthread_mutexattr_init(&attr) != 0) {
handler->Message(kError, "pthread_mutexattr_init failed with errno:%d",
-@@ -113,19 +141,33 @@
+@@ -113,19 +156,32 @@
pthread_mutexattr_destroy(&attr);
return true;
-+#else
-+//std::printf("sem: %s\n", name_);
-+ sem_ = sem_open(name_, O_CREAT, 0755, 1);
-+ return sem_ ? true : false;
+#endif
}
virtual AbstractMutex* AttachToSharedMutex(size_t offset) {
-+#if 0
- return new PthreadSharedMemMutex(MutexPtr(offset));
-+#else
++#if defined(__FreeBSD__)
+ sem_ = sem_open(name_, O_EXCL);
+ return new SemSharedMemMutex(sem_);
++#else
+ return new PthreadSharedMemMutex(MutexPtr(offset));
+#endif
}
private:
-+#if 0
++#if defined(__FreeBSD__)
++#else
pthread_mutex_t* MutexPtr(size_t offset) {
return reinterpret_cast<pthread_mutex_t*>(base_ + offset);
}
@@ -90,38 +101,46 @@
char* const base_;
const size_t size_;
++#if defined(__FreeBSD__)
+ char name_[256];
+ sem_t* sem_;
++#endif
DISALLOW_COPY_AND_ASSIGN(PthreadSharedMemSegment);
};
-@@ -143,7 +185,11 @@
+@@ -143,7 +199,11 @@
}
size_t PthreadSharedMem::SharedMutexSize() const {
-+#if 0
- return sizeof(pthread_mutex_t);
-+#else
++#if defined(__FreeBSD__)
+ return 0;
++#else
+ return sizeof(pthread_mutex_t);
+#endif
}
AbstractSharedMemSegment* PthreadSharedMem::CreateSegment(
-@@ -167,7 +213,7 @@
+@@ -167,7 +227,11 @@
SegmentBaseMap* bases = AcquireSegmentBases();
(*bases)[name] = base;
UnlockSegmentBases();
-- return new PthreadSharedMemSegment(base, size, handler);
++#if defined(__FreeBSD__)
+ return new PthreadSharedMemSegment(base, size, handler, name.c_str());
++#else
+ return new PthreadSharedMemSegment(base, size, handler);
++#endif
}
AbstractSharedMemSegment* PthreadSharedMem::AttachToSegment(
-@@ -182,7 +228,7 @@
+@@ -182,7 +246,11 @@
}
char* base = i->second;
UnlockSegmentBases();
-- return new PthreadSharedMemSegment(base, size, handler);
++#if defined(__FreeBSD__)
+ return new PthreadSharedMemSegment(base, size, handler, name.c_str());
++#else
+ return new PthreadSharedMemSegment(base, size, handler);
++#endif
}
void PthreadSharedMem::DestroySegment(const GoogleString& name,
diff --git a/www/mod_pagespeed/files/patch-ptypes.h b/www/mod_pagespeed/files/patch-ptypes.h
deleted file mode 100644
index 446b84826093..000000000000
--- a/www/mod_pagespeed/files/patch-ptypes.h
+++ /dev/null
@@ -1,95 +0,0 @@
---- third_party/icu/public/common/unicode/ptypes.h.orig 2011-09-28 02:41:36.000000000 +0000
-+++ third_party/icu/public/common/unicode/ptypes.h 2011-09-28 02:41:50.000000000 +0000
-@@ -0,0 +1,92 @@
-+/*
-+******************************************************************************
-+*
-+* Copyright (C) 1997-2010, International Business Machines
-+* Corporation and others. All Rights Reserved.
-+*
-+******************************************************************************
-+*
-+* FILE NAME : ptypes.h
-+*
-+* Date Name Description
-+* 05/13/98 nos Creation (content moved here from ptypes.h).
-+* 03/02/99 stephen Added AS400 support.
-+* 03/30/99 stephen Added Linux support.
-+* 04/13/99 stephen Reworked for autoconf.
-+* 09/18/08 srl Moved basic types back to ptypes.h from platform.h
-+******************************************************************************
-+*/
-+
-+#ifndef _PTYPES_H
-+#define _PTYPES_H
-+
-+#include <sys/types.h>
-+
-+#include "unicode/platform.h"
-+
-+/*===========================================================================*/
-+/* Generic data types */
-+/*===========================================================================*/
-+
-+/* If your platform does not have the <inttypes.h> header, you may
-+ need to edit the typedefs below. */
-+#if U_HAVE_INTTYPES_H
-+
-+/* autoconf 2.13 sometimes can't properly find the data types in <inttypes.h> */
-+/* os/390 needs <inttypes.h>, but it doesn't have int8_t, and it sometimes */
-+/* doesn't have uint8_t depending on the OS version. */
-+/* So we have this work around. */
-+#ifdef OS390
-+/* The features header is needed to get (u)int64_t sometimes. */
-+#include <features.h>
-+#if ! U_HAVE_INT8_T
-+typedef signed char int8_t;
-+#endif
-+#if !defined(__uint8_t)
-+#define __uint8_t 1
-+typedef unsigned char uint8_t;
-+#endif
-+#endif /* OS390 */
-+
-+#include <inttypes.h>
-+
-+#else /* U_HAVE_INTTYPES_H */
-+
-+#if ! U_HAVE_INT8_T
-+typedef signed char int8_t;
-+#endif
-+
-+#if ! U_HAVE_UINT8_T
-+typedef unsigned char uint8_t;
-+#endif
-+
-+#if ! U_HAVE_INT16_T
-+typedef signed short int16_t;
-+#endif
-+
-+#if ! U_HAVE_UINT16_T
-+typedef unsigned short uint16_t;
-+#endif
-+
-+#if ! U_HAVE_INT32_T
-+typedef signed int int32_t;
-+#endif
-+
-+#if ! U_HAVE_UINT32_T
-+typedef unsigned int uint32_t;
-+#endif
-+
-+#if ! U_HAVE_INT64_T
-+ typedef signed long long int64_t;
-+/* else we may not have a 64-bit type */
-+#endif
-+
-+#if ! U_HAVE_UINT64_T
-+ typedef unsigned long long uint64_t;
-+/* else we may not have a 64-bit type */
-+#endif
-+
-+#endif /* U_HAVE_INTTYPES_H */
-+
-+#endif /* _PTYPES_H */
-+
diff --git a/www/mod_pagespeed/files/patch-python_arch.sh b/www/mod_pagespeed/files/patch-python_arch.sh
deleted file mode 100644
index acb5b7b6bba6..000000000000
--- a/www/mod_pagespeed/files/patch-python_arch.sh
+++ /dev/null
@@ -1,11 +0,0 @@
---- build/linux/python_arch.sh.orig 2011-09-27 21:20:46.000000000 -0400
-+++ build/linux/python_arch.sh 2011-10-11 19:20:09.472740606 -0400
-@@ -10,7 +10,7 @@
- # python_arch.sh /path/to/sysroot/usr/lib/libpython2.4.so.1.0
- #
-
--python=$(readlink -f "$1")
-+python=$(greadlink -f "$1")
- if [ ! -r "$python" ]; then
- echo unknown
- exit 0;
diff --git a/www/mod_pagespeed/files/patch-resource_manager_test.cc b/www/mod_pagespeed/files/patch-resource_manager_test.cc
index 634379f0c2d9..6f1c3e77db1e 100644
--- a/www/mod_pagespeed/files/patch-resource_manager_test.cc
+++ b/www/mod_pagespeed/files/patch-resource_manager_test.cc
@@ -1,11 +1,14 @@
---- net/instaweb/rewriter/resource_manager_test.cc.orig 2011-09-29 13:52:19.000000000 +0000
-+++ net/instaweb/rewriter/resource_manager_test.cc 2011-09-29 13:52:27.000000000 +0000
-@@ -323,7 +323,7 @@
+--- net/instaweb/rewriter/resource_manager_test.cc.orig 2011-10-31 14:25:06.000000000 +0000
++++ net/instaweb/rewriter/resource_manager_test.cc 2011-10-31 18:56:11.000000000 +0000
+@@ -339,7 +339,11 @@
void VerifyWithinSecond(int64 time_a_ms, int64 time_b_ms) {
// Note: need to pass in 1 * since otherwise we get a link failure
// due to conversion of compile-time constant to const reference
-- EXPECT_GE(1 * Timer::kSecondMs, std::abs(time_a_ms - time_b_ms));
++#if defined(__FreeBSD__)
+ EXPECT_GE(1 * Timer::kSecondMs, llabs(time_a_ms - time_b_ms));
++#else
+ EXPECT_GE(1 * Timer::kSecondMs, std::abs(time_a_ms - time_b_ms));
++#endif
}
void VerifyValidCachedResult(const char* subtest_name, bool test_meta_data,
diff --git a/www/mod_pagespeed/files/patch-utypes.h b/www/mod_pagespeed/files/patch-utypes.h
index b845e206ea76..a85ea4f4a902 100644
--- a/www/mod_pagespeed/files/patch-utypes.h
+++ b/www/mod_pagespeed/files/patch-utypes.h
@@ -1,11 +1,13 @@
---- third_party/icu/public/common/unicode/utypes.h.orig 2011-09-28 02:40:04.000000000 +0000
-+++ third_party/icu/public/common/unicode/utypes.h 2011-09-28 02:41:11.000000000 +0000
-@@ -32,7 +32,7 @@
+--- third_party/icu/public/common/unicode/utypes.h.orig 2011-10-31 14:25:20.000000000 +0000
++++ third_party/icu/public/common/unicode/utypes.h 2011-10-31 18:11:55.000000000 +0000
+@@ -32,7 +32,9 @@
#ifndef UTYPES_H
#define UTYPES_H
-
++#if defined(__FreeBSD__)
+#include <unicode/ptypes.h>
++#endif
#include "unicode/umachine.h"
#include "unicode/utf.h"
#include "unicode/uversion.h"