aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2010-11-08 12:06:02 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2010-11-08 12:06:02 +0000
commit92bf8f3f5c7422400a4328c3ddf952c4580f3e76 (patch)
tree8c8112a09a7d77a1990a8efef598c2a83d50fd3c /www
parent6e2ada58d54c90e760f48918dc20110f92442494 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/varnish/Makefile1
-rw-r--r--www/varnish/files/patch-r546117
-rw-r--r--www/varnish2/Makefile1
-rw-r--r--www/varnish2/files/patch-r546117
4 files changed, 36 insertions, 0 deletions
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index 18d5e4da5ca2..c279b313c3c4 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -7,6 +7,7 @@
PORTNAME= varnish
PORTVERSION= 2.1.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.varnish-software.com/sites/default/files/
diff --git a/www/varnish/files/patch-r5461 b/www/varnish/files/patch-r5461
new file mode 100644
index 000000000000..6447a2d6d319
--- /dev/null
+++ b/www/varnish/files/patch-r5461
@@ -0,0 +1,17 @@
+Index: bin/varnishd/cache_fetch.c
+===================================================================
+--- bin/varnishd/cache_fetch.c (revision 5460)
++++ bin/varnishd/cache_fetch.c (revision 5461)
+@@ -552,9 +552,11 @@
+ assert(uu == sp->obj->len);
+ }
+
+- if (mklen > 0)
++ if (mklen > 0) {
++ http_Unset(sp->obj->http, H_Content_Length);
+ http_PrintfHeader(sp->wrk, sp->fd, sp->obj->http,
+ "Content-Length: %u", sp->obj->len);
++ }
+
+ if (http_HdrIs(hp, H_Connection, "close"))
+ cls = 1;
diff --git a/www/varnish2/Makefile b/www/varnish2/Makefile
index 18d5e4da5ca2..c279b313c3c4 100644
--- a/www/varnish2/Makefile
+++ b/www/varnish2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= varnish
PORTVERSION= 2.1.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.varnish-software.com/sites/default/files/
diff --git a/www/varnish2/files/patch-r5461 b/www/varnish2/files/patch-r5461
new file mode 100644
index 000000000000..6447a2d6d319
--- /dev/null
+++ b/www/varnish2/files/patch-r5461
@@ -0,0 +1,17 @@
+Index: bin/varnishd/cache_fetch.c
+===================================================================
+--- bin/varnishd/cache_fetch.c (revision 5460)
++++ bin/varnishd/cache_fetch.c (revision 5461)
+@@ -552,9 +552,11 @@
+ assert(uu == sp->obj->len);
+ }
+
+- if (mklen > 0)
++ if (mklen > 0) {
++ http_Unset(sp->obj->http, H_Content_Length);
+ http_PrintfHeader(sp->wrk, sp->fd, sp->obj->http,
+ "Content-Length: %u", sp->obj->len);
++ }
+
+ if (http_HdrIs(hp, H_Connection, "close"))
+ cls = 1;