aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2009-06-22 07:55:50 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2009-06-22 07:55:50 +0000
commitab4b038114273792b64feb02644f8884bce820a5 (patch)
tree52d874d9c7e8fa1e3470ae9ea43417f4226967fe /www
parente220ab97c2f6f7b42bbc67a0aec7f5f847d5a2ee (diff)
downloadports-ab4b038114273792b64feb02644f8884bce820a5.tar.gz
ports-ab4b038114273792b64feb02644f8884bce820a5.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile2
-rw-r--r--www/mod_mono/Makefile45
-rw-r--r--www/mod_mono/distinfo3
-rw-r--r--www/mod_mono/files/patch-Makefile.in11
-rw-r--r--www/mod_mono/files/patch-src_Makefile.in13
-rw-r--r--www/mod_mono/files/patch-src_mod__mono.c18
-rw-r--r--www/mod_mono/pkg-descr3
-rw-r--r--www/mod_mono/pkg-plist3
-rw-r--r--www/xsp/Makefile33
-rw-r--r--www/xsp/distinfo3
-rw-r--r--www/xsp/files/patch-configure31
-rw-r--r--www/xsp/pkg-descr4
-rw-r--r--www/xsp/pkg-plist257
13 files changed, 426 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a30abca1bcbd..17b4521f55e1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -476,6 +476,7 @@
SUBDIR += mod_macro2
SUBDIR += mod_macro22
SUBDIR += mod_memcache
+ SUBDIR += mod_mono
SUBDIR += mod_mp3
SUBDIR += mod_musicindex
SUBDIR += mod_mylo
@@ -1737,6 +1738,7 @@
SUBDIR += xpi-yslow
SUBDIR += xshttpd
SUBDIR += xshttpd-devel
+ SUBDIR += xsp
SUBDIR += xulrunner
SUBDIR += yabb
SUBDIR += yahoo-ui
diff --git a/www/mod_mono/Makefile b/www/mod_mono/Makefile
new file mode 100644
index 000000000000..4de42990e073
--- /dev/null
+++ b/www/mod_mono/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mod_mono
+# Date created: 20040828
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.39 2007/12/13 19:35:47 killfill Exp $
+#
+
+PORTNAME= mod_mono
+PORTVERSION= 2.4
+CATEGORIES= www
+MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Apache module for serving ASP.NET applications
+
+LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono \
+ xsp:${PORTSDIR}/www/xsp
+RUN_DEPENDS= mono:${PORTSDIR}/lang/mono \
+ xsp:${PORTSDIR}/www/xsp
+
+USE_APACHE= 2.0+
+USE_BZIP2= yes
+USE_GNOME= gnometarget
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ARGS= --man=${PREFIX}/man
+
+MAN8= mod_mono.8
+
+.include <bsd.port.pre.mk>
+.if ${APACHE_VERSION} == 13
+MOD_MONOCONFDIR=${APACHEETCDIR}
+.else
+MOD_MONOCONFDIR=${APACHEETCDIR}/Includes
+.endif
+
+PLIST_SUB+= MOD_MONOCONFDIR=${MOD_MONOCONFDIR}
+
+post-patch:
+ @${REINPLACE_CMD} 's|%%MOD_MONOCONFDIR%%|${PREFIX}/${MOD_MONOCONFDIR}|g' \
+ ${WRKSRC}/Makefile.in
+
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+.include <bsd.port.post.mk>
diff --git a/www/mod_mono/distinfo b/www/mod_mono/distinfo
new file mode 100644
index 000000000000..fe1b1c1c8ebb
--- /dev/null
+++ b/www/mod_mono/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_mono-2.4.tar.bz2) = 4dc8e93baa22211e858bff84d3ffabd4
+SHA256 (mod_mono-2.4.tar.bz2) = 10c1c8d339bc35d729d257801f6d235a71ffb23989ff8802646416fc102cc991
+SIZE (mod_mono-2.4.tar.bz2) = 268525
diff --git a/www/mod_mono/files/patch-Makefile.in b/www/mod_mono/files/patch-Makefile.in
new file mode 100644
index 000000000000..4c9e390925f7
--- /dev/null
+++ b/www/mod_mono/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Sep 22 14:04:39 2005
++++ Makefile.in Sun Oct 2 20:24:15 2005
+@@ -192,7 +192,7 @@
+ # Current spec file is obsolete
+ # packaging/redhat/mod_mono.spec \
+ # packaging/redhat/mono.conf
+-modmonoconfdir = $(APXS_SYSCONFDIR)
++modmonoconfdir = %%MOD_MONOCONFDIR%%
+ modmonoconf_DATA = mod_mono.conf
+ all: all-recursive
+
diff --git a/www/mod_mono/files/patch-src_Makefile.in b/www/mod_mono/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..2240fc2eca88
--- /dev/null
+++ b/www/mod_mono/files/patch-src_Makefile.in
@@ -0,0 +1,13 @@
+--- src/Makefile.in.orig Thu Sep 22 14:04:38 2005
++++ src/Makefile.in Sat Oct 22 18:28:32 2005
+@@ -468,8 +468,8 @@
+
+ install: $(lib_LTLIBRARIES)
+ $(mkinstalldirs) "$(DESTDIR)$(APXS_LIBEXECDIR)"
+-@APACHE2_TRUE@ $(APXS) -S LIBEXECDIR="$(DESTDIR)$(APXS_LIBEXECDIR)" -i -n mono mod_mono.la
+-@APACHE2_FALSE@ $(APXS) -S LIBEXECDIR="$(DESTDIR)$(APXS_LIBEXECDIR)" -i -n mono .libs/mod_mono.so
++#@APACHE2_TRUE@ $(APXS) -S LIBEXECDIR="$(DESTDIR)$(APXS_LIBEXECDIR)" -i -n mono mod_mono.la
++ $(APXS) -S LIBEXECDIR="$(DESTDIR)$(APXS_LIBEXECDIR)" -i -n mono .libs/mod_mono.so
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/www/mod_mono/files/patch-src_mod__mono.c b/www/mod_mono/files/patch-src_mod__mono.c
new file mode 100644
index 000000000000..8fec14444592
--- /dev/null
+++ b/www/mod_mono/files/patch-src_mod__mono.c
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- src/mod_mono.c.orig
++++ src/mod_mono.c
+@@ -1765,8 +1765,12 @@
+
+ /* Unblock signals Mono uses: see bug #472732 */
+ sigemptyset (&sigset);
++#if defined SIGPWR
+ sigaddset (&sigset, SIGPWR);
++#endif /* def SIGPWR */
++#if defined SIGXCPU
+ sigaddset (&sigset, SIGXCPU);
++#endif /* def SIGXCPU */
+ sigaddset (&sigset, 33);
+ sigaddset (&sigset, 35);
+ sigprocmask (SIG_UNBLOCK, &sigset, NULL);
diff --git a/www/mod_mono/pkg-descr b/www/mod_mono/pkg-descr
new file mode 100644
index 000000000000..6bb0698c2e55
--- /dev/null
+++ b/www/mod_mono/pkg-descr
@@ -0,0 +1,3 @@
+An Apache module that ties Mono's XSP and Apache together.
+
+WWW: http://www.mono-project.com
diff --git a/www/mod_mono/pkg-plist b/www/mod_mono/pkg-plist
new file mode 100644
index 000000000000..dd256790f88f
--- /dev/null
+++ b/www/mod_mono/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+%%MOD_MONOCONFDIR%%/mod_mono.conf
+%%APACHEMODDIR%%/mod_mono.so
diff --git a/www/xsp/Makefile b/www/xsp/Makefile
new file mode 100644
index 000000000000..eba55cb21a0c
--- /dev/null
+++ b/www/xsp/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xsp
+# Date created: 20040828
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.38 2007/12/15 00:04:31 killfill Exp $
+#
+
+PORTNAME= xsp
+PORTVERSION= 2.4
+CATEGORIES= www
+MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Mono based web server
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/mono:${PORTSDIR}/lang/mono
+RUN_DEPENDS= ${LOCALBASE}/bin/mono:${PORTSDIR}/lang/mono
+
+USE_SQLITE= 3
+USE_BZIP2= yes
+USE_GNOME= gnometarget gnomehack
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= asp-state.1 dbsessmgr.1 mod-mono-server.1 xsp.1 \
+ fastcgi-mono-server.1
+
+pre-su-install:
+ ${MKDIR} ${XSP_DOCROOT}
+
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+.include <bsd.port.mk>
diff --git a/www/xsp/distinfo b/www/xsp/distinfo
new file mode 100644
index 000000000000..74ee977f6d15
--- /dev/null
+++ b/www/xsp/distinfo
@@ -0,0 +1,3 @@
+MD5 (xsp-2.4.tar.bz2) = 4c8215a528e8427797ef1e3093660892
+SHA256 (xsp-2.4.tar.bz2) = ae6aa06be256a4d826264d3f480772513dbce24ac60e284c9e162524d33c06ea
+SIZE (xsp-2.4.tar.bz2) = 258444
diff --git a/www/xsp/files/patch-configure b/www/xsp/files/patch-configure
new file mode 100644
index 000000000000..b45b52d7dae4
--- /dev/null
+++ b/www/xsp/files/patch-configure
@@ -0,0 +1,31 @@
+--- configure.orig Wed Feb 2 19:30:26 2005
++++ configure Wed Feb 23 22:03:36 2005
+@@ -1974,6 +1974,28 @@
+ MCS=$CSC
+ fi
+
++if test "x$GMCS" != "xno" ; then
++ echo "$as_me:$LINENO: checking whether gmcs is actually able to compile..." >&5
++echo $ECHO_N "checking whether gmcs is actually able to compile...... $ECHO_C" >&6
++
++ tmpin=fixme.exe
++ tmpout=fixme.exe
++
++ echo "class Foo { public static void Main() {} }" > $tmpin
++
++ if gmcs -r:System.Web.dll -out:$tmpout $tmpin > /dev/null 2>&1
++ then
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ else
++ GMCS=no
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++ fi
++
++ rm -f $tmpin $tmpout
++fi
++
+ case "$host" in
+ *-*-mingw*|*-*-cygwin*)
+ platform_win32=yes
diff --git a/www/xsp/pkg-descr b/www/xsp/pkg-descr
new file mode 100644
index 000000000000..1576cfee4228
--- /dev/null
+++ b/www/xsp/pkg-descr
@@ -0,0 +1,4 @@
+The XSP is a Mono based web server that can be used to run ASP.NET
+applications.
+
+WWW: http://www.mono-project.com
diff --git a/www/xsp/pkg-plist b/www/xsp/pkg-plist
new file mode 100644
index 000000000000..8ce8ba267864
--- /dev/null
+++ b/www/xsp/pkg-plist
@@ -0,0 +1,257 @@
+@comment $FreeBSD$
+bin/asp-state
+bin/asp-state1
+bin/asp-state2
+bin/dbsessmgr
+bin/dbsessmgr1
+bin/dbsessmgr2
+bin/fastcgi-mono-server
+bin/fastcgi-mono-server1
+bin/fastcgi-mono-server2
+bin/mod-mono-server
+bin/mod-mono-server1
+bin/mod-mono-server2
+bin/xsp
+bin/xsp1
+bin/xsp2
+lib/mono/1.0/Mono.WebServer.dll
+lib/mono/1.0/fastcgi-mono-server.exe
+lib/mono/1.0/mod-mono-server.exe
+lib/mono/1.0/xsp.exe
+lib/mono/2.0/Mono.WebServer2.dll
+lib/mono/2.0/fastcgi-mono-server2.exe
+lib/mono/2.0/mod-mono-server2.exe
+lib/mono/2.0/xsp2.exe
+lib/mono/gac/Mono.WebServer/0.1.0.0__0738eb9f132ed756/Mono.WebServer.dll
+lib/mono/gac/Mono.WebServer/0.1.0.0__0738eb9f132ed756/Mono.WebServer.dll.mdb
+lib/mono/gac/Mono.WebServer2/0.2.0.0__0738eb9f132ed756/Mono.WebServer2.dll
+lib/mono/gac/Mono.WebServer2/0.2.0.0__0738eb9f132ed756/Mono.WebServer2.dll.mdb
+lib/mono/gac/fastcgi-mono-server/2.4.0.0__0738eb9f132ed756/fastcgi-mono-server.exe
+lib/mono/gac/fastcgi-mono-server/2.4.0.0__0738eb9f132ed756/fastcgi-mono-server.exe.mdb
+lib/mono/gac/fastcgi-mono-server2/2.4.0.0__0738eb9f132ed756/fastcgi-mono-server2.exe
+lib/mono/gac/fastcgi-mono-server2/2.4.0.0__0738eb9f132ed756/fastcgi-mono-server2.exe.mdb
+lib/mono/gac/mod-mono-server/2.4.0.0__0738eb9f132ed756/mod-mono-server.exe
+lib/mono/gac/mod-mono-server/2.4.0.0__0738eb9f132ed756/mod-mono-server.exe.mdb
+lib/mono/gac/mod-mono-server2/2.4.0.0__0738eb9f132ed756/mod-mono-server2.exe
+lib/mono/gac/mod-mono-server2/2.4.0.0__0738eb9f132ed756/mod-mono-server2.exe.mdb
+lib/mono/gac/xsp/2.4.0.0__0738eb9f132ed756/xsp.exe
+lib/mono/gac/xsp/2.4.0.0__0738eb9f132ed756/xsp.exe.mdb
+lib/mono/gac/xsp2/2.4.0.0__0738eb9f132ed756/xsp2.exe
+lib/mono/gac/xsp2/2.4.0.0__0738eb9f132ed756/xsp2.exe.mdb
+lib/xsp/1.0/asp-state.exe
+lib/xsp/1.0/asp-state.exe.config
+lib/xsp/1.0/dbsessmgr.exe
+lib/xsp/1.0/dbsessmgr.exe.config
+lib/xsp/2.0/asp-state2.exe
+lib/xsp/2.0/asp-state2.exe.config
+lib/xsp/2.0/dbsessmgr2.exe
+lib/xsp/2.0/dbsessmgr2.exe.config
+lib/xsp/test/1.1/asp.net/body.inc
+lib/xsp/test/1.1/asp.net/browsercaps.aspx
+lib/xsp/test/1.1/asp.net/code-render.aspx
+lib/xsp/test/1.1/asp.net/codebehind1.aspx
+lib/xsp/test/1.1/asp.net/header.inc
+lib/xsp/test/1.1/asp.net/includetest.aspx
+lib/xsp/test/1.1/asp.net/index.aspx
+lib/xsp/test/1.1/asp.net/registertest.aspx
+lib/xsp/test/1.1/asp.net/registertest1.ascx
+lib/xsp/test/1.1/asp.net/registertest2.ascx
+lib/xsp/test/1.1/asp.net/serial.aspx
+lib/xsp/test/1.1/asp.net/server-side-object.aspx
+lib/xsp/test/1.1/asp.net/session1.aspx
+lib/xsp/test/1.1/asp.net/transfer1.aspx
+lib/xsp/test/1.1/asp.net/transfer2.aspx
+lib/xsp/test/1.1/asp.net/typedesc.aspx
+lib/xsp/test/1.1/authtest/index.aspx
+lib/xsp/test/1.1/authtest/login.aspx
+lib/xsp/test/1.1/authtest/web.config
+lib/xsp/test/1.1/customcontrol/index.aspx
+lib/xsp/test/1.1/customcontrol/tabcontrol.aspx
+lib/xsp/test/1.1/customcontrol/tabcontrol2.aspx
+lib/xsp/test/1.1/databind/databind-arraylist.aspx
+lib/xsp/test/1.1/databind/databind-attribute.aspx
+lib/xsp/test/1.1/databind/databind-class.aspx
+lib/xsp/test/1.1/databind/databind-template.aspx
+lib/xsp/test/1.1/databind/index.aspx
+lib/xsp/test/1.1/handlers/async.ashx
+lib/xsp/test/1.1/handlers/chunked.ashx
+lib/xsp/test/1.1/handlers/empty.ashx
+lib/xsp/test/1.1/handlers/index.aspx
+lib/xsp/test/1.1/handlers/monodoc.ashx
+lib/xsp/test/1.1/handlers/webhandler.ashx
+lib/xsp/test/1.1/html/button.aspx
+lib/xsp/test/1.1/html/htmlanchor.aspx
+lib/xsp/test/1.1/html/htmlbutton.aspx
+lib/xsp/test/1.1/html/htmlgeneric.aspx
+lib/xsp/test/1.1/html/htmlimage.aspx
+lib/xsp/test/1.1/html/htmlinputbutton.aspx
+lib/xsp/test/1.1/html/htmlinputcheckbox.aspx
+lib/xsp/test/1.1/html/htmlinputfile.aspx
+lib/xsp/test/1.1/html/htmlinputhidden.aspx
+lib/xsp/test/1.1/html/htmlinputimage.aspx
+lib/xsp/test/1.1/html/htmlinputradiobutton.aspx
+lib/xsp/test/1.1/html/htmlinputtext.aspx
+lib/xsp/test/1.1/html/htmlselect.aspx
+lib/xsp/test/1.1/html/htmltable.aspx
+lib/xsp/test/1.1/html/htmltextarea.aspx
+lib/xsp/test/1.1/html/index.aspx
+lib/xsp/test/1.1/index.aspx
+lib/xsp/test/1.1/webcontrols/calendar.aspx
+lib/xsp/test/1.1/webcontrols/datalist.aspx
+lib/xsp/test/1.1/webcontrols/dbpage1.aspx
+lib/xsp/test/1.1/webcontrols/dbpage1.sqlite
+lib/xsp/test/1.1/webcontrols/dbpage2.aspx
+lib/xsp/test/1.1/webcontrols/dbpage2.sqlite
+lib/xsp/test/1.1/webcontrols/dbpage_test_setup.exe
+lib/xsp/test/1.1/webcontrols/index.aspx
+lib/xsp/test/1.1/webcontrols/listitem.aspx
+lib/xsp/test/1.1/webcontrols/people.xml
+lib/xsp/test/1.1/webcontrols/peopletable.xsl
+lib/xsp/test/1.1/webcontrols/temperature.aspx
+lib/xsp/test/1.1/webcontrols/validator1.aspx
+lib/xsp/test/1.1/webcontrols/web_adrotator.aspx
+lib/xsp/test/1.1/webcontrols/web_adrotator.xml
+lib/xsp/test/1.1/webcontrols/web_button.aspx
+lib/xsp/test/1.1/webcontrols/web_checkbox.aspx
+lib/xsp/test/1.1/webcontrols/web_checkboxlist.aspx
+lib/xsp/test/1.1/webcontrols/web_comparevalidator.aspx
+lib/xsp/test/1.1/webcontrols/web_datagrid.aspx
+lib/xsp/test/1.1/webcontrols/web_datagrid_command.aspx
+lib/xsp/test/1.1/webcontrols/web_dropdownlist.aspx
+lib/xsp/test/1.1/webcontrols/web_hyperlink.aspx
+lib/xsp/test/1.1/webcontrols/web_image.aspx
+lib/xsp/test/1.1/webcontrols/web_imagebutton.aspx
+lib/xsp/test/1.1/webcontrols/web_label.aspx
+lib/xsp/test/1.1/webcontrols/web_linkbutton.aspx
+lib/xsp/test/1.1/webcontrols/web_listbox.aspx
+lib/xsp/test/1.1/webcontrols/web_literal.aspx
+lib/xsp/test/1.1/webcontrols/web_panel.aspx
+lib/xsp/test/1.1/webcontrols/web_placeholder.aspx
+lib/xsp/test/1.1/webcontrols/web_radiobutton.aspx
+lib/xsp/test/1.1/webcontrols/web_radiobuttonlist.aspx
+lib/xsp/test/1.1/webcontrols/web_regularexpressionvalidator.aspx
+lib/xsp/test/1.1/webcontrols/web_repeater.aspx
+lib/xsp/test/1.1/webcontrols/web_table.aspx
+lib/xsp/test/1.1/webcontrols/web_table2.aspx
+lib/xsp/test/1.1/webcontrols/web_textbox.aspx
+lib/xsp/test/1.1/webcontrols/web_xml.aspx
+lib/xsp/test/1.1/webservice/CompressExtension.cs
+lib/xsp/test/1.1/webservice/ConverterService.asmx
+lib/xsp/test/1.1/webservice/ServiceClient.exe.config
+lib/xsp/test/1.1/webservice/TestService.asmx
+lib/xsp/test/1.1/webservice/index.aspx
+lib/xsp/test/2.0/index.aspx
+lib/xsp/test/2.0/masterpages/content1.aspx
+lib/xsp/test/2.0/masterpages/content2.aspx
+lib/xsp/test/2.0/masterpages/frame.master
+lib/xsp/test/2.0/masterpages/index.aspx
+lib/xsp/test/2.0/masterpages/simple.aspx
+lib/xsp/test/2.0/masterpages/simple.master
+lib/xsp/test/2.0/menu/index.aspx
+lib/xsp/test/2.0/menu/menu1.aspx
+lib/xsp/test/2.0/menu/menu2.aspx
+lib/xsp/test/2.0/menu/stock_copy_24.png
+lib/xsp/test/2.0/menu/stock_cut_24.png
+lib/xsp/test/2.0/menu/stock_paste_24.png
+lib/xsp/test/2.0/treeview/TreeLineImages/dash.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/dashminus.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/dashplus.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/i.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/l.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/lminus.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/lplus.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/minus.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/noexpand.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/plus.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/r.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/rminus.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/rplus.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/t.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/tminus.gif
+lib/xsp/test/2.0/treeview/TreeLineImages/tplus.gif
+lib/xsp/test/2.0/treeview/index.aspx
+lib/xsp/test/2.0/treeview/populate-on-demand.aspx
+lib/xsp/test/2.0/treeview/populate.cs
+lib/xsp/test/2.0/treeview/treeview-databound.aspx
+lib/xsp/test/2.0/treeview/treeview.aspx
+lib/xsp/test/App_Code/Application.cs
+lib/xsp/test/ServiceClient.exe
+lib/xsp/test/Web.sitemap
+lib/xsp/test/bin/SiteMapReader_1.1.dll
+lib/xsp/test/bin/codebehind1.dll
+lib/xsp/test/bin/extensions.dll
+lib/xsp/test/bin/tabcontrol.dll
+lib/xsp/test/bin/tabcontrol2.dll
+lib/xsp/test/bin/treeview.dll
+lib/xsp/test/bin/typedesc.dll
+lib/xsp/test/controls/BreadCrumbs_1.1.ascx
+lib/xsp/test/controls/BreadCrumbs_2.0.ascx
+lib/xsp/test/controls/FileList.ascx
+lib/xsp/test/controls/MonoSamplesHeader.ascx
+lib/xsp/test/extensions.dll
+lib/xsp/test/favicon.ico
+lib/xsp/test/global.asax
+lib/xsp/test/index.aspx
+lib/xsp/test/index2.aspx
+lib/xsp/test/missing_components.aspx
+lib/xsp/test/mod-mono-server.exe.config
+lib/xsp/test/mono-powered-big.png
+lib/xsp/test/mono-xsp.css
+lib/xsp/test/mono.png
+lib/xsp/test/monobutton.png
+lib/xsp/test/sample.webapp
+lib/xsp/test/small-icon.png
+lib/xsp/test/web.config
+lib/xsp/test/xsp.exe.config
+lib/xsp/unittests/ChangeLog
+lib/xsp/unittests/NOACCESS
+lib/xsp/unittests/README
+lib/xsp/unittests/Tests.XSP.Security/DirectoryTraversalTest.cs
+lib/xsp/unittests/Tests.XSP.Security/FileExtensionsTest.cs
+lib/xsp/unittests/Tests.XSP.Security/Makefile
+lib/xsp/unittests/Tests.XSP.Security/Tests.XSP.Security.dll
+lib/xsp/unittests/Tests.XSP.Security/WebTestHelper.cs
+lib/xsp/unittests/webroot/index.aspx
+libdata/pkgconfig/xsp-2.pc
+libdata/pkgconfig/xsp.pc
+@dirrm www/xsp
+@dirrm lib/xsp/unittests/webroot
+@dirrm lib/xsp/unittests/Tests.XSP.Security
+@dirrm lib/xsp/unittests
+@dirrm lib/xsp/test/controls
+@dirrm lib/xsp/test/bin
+@dirrm lib/xsp/test/App_Code
+@dirrm lib/xsp/test/2.0/treeview/TreeLineImages
+@dirrm lib/xsp/test/2.0/treeview
+@dirrm lib/xsp/test/2.0/menu
+@dirrm lib/xsp/test/2.0/masterpages
+@dirrm lib/xsp/test/2.0
+@dirrm lib/xsp/test/1.1/webservice
+@dirrm lib/xsp/test/1.1/webcontrols
+@dirrm lib/xsp/test/1.1/html
+@dirrm lib/xsp/test/1.1/handlers
+@dirrm lib/xsp/test/1.1/databind
+@dirrm lib/xsp/test/1.1/customcontrol
+@dirrm lib/xsp/test/1.1/authtest
+@dirrm lib/xsp/test/1.1/asp.net
+@dirrm lib/xsp/test/1.1
+@dirrm lib/xsp/test
+@dirrm lib/xsp/2.0
+@dirrm lib/xsp/1.0
+@dirrm lib/xsp
+@dirrm lib/mono/gac/xsp2/2.4.0.0__0738eb9f132ed756
+@dirrm lib/mono/gac/xsp2
+@dirrm lib/mono/gac/xsp/2.4.0.0__0738eb9f132ed756
+@dirrm lib/mono/gac/xsp
+@dirrm lib/mono/gac/mod-mono-server2/2.4.0.0__0738eb9f132ed756
+@dirrm lib/mono/gac/mod-mono-server2
+@dirrm lib/mono/gac/mod-mono-server/2.4.0.0__0738eb9f132ed756
+@dirrm lib/mono/gac/mod-mono-server
+@dirrm lib/mono/gac/fastcgi-mono-server2/2.4.0.0__0738eb9f132ed756
+@dirrm lib/mono/gac/fastcgi-mono-server2
+@dirrm lib/mono/gac/fastcgi-mono-server/2.4.0.0__0738eb9f132ed756
+@dirrm lib/mono/gac/fastcgi-mono-server
+@dirrm lib/mono/gac/Mono.WebServer2/0.2.0.0__0738eb9f132ed756
+@dirrm lib/mono/gac/Mono.WebServer2
+@dirrm lib/mono/gac/Mono.WebServer/0.1.0.0__0738eb9f132ed756
+@dirrm lib/mono/gac/Mono.WebServer