aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-12-18 19:56:36 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-12-18 19:56:36 +0000
commitc405b09e344c0b4a05b9236f7134b348e28adf41 (patch)
tree4164d2bc19db58e3692ab06b8ae460c93c41d9a2 /www
parent93d5ac5687e0c6ee4e342c000cc17853b63ce448 (diff)
downloadports-c405b09e344c0b4a05b9236f7134b348e28adf41.tar.gz
ports-c405b09e344c0b4a05b9236f7134b348e28adf41.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-splinter/Makefile24
-rw-r--r--www/py-splinter/distinfo2
-rw-r--r--www/py-splinter/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3121902c26fe..7f603738b0c2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1671,6 +1671,7 @@
SUBDIR += py-selenium
SUBDIR += py-slimmer
SUBDIR += py-slumber
+ SUBDIR += py-splinter
SUBDIR += py-surl
SUBDIR += py-textile
SUBDIR += py-tgwebservices
diff --git a/www/py-splinter/Makefile b/www/py-splinter/Makefile
new file mode 100644
index 000000000000..d1948c643423
--- /dev/null
+++ b/www/py-splinter/Makefile
@@ -0,0 +1,24 @@
+# Created by: William Grzybowski <wg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= splinter
+PORTVERSION= 0.5.4
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Browser abstraction for web acceptance testing
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}selenium>=2.33:${PORTSDIR}/www/py-selenium \
+ ${PYTHON_PKGNAMEPREFIX}zope.testbrowser>=4.0.2:${PORTSDIR}/devel/py-zope.testbrowser \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}cssselect>0:${PORTSDIR}/www/py-cssselect
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-splinter/distinfo b/www/py-splinter/distinfo
new file mode 100644
index 000000000000..89160bc20afc
--- /dev/null
+++ b/www/py-splinter/distinfo
@@ -0,0 +1,2 @@
+SHA256 (splinter-0.5.4.tar.gz) = cd45b67f8ae1c98a69ac840c0c896cff914f65ddf05ea8d048087ce892bb9b03
+SIZE (splinter-0.5.4.tar.gz) = 14390
diff --git a/www/py-splinter/pkg-descr b/www/py-splinter/pkg-descr
new file mode 100644
index 000000000000..0c1648a18186
--- /dev/null
+++ b/www/py-splinter/pkg-descr
@@ -0,0 +1,5 @@
+Splinter is an open source tool for testing web applications using Python.
+It lets you automate browser actions, such as visiting URLs and interacting
+with their items.
+
+WWW: http://splinter.cobrateam.info/