aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-17 15:56:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-17 15:56:06 +0000
commitc5ade3bf734d5e73237bd9d9c91728ced435f7c7 (patch)
tree0d29f67bc103d405f564d89c08751de94b76b41a /www
parent82c16827c562b43d598823153ec48cb39c40242f (diff)
downloadports-c5ade3bf734d5e73237bd9d9c91728ced435f7c7.tar.gz
ports-c5ade3bf734d5e73237bd9d9c91728ced435f7c7.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_xml2enc/Makefile38
-rw-r--r--www/mod_xml2enc/distinfo2
-rw-r--r--www/mod_xml2enc/pkg-descr7
4 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c8fe45dbe75a..a576ce499d77 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -574,6 +574,7 @@
SUBDIR += mod_whatkilledus
SUBDIR += mod_wsgi
SUBDIR += mod_wsgi3
+ SUBDIR += mod_xml2enc
SUBDIR += mod_xmlns
SUBDIR += mod_xsendfile
SUBDIR += moinmoin
diff --git a/www/mod_xml2enc/Makefile b/www/mod_xml2enc/Makefile
new file mode 100644
index 000000000000..5f582783117e
--- /dev/null
+++ b/www/mod_xml2enc/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mod_xml2enc
+# Date created: 02 March 2011
+# Whom: Marin Atanasov Nikolov <dnaeon@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_xml2enc
+PORTVERSION= 1.0.3
+CATEGORIES= www
+MASTER_SITES= http://apache.webthing.com/mod_proxy_html/
+DISTNAME= mod_proxy_html
+DIST_SUBDIR= mod_proxy_html
+
+MAINTAINER= dnaeon@gmail.com
+COMMENT= Apache module for converting encoding before and/or after a filter run
+
+MAKE_JOBS_SAFE= yes
+
+USE_APACHE= 2.2+
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+SHORTMODNAME= xml2enc
+USE_BZIP2= YES
+USE_GNOME= libxml2
+
+AP_INC+= ${LOCALBASE}/include/libxml2 -I${WRKSRC}
+AP_LIB+= ${LOCALBASE}/lib
+AP_EXTRAS+= -lxml2
+
+PLIST_FILES= %%DOCSDIR%%/COPYING
+PLIST_DIRS= %%DOCSDIR%%
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/COPYING ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/www/mod_xml2enc/distinfo b/www/mod_xml2enc/distinfo
new file mode 100644
index 000000000000..b1f22b0176eb
--- /dev/null
+++ b/www/mod_xml2enc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mod_proxy_html/mod_proxy_html.tar.bz2) = a1aee758bda605e153868b91188ebf2c527b8eeb0f115d11af152078e65895bf
+SIZE (mod_proxy_html/mod_proxy_html.tar.bz2) = 23019
diff --git a/www/mod_xml2enc/pkg-descr b/www/mod_xml2enc/pkg-descr
new file mode 100644
index 000000000000..0f9be8941bdf
--- /dev/null
+++ b/www/mod_xml2enc/pkg-descr
@@ -0,0 +1,7 @@
+mod_xml2enc is a transcoding module that can be used to extend the
+internationalisation support of libxml2-based filter modules by
+converting encoding before and/or after the filter has run.
+Thus an unsupported input charset can be converted to UTF-8,
+and output can also be converted to another charset if required.
+
+WWW: http://apache.webthing.com/mod_xml2enc/