aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-23 04:49:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-23 04:49:02 +0000
commite343dd85af1142053f541322706a814da2319746 (patch)
tree2771e96df13a967204f845f5b00c64b160814912 /www
parented177f1d6bcf37f8b1e65cbf3e43ad3d27b7ba90 (diff)
downloadports-e343dd85af1142053f541322706a814da2319746.tar.gz
ports-e343dd85af1142053f541322706a814da2319746.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/firefox/Makefile.options1
-rw-r--r--www/seamonkey/Makefile12
2 files changed, 10 insertions, 3 deletions
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index b2e258ad63b5..50ae9f1c4d96 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -28,4 +28,5 @@ BUNDLED_CAIRO_DESC?= Use bundled fork of cairo-1.9.5
CANBERRA_DESC?= Sound theme alerts
INTEGER_SAMPLES_DESC?= Integer audio sample format
LIBPROXY_DESC?= Proxy support via libproxy
+LIGHTNING_DESC?= Calendar extension
RUST_DESC?= Build with components written in Rust language
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 3da18f8cfe85..dacbab28f467 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -3,7 +3,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.49.3
-PORTREVISION= 5
+PORTREVISION= 6
MOZILLA_VER= 52 # above + 3
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
@@ -42,10 +42,10 @@ MOZ_OPTIONS+= --enable-application=suite
USE_MOZILLA= -soundtouch
MOZ_PKGCONFIG_FILES=
-OPTIONS_DEFINE= LDAP RUST
+OPTIONS_DEFINE= LDAP LIGHTNING RUST
OPTIONS_SINGLE= TOOLKIT
OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3
-OPTIONS_DEFAULT=CANBERRA GTK3 LDAP
+OPTIONS_DEFAULT=CANBERRA GTK3 LDAP LIGHTNING
LDAP_DESC?= LDAP support for Mailnews
@@ -59,6 +59,12 @@ MOZ_OPTIONS+= --disable-ldap
.else
MOZ_OPTIONS+= --enable-ldap
.endif
+.if ${PORT_OPTIONS:MLIGHTNING}
+MOZ_OPTIONS+= --enable-calendar
+.else
+MOZ_OPTIONS+= --disable-calendar
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/suite/app/nsSuiteApp.cpp