aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-01 15:44:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-01 15:44:21 +0000
commit7df5d5e9af37898d8a65f0c8fce6b7f5ab104f5b (patch)
tree91c11d39bd78595fd3f30bc682b0e060e5a07f01 /www
parentb10501601084d1fec6147d6b85204adb37d1469b (diff)
downloadports-7df5d5e9af37898d8a65f0c8fce6b7f5ab104f5b.tar.gz
ports-7df5d5e9af37898d8a65f0c8fce6b7f5ab104f5b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Parser-Simple/Makefile27
-rw-r--r--www/p5-HTML-Parser-Simple/distinfo2
-rw-r--r--www/p5-HTML-Parser-Simple/pkg-descr4
-rw-r--r--www/p5-HTML-Parser-Simple/pkg-plist9
5 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1529fdf4601f..d67c6b4ddd63 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -981,6 +981,7 @@
SUBDIR += p5-HTML-Mason
SUBDIR += p5-HTML-Pager
SUBDIR += p5-HTML-Parser
+ SUBDIR += p5-HTML-Parser-Simple
SUBDIR += p5-HTML-Perlinfo
SUBDIR += p5-HTML-PrettyPrinter
SUBDIR += p5-HTML-Prototype
diff --git a/www/p5-HTML-Parser-Simple/Makefile b/www/p5-HTML-Parser-Simple/Makefile
new file mode 100644
index 000000000000..7205f11314b9
--- /dev/null
+++ b/www/p5-HTML-Parser-Simple/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-HTML-Parser-Simple
+# Date created: 2011-05-29
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Parser-Simple
+PORTVERSION= 1.06
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parse nice HTML files without needing a compiler
+
+BUILD_DEPENDS= p5-Tree-Simple>=0:${PORTSDIR}/devel/p5-Tree-Simple
+RUN_DEPENDS= p5-Tree-Simple>=0:${PORTSDIR}/devel/p5-Tree-Simple
+TEST_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Parser::Simple.3 \
+ HTML::Parser::Simple::Attributes.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Parser-Simple/distinfo b/www/p5-HTML-Parser-Simple/distinfo
new file mode 100644
index 000000000000..9038cd6ff9b2
--- /dev/null
+++ b/www/p5-HTML-Parser-Simple/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTML-Parser-Simple-1.06.tgz) = 5e57dc18d346eff1f743ccd301b16d75d3357bcfc42b6dfb57fd2b7f041b8572
+SIZE (HTML-Parser-Simple-1.06.tgz) = 19945
diff --git a/www/p5-HTML-Parser-Simple/pkg-descr b/www/p5-HTML-Parser-Simple/pkg-descr
new file mode 100644
index 000000000000..8cc49ae4c1dd
--- /dev/null
+++ b/www/p5-HTML-Parser-Simple/pkg-descr
@@ -0,0 +1,4 @@
+HTML::Parser::Simple is a pure Perl module. It parses HTML4 files, and
+generates a tree of nodes per HTML tag.
+
+WWW: http://search.cpan.org/dist/HTML-Parser-Simple/
diff --git a/www/p5-HTML-Parser-Simple/pkg-plist b/www/p5-HTML-Parser-Simple/pkg-plist
new file mode 100644
index 000000000000..4aca463d99a1
--- /dev/null
+++ b/www/p5-HTML-Parser-Simple/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/HTML/Parser/Simple.pm
+%%SITE_PERL%%/HTML/Parser/Simple/Attributes.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Parser/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Parser/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Parser
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrm %%SITE_PERL%%/HTML/Parser/Simple
+@dirrmtry %%SITE_PERL%%/HTML/Parser
+@dirrmtry %%SITE_PERL%%/HTML