aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 20:33:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 20:33:37 +0000
commitedcdb5ee3405f9fa4dcb33a256ed28e6ca9ccfea (patch)
tree9400b899b0114e2c6b54ab4ecdcf61f990308a29 /www
parentc71c5b210be30c1e802476b2499f82169715e439 (diff)
downloadports-edcdb5ee3405f9fa4dcb33a256ed28e6ca9ccfea.tar.gz
ports-edcdb5ee3405f9fa4dcb33a256ed28e6ca9ccfea.zip
www/py-ghp-import: Add py-ghp-import 2.0.2
GitHub Pages is a pretty awesome service that GitHub provides for hosting project documentation. The only thing is that it requires a gh-pages branch that is the site's document root. This means that keeping documentation sources in the branch with code is a bit difficult. And it really turns into a head scratcher for things like Sphinx that want to access documentation sources and code sources at the same time. Then I stumbled across an interesting looking package called github-tools that looked almost like what I wanted. It was a tad complicated and more involved than I wanted but it gave me an idea. Why not just write a script that can copy a directory to the gh-pages branch of the repository. This saves me from even having to think about the branch and everything becomes magical. This is what ghp-import was written for. WWW: https://github.com/c-w/ghp-import
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-ghp-import/Makefile22
-rw-r--r--www/py-ghp-import/distinfo3
-rw-r--r--www/py-ghp-import/pkg-descr16
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0b8c2f140771..d3ee8ebb6b98 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1635,6 +1635,7 @@
SUBDIR += py-frozen-flask
SUBDIR += py-gandi.cli
SUBDIR += py-gevent-websocket
+ SUBDIR += py-ghp-import
SUBDIR += py-google
SUBDIR += py-google-api-core
SUBDIR += py-google-api-python-client
diff --git a/www/py-ghp-import/Makefile b/www/py-ghp-import/Makefile
new file mode 100644
index 000000000000..a83005d7eb0b
--- /dev/null
+++ b/www/py-ghp-import/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= ghp-import
+PORTVERSION= 2.0.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Copy your docs directly to the gh-pages branch
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=2.8.1:devel/py-dateutil@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-ghp-import/distinfo b/www/py-ghp-import/distinfo
new file mode 100644
index 000000000000..81c74343f6cd
--- /dev/null
+++ b/www/py-ghp-import/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632773097
+SHA256 (ghp-import-2.0.2.tar.gz) = 947b3771f11be850c852c64b561c600fdddf794bab363060854c1ee7ad05e071
+SIZE (ghp-import-2.0.2.tar.gz) = 10928
diff --git a/www/py-ghp-import/pkg-descr b/www/py-ghp-import/pkg-descr
new file mode 100644
index 000000000000..5c34eb2101d4
--- /dev/null
+++ b/www/py-ghp-import/pkg-descr
@@ -0,0 +1,16 @@
+GitHub Pages is a pretty awesome service that GitHub provides for hosting
+project documentation. The only thing is that it requires a gh-pages branch that
+is the site's document root. This means that keeping documentation sources in
+the branch with code is a bit difficult. And it really turns into a head
+scratcher for things like Sphinx that want to access documentation sources and
+code sources at the same time.
+
+Then I stumbled across an interesting looking package called github-tools that
+looked almost like what I wanted. It was a tad complicated and more involved
+than I wanted but it gave me an idea. Why not just write a script that can copy
+a directory to the gh-pages branch of the repository. This saves me from even
+having to think about the branch and everything becomes magical.
+
+This is what ghp-import was written for.
+
+WWW: https://github.com/c-w/ghp-import