aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-12 16:48:56 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-12 16:48:56 +0000
commit2213e9a1d9ccaf87f9cf19a361c8f6e029c9f30b (patch)
tree71eae0caf37a0c62eabe12337597b04cfad23add /www
parenta01a147b38c935f0f4aac5eedf425a97dbe2bd47 (diff)
downloadports-2213e9a1d9ccaf87f9cf19a361c8f6e029c9f30b.tar.gz
ports-2213e9a1d9ccaf87f9cf19a361c8f6e029c9f30b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mozilla-devel-gtk1/Makefile2
-rw-r--r--www/mozilla-devel-gtk2/Makefile2
-rw-r--r--www/mozilla-devel/Makefile16
-rw-r--r--www/mozilla-devel/files/mozilla.sh6
-rw-r--r--www/mozilla-devel/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp57
-rw-r--r--www/seamonkey/Makefile16
-rw-r--r--www/seamonkey/files/mozilla.sh6
-rw-r--r--www/seamonkey/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp57
-rw-r--r--www/seamonkey2/Makefile16
-rw-r--r--www/seamonkey2/files/mozilla.sh6
-rw-r--r--www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp57
11 files changed, 221 insertions, 20 deletions
diff --git a/www/mozilla-devel-gtk1/Makefile b/www/mozilla-devel-gtk1/Makefile
index 9e273ca521a3..adf5a2a10424 100644
--- a/www/mozilla-devel-gtk1/Makefile
+++ b/www/mozilla-devel-gtk1/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mozilla
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 0
CATEGORIES= www
diff --git a/www/mozilla-devel-gtk2/Makefile b/www/mozilla-devel-gtk2/Makefile
index 9e273ca521a3..adf5a2a10424 100644
--- a/www/mozilla-devel-gtk2/Makefile
+++ b/www/mozilla-devel-gtk2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mozilla
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 0
CATEGORIES= www
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index d8ff3407aafa..f69ebd82b7fb 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.5a
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 1
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -25,7 +25,8 @@ BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ nspr4.1:${PORTSDIR}/devel/nspr
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -110,12 +111,14 @@ CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
.endif
.endif
-
+MOZ_EXTENSIONS= default
.if !defined(WITHOUT_CHATZILLA)
-CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
-.else
-CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
+MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
+.endif
+.if !defined(WITHOUT_XMLTERM)
+MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},xmlterm
.endif
+CONFIGURE_ARGS+= --enable-extensions=${MOZ_EXTENSIONS}
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
.if defined(WITH_JAVASCRIPT_DEBUGGER)
@@ -181,6 +184,7 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
@${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
@${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
+ @${ECHO_MSG} " WITHOUT_XMLTERM=yes Disable the XMLTerm module"
@${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
@${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
@${ECHO_MSG} ""
diff --git a/www/mozilla-devel/files/mozilla.sh b/www/mozilla-devel/files/mozilla.sh
index bbc7d2568bc6..c839ef1a9ff4 100644
--- a/www/mozilla-devel/files/mozilla.sh
+++ b/www/mozilla-devel/files/mozilla.sh
@@ -7,9 +7,15 @@ LOCATION='new-tab'
cd $MOZILLA_DIR || exit 1
case $1 in
+ -browser)
+ REMOTE_COMMAND="xfeDoCommand (openBrowser)"
+ ;;
-mail)
REMOTE_COMMAND="xfeDoCommand (openInbox)"
;;
+ -compose)
+ REMOTE_COMMAND="xfeDoCommand (composeMessage)"
+ ;;
-*)
exec ./$MOZILLA_EXEC "$@"
;;
diff --git a/www/mozilla-devel/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp b/www/mozilla-devel/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
new file mode 100644
index 000000000000..0b0e08247101
--- /dev/null
+++ b/www/mozilla-devel/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
@@ -0,0 +1,57 @@
+--- gfx/src/gtk/nsFontMetricsXft.cpp.save Thu Aug 7 12:14:49 2003
++++ gfx/src/gtk/nsFontMetricsXft.cpp Thu Aug 7 12:33:45 2003
+@@ -106,6 +106,7 @@
+ FcPattern *mPattern;
+ FcPattern *mFontName;
+ FcCharSet *mCharset;
++ int mNotXft;
+ };
+
+ class nsFontXftInfo;
+@@ -1051,7 +1052,7 @@
+ // font in our loaded list that supports the character
+ for (PRInt32 i = 0, end = mLoadedFonts.Count(); i < end; ++i) {
+ nsFontXft *font = (nsFontXft *)mLoadedFonts.ElementAt(i);
+- if (font->HasChar(PRUint32(aChar)))
++ if (font->HasChar(PRUint32(aChar)) && font->GetXftFont())
+ return font;
+ }
+
+@@ -1492,7 +1493,7 @@
+ // this character.
+ for (PRInt32 j = 0, end = mLoadedFonts.Count(); j < end; ++j) {
+ font = (nsFontXft *)mLoadedFonts.ElementAt(j);
+- if (font->HasChar(c)) {
++ if (font->HasChar(c) && font->GetXftFont()) {
+ currFont = font;
+ goto FoundFont; // for speed -- avoid "if" statement
+ }
+@@ -1922,6 +1923,7 @@
+ FcPatternReference(mFontName);
+
+ mXftFont = nsnull;
++ mNotXft = 0;
+
+ // set up our charset
+ mCharset = nsnull;
+@@ -1948,7 +1950,7 @@
+ XftFont *
+ nsFontXft::GetXftFont(void)
+ {
+- if (!mXftFont) {
++ if (!mXftFont && !mNotXft) {
+ FcPattern *pat = FcFontRenderPrepare(0, mPattern, mFontName);
+ if (!pat)
+ return nsnull;
+@@ -1967,8 +1969,10 @@
+ FcPatternDel(pat, FC_SPACING);
+
+ mXftFont = XftFontOpenPattern(GDK_DISPLAY(), pat);
+- if (!mXftFont)
++ if (!mXftFont) {
+ FcPatternDestroy(pat);
++ mNotXft = 1;
++ }
+ }
+
+ return mXftFont;
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index d8ff3407aafa..f69ebd82b7fb 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.5a
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 1
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -25,7 +25,8 @@ BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ nspr4.1:${PORTSDIR}/devel/nspr
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -110,12 +111,14 @@ CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
.endif
.endif
-
+MOZ_EXTENSIONS= default
.if !defined(WITHOUT_CHATZILLA)
-CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
-.else
-CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
+MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
+.endif
+.if !defined(WITHOUT_XMLTERM)
+MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},xmlterm
.endif
+CONFIGURE_ARGS+= --enable-extensions=${MOZ_EXTENSIONS}
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
.if defined(WITH_JAVASCRIPT_DEBUGGER)
@@ -181,6 +184,7 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
@${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
@${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
+ @${ECHO_MSG} " WITHOUT_XMLTERM=yes Disable the XMLTerm module"
@${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
@${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
@${ECHO_MSG} ""
diff --git a/www/seamonkey/files/mozilla.sh b/www/seamonkey/files/mozilla.sh
index bbc7d2568bc6..c839ef1a9ff4 100644
--- a/www/seamonkey/files/mozilla.sh
+++ b/www/seamonkey/files/mozilla.sh
@@ -7,9 +7,15 @@ LOCATION='new-tab'
cd $MOZILLA_DIR || exit 1
case $1 in
+ -browser)
+ REMOTE_COMMAND="xfeDoCommand (openBrowser)"
+ ;;
-mail)
REMOTE_COMMAND="xfeDoCommand (openInbox)"
;;
+ -compose)
+ REMOTE_COMMAND="xfeDoCommand (composeMessage)"
+ ;;
-*)
exec ./$MOZILLA_EXEC "$@"
;;
diff --git a/www/seamonkey/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp b/www/seamonkey/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
new file mode 100644
index 000000000000..0b0e08247101
--- /dev/null
+++ b/www/seamonkey/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
@@ -0,0 +1,57 @@
+--- gfx/src/gtk/nsFontMetricsXft.cpp.save Thu Aug 7 12:14:49 2003
++++ gfx/src/gtk/nsFontMetricsXft.cpp Thu Aug 7 12:33:45 2003
+@@ -106,6 +106,7 @@
+ FcPattern *mPattern;
+ FcPattern *mFontName;
+ FcCharSet *mCharset;
++ int mNotXft;
+ };
+
+ class nsFontXftInfo;
+@@ -1051,7 +1052,7 @@
+ // font in our loaded list that supports the character
+ for (PRInt32 i = 0, end = mLoadedFonts.Count(); i < end; ++i) {
+ nsFontXft *font = (nsFontXft *)mLoadedFonts.ElementAt(i);
+- if (font->HasChar(PRUint32(aChar)))
++ if (font->HasChar(PRUint32(aChar)) && font->GetXftFont())
+ return font;
+ }
+
+@@ -1492,7 +1493,7 @@
+ // this character.
+ for (PRInt32 j = 0, end = mLoadedFonts.Count(); j < end; ++j) {
+ font = (nsFontXft *)mLoadedFonts.ElementAt(j);
+- if (font->HasChar(c)) {
++ if (font->HasChar(c) && font->GetXftFont()) {
+ currFont = font;
+ goto FoundFont; // for speed -- avoid "if" statement
+ }
+@@ -1922,6 +1923,7 @@
+ FcPatternReference(mFontName);
+
+ mXftFont = nsnull;
++ mNotXft = 0;
+
+ // set up our charset
+ mCharset = nsnull;
+@@ -1948,7 +1950,7 @@
+ XftFont *
+ nsFontXft::GetXftFont(void)
+ {
+- if (!mXftFont) {
++ if (!mXftFont && !mNotXft) {
+ FcPattern *pat = FcFontRenderPrepare(0, mPattern, mFontName);
+ if (!pat)
+ return nsnull;
+@@ -1967,8 +1969,10 @@
+ FcPatternDel(pat, FC_SPACING);
+
+ mXftFont = XftFontOpenPattern(GDK_DISPLAY(), pat);
+- if (!mXftFont)
++ if (!mXftFont) {
+ FcPatternDestroy(pat);
++ mNotXft = 1;
++ }
+ }
+
+ return mXftFont;
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index d8ff3407aafa..f69ebd82b7fb 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.5a
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 1
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -25,7 +25,8 @@ BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ nspr4.1:${PORTSDIR}/devel/nspr
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -110,12 +111,14 @@ CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
.endif
.endif
-
+MOZ_EXTENSIONS= default
.if !defined(WITHOUT_CHATZILLA)
-CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
-.else
-CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
+MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
+.endif
+.if !defined(WITHOUT_XMLTERM)
+MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},xmlterm
.endif
+CONFIGURE_ARGS+= --enable-extensions=${MOZ_EXTENSIONS}
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
.if defined(WITH_JAVASCRIPT_DEBUGGER)
@@ -181,6 +184,7 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
@${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
@${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
+ @${ECHO_MSG} " WITHOUT_XMLTERM=yes Disable the XMLTerm module"
@${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
@${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
@${ECHO_MSG} ""
diff --git a/www/seamonkey2/files/mozilla.sh b/www/seamonkey2/files/mozilla.sh
index bbc7d2568bc6..c839ef1a9ff4 100644
--- a/www/seamonkey2/files/mozilla.sh
+++ b/www/seamonkey2/files/mozilla.sh
@@ -7,9 +7,15 @@ LOCATION='new-tab'
cd $MOZILLA_DIR || exit 1
case $1 in
+ -browser)
+ REMOTE_COMMAND="xfeDoCommand (openBrowser)"
+ ;;
-mail)
REMOTE_COMMAND="xfeDoCommand (openInbox)"
;;
+ -compose)
+ REMOTE_COMMAND="xfeDoCommand (composeMessage)"
+ ;;
-*)
exec ./$MOZILLA_EXEC "$@"
;;
diff --git a/www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp b/www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
new file mode 100644
index 000000000000..0b0e08247101
--- /dev/null
+++ b/www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
@@ -0,0 +1,57 @@
+--- gfx/src/gtk/nsFontMetricsXft.cpp.save Thu Aug 7 12:14:49 2003
++++ gfx/src/gtk/nsFontMetricsXft.cpp Thu Aug 7 12:33:45 2003
+@@ -106,6 +106,7 @@
+ FcPattern *mPattern;
+ FcPattern *mFontName;
+ FcCharSet *mCharset;
++ int mNotXft;
+ };
+
+ class nsFontXftInfo;
+@@ -1051,7 +1052,7 @@
+ // font in our loaded list that supports the character
+ for (PRInt32 i = 0, end = mLoadedFonts.Count(); i < end; ++i) {
+ nsFontXft *font = (nsFontXft *)mLoadedFonts.ElementAt(i);
+- if (font->HasChar(PRUint32(aChar)))
++ if (font->HasChar(PRUint32(aChar)) && font->GetXftFont())
+ return font;
+ }
+
+@@ -1492,7 +1493,7 @@
+ // this character.
+ for (PRInt32 j = 0, end = mLoadedFonts.Count(); j < end; ++j) {
+ font = (nsFontXft *)mLoadedFonts.ElementAt(j);
+- if (font->HasChar(c)) {
++ if (font->HasChar(c) && font->GetXftFont()) {
+ currFont = font;
+ goto FoundFont; // for speed -- avoid "if" statement
+ }
+@@ -1922,6 +1923,7 @@
+ FcPatternReference(mFontName);
+
+ mXftFont = nsnull;
++ mNotXft = 0;
+
+ // set up our charset
+ mCharset = nsnull;
+@@ -1948,7 +1950,7 @@
+ XftFont *
+ nsFontXft::GetXftFont(void)
+ {
+- if (!mXftFont) {
++ if (!mXftFont && !mNotXft) {
+ FcPattern *pat = FcFontRenderPrepare(0, mPattern, mFontName);
+ if (!pat)
+ return nsnull;
+@@ -1967,8 +1969,10 @@
+ FcPatternDel(pat, FC_SPACING);
+
+ mXftFont = XftFontOpenPattern(GDK_DISPLAY(), pat);
+- if (!mXftFont)
++ if (!mXftFont) {
+ FcPatternDestroy(pat);
++ mNotXft = 1;
++ }
+ }
+
+ return mXftFont;