aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-09-11 21:25:13 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-09-11 21:25:13 +0000
commit33e09467b1c18443b024f8dda8d42e9d6e9bf3dd (patch)
treef33d525ec1d7c30b91d7323c234f3f2da5d6739e /www
parent80d5261e88c45ae912a9e57602de8c55bba6a74b (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-selector/Makefile25
-rw-r--r--www/py-selector/distinfo2
-rw-r--r--www/py-selector/pkg-descr13
-rw-r--r--www/py-selector/pkg-plist11
5 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1600ea8a0b12..a96608c9cfd7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1649,6 +1649,7 @@
SUBDIR += py-scgi
SUBDIR += py-scrapy
SUBDIR += py-scriptaculous
+ SUBDIR += py-selector
SUBDIR += py-selenium
SUBDIR += py-slimmer
SUBDIR += py-slumber
diff --git a/www/py-selector/Makefile b/www/py-selector/Makefile
new file mode 100644
index 000000000000..d577abcae125
--- /dev/null
+++ b/www/py-selector/Makefile
@@ -0,0 +1,25 @@
+# Created by: Trevor Caira <trevor@bitba.se>
+# $FreeBSD$
+#
+
+PORTNAME= selector
+PORTVERSION= 0.9.4
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= trevor@bitba.se
+COMMENT= WSGI request delegation (a.k.a. routing)
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}resolver>=0.2.1:${PORTSDIR}/devel/py-resolver
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+post-patch:
+ @${REINPLACE_CMD} 's/license="MIT",/license="MIT", zip_safe=False,/' \
+ ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/www/py-selector/distinfo b/www/py-selector/distinfo
new file mode 100644
index 000000000000..acb89f3c8e84
--- /dev/null
+++ b/www/py-selector/distinfo
@@ -0,0 +1,2 @@
+SHA256 (selector-0.9.4.tar.gz) = 6eb14570e638eecc8edb75b20dcec3809c55db92116f8f4bfd9fecbeb6457c3f
+SIZE (selector-0.9.4.tar.gz) = 5723
diff --git a/www/py-selector/pkg-descr b/www/py-selector/pkg-descr
new file mode 100644
index 000000000000..0050bf750e1f
--- /dev/null
+++ b/www/py-selector/pkg-descr
@@ -0,0 +1,13 @@
+WSGI request delegation. (AKA routing.)
+
+This distribution provides WSGI middleware for "RESTful" dispatch of
+requests to WSGI applications by URL path and HTTP request
+method. Selector now also comes with components for environ-based
+dispatch and on-the-fly middleware composition. There is a very simple
+optional mini-language for path matching expressions. Alternately we
+can easily use regular expressions directly or even create our own
+mini-language. There is a simple "mapping file" format that can be
+used. There are no architecture specific features (to MVC or
+whatever). Neither are there any framework specific features.
+
+WWW: https://github.com/lukearno/selector/
diff --git a/www/py-selector/pkg-plist b/www/py-selector/pkg-plist
new file mode 100644
index 000000000000..bf085dace4b3
--- /dev/null
+++ b/www/py-selector/pkg-plist
@@ -0,0 +1,11 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/selector.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/selector.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/selector.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%