aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-10-02 22:55:18 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-10-02 22:55:18 +0000
commit956602650cb98620b2d1601da51f75af22670b6b (patch)
tree5623c5496dfba71730aa9b0d0f41ccc029c8365a /www
parent88f1eb7ccd639d1101c156dab594205a56bb7a64 (diff)
downloadports-956602650cb98620b2d1601da51f75af22670b6b.tar.gz
ports-956602650cb98620b2d1601da51f75af22670b6b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/ajaxplorer/Makefile22
1 files changed, 5 insertions, 17 deletions
diff --git a/www/ajaxplorer/Makefile b/www/ajaxplorer/Makefile
index 68734764a53c..8a27e0b99262 100644
--- a/www/ajaxplorer/Makefile
+++ b/www/ajaxplorer/Makefile
@@ -18,7 +18,6 @@ DOS2UNIX_REGEX= .*\.php
WANT_PHP_WEB= yes
SUB_FILES= pkg-deinstall pkg-install pkg-message
-NO_STAGE= yes
post-patch:
@${RM} -f ${WRKSRC}/plugins/gui.ajax/res/themes/vision/images/mimes/16/._users-folder.png
@${MV} ${WRKSRC}/conf/bootstrap_conf.php ${WRKDIR}/bootstrap_conf.php.sample
@@ -26,24 +25,13 @@ post-patch:
@${MV} ${WRKSRC}/conf/bootstrap_repositories.php ${WRKDIR}/bootstrap_repositories.php.sample
do-install:
- ${MKDIR} ${WWWDIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "* .htaccess" ${WWWDIR})
- ${INSTALL_DATA} ${WRKDIR}/bootstrap_*.php.sample ${WWWDIR}/conf
- ${INSTALL_DATA} ${FILESDIR}/4.2.3-5.0.0-db-upgrade.sql ${WWWDIR}/conf
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "* .htaccess" ${STAGEDIR}${WWWDIR})
+ ${INSTALL_DATA} ${WRKDIR}/bootstrap_*.php.sample ${STAGEDIR}${WWWDIR}/conf
+ ${INSTALL_DATA} ${FILESDIR}/4.2.3-5.0.0-db-upgrade.sql ${STAGEDIR}${WWWDIR}/conf
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
post-install:
- @if [ ! -f ${WWWDIR}/conf/bootstrap_conf.php ]; then \
- ${CP} -p ${WWWDIR}/conf/bootstrap_conf.php.sample ${WWWDIR}/conf/bootstrap_conf.php ; \
- fi
- @if [ ! -f ${WWWDIR}/conf/bootstrap_context.php ]; then \
- ${CP} -p ${WWWDIR}/conf/bootstrap_context.php.sample ${WWWDIR}/conf/bootstrap_context.php ; \
- fi
- @if [ ! -f ${WWWDIR}/conf/bootstrap_repositories.php ]; then \
- ${CP} -p ${WWWDIR}/conf/bootstrap_repositories.php.sample ${WWWDIR}/conf/bootstrap_repositories.php ; \
- fi
@${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' >> ${TMPPLIST}
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>