aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:20:28 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:20:28 +0000
commitaaf92181710ea23b964f7cccd9c2b31e2e863d2a (patch)
tree92a4f2502c04942ec1c80343d14e1b7911631fd0 /www
parent339e1d344b5f7264125adc11c4943f0616b1de1e (diff)
downloadports-aaf92181710ea23b964f7cccd9c2b31e2e863d2a.tar.gz
ports-aaf92181710ea23b964f7cccd9c2b31e2e863d2a.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-AuthenCache/Makefile26
-rw-r--r--www/p5-Apache-AuthenCache/distinfo1
-rw-r--r--www/p5-Apache-AuthenCache/pkg-comment1
-rw-r--r--www/p5-Apache-AuthenCache/pkg-descr7
-rw-r--r--www/p5-Apache-AuthenCache/pkg-plist3
6 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 991b021d9a8f..d605bdd4acd5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -134,6 +134,7 @@
SUBDIR += p5-Apache-Archive
SUBDIR += p5-Apache-AuthCookie
SUBDIR += p5-Apache-AuthTicket
+ SUBDIR += p5-Apache-AuthenCache
SUBDIR += p5-Apache-AutoIndex
SUBDIR += p5-Apache-DBI
SUBDIR += p5-Apache-Icon
diff --git a/www/p5-Apache-AuthenCache/Makefile b/www/p5-Apache-AuthenCache/Makefile
new file mode 100644
index 000000000000..3d02847921bf
--- /dev/null
+++ b/www/p5-Apache-AuthenCache/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Apache-AuthenCache
+# Date created: Sun Dec 31 19:59:31 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-AuthenCache
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/www/p5-Tie-IxHash
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::AuthenCache.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-AuthenCache/distinfo b/www/p5-Apache-AuthenCache/distinfo
new file mode 100644
index 000000000000..90fe4cc53544
--- /dev/null
+++ b/www/p5-Apache-AuthenCache/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-AuthenCache-0.03.tar.gz) = eb9b0d3266c906b5c1ee61eac31a00d3
diff --git a/www/p5-Apache-AuthenCache/pkg-comment b/www/p5-Apache-AuthenCache/pkg-comment
new file mode 100644
index 000000000000..8dfd8bf37531
--- /dev/null
+++ b/www/p5-Apache-AuthenCache/pkg-comment
@@ -0,0 +1 @@
+Perl module that implements authentication caching
diff --git a/www/p5-Apache-AuthenCache/pkg-descr b/www/p5-Apache-AuthenCache/pkg-descr
new file mode 100644
index 000000000000..e1ce3edbcfee
--- /dev/null
+++ b/www/p5-Apache-AuthenCache/pkg-descr
@@ -0,0 +1,7 @@
+Apache::AuthenCache is a perl module that implements authentication caching
+to be used in conjunction with a primary authentication module, e.g.
+Apache::AuthenDBI and others.
+
+Author: Jason Bodnar <jcbodnar@mail.utexas.edu>
+
+--will
diff --git a/www/p5-Apache-AuthenCache/pkg-plist b/www/p5-Apache-AuthenCache/pkg-plist
new file mode 100644
index 000000000000..f3c60ee813e9
--- /dev/null
+++ b/www/p5-Apache-AuthenCache/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Apache/AuthenCache.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/AuthenCache/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/AuthenCache