aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-20 08:56:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-20 08:56:50 +0000
commit10aac1d4d50b996d7675877640f5db164594277b (patch)
treea4e8ca0818ecdac104bc72435645b2eea2f5132e /www
parentc4c7231c1ee6db2ea810e6b5dd6effb3ec0831fa (diff)
downloadports-10aac1d4d50b996d7675877640f5db164594277b.tar.gz
ports-10aac1d4d50b996d7675877640f5db164594277b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/tomcat55/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/www/tomcat55/Makefile b/www/tomcat55/Makefile
index 642f3dd6519a..e53413fd869a 100644
--- a/www/tomcat55/Makefile
+++ b/www/tomcat55/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.23
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-5/v${PORTVERSION}/bin
@@ -129,10 +129,13 @@ do-install:
@${ECHO_MSG} -n ">> Fixing ownership settings..."
@${CHOWN} -R ${TOMCAT_USER}:${TOMCAT_GROUP} ${APP_HOME}/conf ${APP_HOME}/logs \
- ${APP_HOME}/temp ${APP_HOME}/work
+ ${APP_HOME}/temp ${APP_HOME}/work ${APP_HOME}/webapps
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Fixing permissions..."
+ @${FIND} ${APP_HOME} -type d | while read a; do\
+ ${CHMOD} 755 "$$a"; \
+ done
@${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_MSG} " [ DONE ]"