aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-03-28 05:52:12 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-03-28 05:52:12 +0000
commit204523bd3c7ab55a9a1d4034e78217e069c1f7c0 (patch)
treed296e6f9588ec24d6485e49b048f96c1689bba52 /www
parent045030410823853fcaee9042f4e1670a9da7caef (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/jetty/Makefile3
-rw-r--r--www/polipo/Makefile2
-rw-r--r--www/polipo/files/pkg-install.in6
3 files changed, 1 insertions, 10 deletions
diff --git a/www/jetty/Makefile b/www/jetty/Makefile
index f783d773b700..27207442d67a 100644
--- a/www/jetty/Makefile
+++ b/www/jetty/Makefile
@@ -21,8 +21,6 @@ USE_PYTHON= 1.6+
PLIST= ${WRKDIR}/pkg-plist
PKGMESSAGE= ${WRKDIR}/pkg-message
-USE_RC_SUBR= jetty
-
APP_NAME= ${PORTNAME}
APP_HOME= ${PREFIX}/${PORTNAME}
PID_FILE?= ${APP_HOME}/${APP_NAME}.pid
@@ -35,7 +33,6 @@ LOG_FILE?= ${APP_HOME}/${APP_NAME}.log
SUB_LIST= \
APP_HOME=${APP_HOME} \
APP_NAME=${APP_NAME} \
- RC_SUBR=${RC_SUBR} \
JAVA_HOME=${JAVA_HOME} \
JAVA=${JAVA} \
PID_FILE=${PID_FILE} \
diff --git a/www/polipo/Makefile b/www/polipo/Makefile
index fd3856b0e5da..b08e8668c11b 100644
--- a/www/polipo/Makefile
+++ b/www/polipo/Makefile
@@ -34,7 +34,7 @@ PORTDOCS= *
SUB_FILES= pkg-message pkg-install pkg-deinstall 400.polipo
SUB_LIST+= USER=${PUSER} GROUP=${PGRP} DESTDIR=${DESTDIR} PCONFIGDIR=${PCONFIGDIR} \
PCACHEDIR=${PCACHEDIR} PPIDDIR=${PPIDDIR} PPIDFILE=${PPIDFILE} \
- PLOGFILE=${PLOGFILE} RC_SUBR=${RC_SUBR}
+ PLOGFILE=${PLOGFILE}
# polipo installation options, propagated to install scripts
PUSER?= polipo
diff --git a/www/polipo/files/pkg-install.in b/www/polipo/files/pkg-install.in
index 8cead8eaf08f..b3e7a0f80b2b 100644
--- a/www/polipo/files/pkg-install.in
+++ b/www/polipo/files/pkg-install.in
@@ -12,12 +12,6 @@ POLIPOPID=%%PPIDFILE%%
if [ "$2" = "PRE-INSTALL" ]; then
- if [ "%%RC_SUBR%%" = "" ]; then
- echo "=> Port requires /etc/rc.subr (native or port/sysutils/rc_subr)!"
- echo "=> If you want to install without you should modify startup script and pkg-install."
- exit 1
- fi
-
if fgrep "polipo" "%%DESTDIR%%/etc/newsyslog.conf" 2>/dev/null 1>&2; then
if ! fgrep "polipo.pid" "%%DESTDIR%%/etc/newsyslog.conf" 2>/dev/null 1>&2; then
echo "==> ERROR: Previous installation left an invalid entry in %%DESTDIR%%/etc/newsyslog.conf."