aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMarcel Moolenaar <marcel@FreeBSD.org>2009-11-22 21:32:27 +0000
committerMarcel Moolenaar <marcel@FreeBSD.org>2009-11-22 21:32:27 +0000
commit463a211c906e273044de1e10f77d7e360ccb3038 (patch)
tree385b4813305d3ef706a62685ca99b75c981a83b0 /www
parenta03f0ab47c72de1b4498ef08741486e0eb802bdd (diff)
downloadports-463a211c906e273044de1e10f77d7e360ccb3038.tar.gz
ports-463a211c906e273044de1e10f77d7e360ccb3038.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/libxul/files/patch-security_coreconf_FreeBSD.mk24
-rw-r--r--www/libxul/files/patch-xpcom-reflect-xptcall-src-xptcprivate.h20
2 files changed, 39 insertions, 5 deletions
diff --git a/www/libxul/files/patch-security_coreconf_FreeBSD.mk b/www/libxul/files/patch-security_coreconf_FreeBSD.mk
index 5c76b5af5ebf..891e42e6dd26 100644
--- a/www/libxul/files/patch-security_coreconf_FreeBSD.mk
+++ b/www/libxul/files/patch-security_coreconf_FreeBSD.mk
@@ -1,6 +1,6 @@
---- security/coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
-+++ security/coreconf/FreeBSD.mk Thu Jul 8 12:56:24 2004
-@@ -35,16 +35,18 @@
+--- security/coreconf/FreeBSD.mk.orig 2009-11-22 11:51:31.000000000 -0800
++++ security/coreconf/FreeBSD.mk 2009-11-22 11:51:44.000000000 -0800
+@@ -37,16 +37,32 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
@@ -13,16 +13,30 @@
ifeq ($(OS_TEST),alpha)
CPU_ARCH = alpha
else
++ifeq ($(OS_TEST),powerpc)
++CPU_ARCH = powerpc
++else
++ifeq ($(OS_TEST),sparc64)
++CPU_ARCH = sparc64
++USE_64 = 1
++else
++ifeq ($(OS_TEST),ia64)
++CPU_ARCH = ia64
++USE_64 = 1
++else
+ifeq ($(OS_TEST),amd64)
+CPU_ARCH = amd64
+else
CPU_ARCH = x86
endif
+endif
++endif
++endif
++endif
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
-@@ -71,7 +73,11 @@
+@@ -73,7 +89,11 @@
DLL_SUFFIX = so.1.0
endif
@@ -33,5 +47,5 @@
+MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS) -o $@
+endif
ifdef MAPFILE
- # Add LD options to restrict exported symbols to those in the map file
+ MKSHLIB += -Wl,--version-script,$(MAPFILE)
endif
diff --git a/www/libxul/files/patch-xpcom-reflect-xptcall-src-xptcprivate.h b/www/libxul/files/patch-xpcom-reflect-xptcall-src-xptcprivate.h
new file mode 100644
index 000000000000..0440ce0a263f
--- /dev/null
+++ b/www/libxul/files/patch-xpcom-reflect-xptcall-src-xptcprivate.h
@@ -0,0 +1,20 @@
+--- xpcom/reflect/xptcall/src/xptcprivate.h.orig 2009-11-09 21:43:49.000000000 -0800
++++ xpcom/reflect/xptcall/src/xptcprivate.h 2009-11-09 21:44:05.000000000 -0800
+@@ -45,7 +45,7 @@
+
+ class xptiInterfaceEntry;
+
+-#if !defined(__ia64) || (!defined(__hpux) && !defined(__linux__))
++#if !defined(__ia64)
+ #define STUB_ENTRY(n) NS_IMETHOD Stub##n() = 0;
+ #else
+ #define STUB_ENTRY(n) NS_IMETHOD Stub##n(PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64) = 0;
+@@ -62,7 +62,7 @@
+ #undef STUB_ENTRY
+ #undef SENTINEL_ENTRY
+
+-#if !defined(__ia64) || (!defined(__hpux) && !defined(__linux__))
++#if !defined(__ia64)
+ #define STUB_ENTRY(n) NS_IMETHOD Stub##n();
+ #else
+ #define STUB_ENTRY(n) NS_IMETHOD Stub##n(PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64);