aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-30 08:22:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-30 08:22:17 +0000
commitefe3103c5bbc7d2348dc680e5d054f50bf57016b (patch)
tree641f7d7416806e367302470d193e785a732eccb1 /www
parent52b46ea94c99d5a22bcec20842aa527d4bcf2c1b (diff)
downloadports-efe3103c5bbc7d2348dc680e5d054f50bf57016b.tar.gz
ports-efe3103c5bbc7d2348dc680e5d054f50bf57016b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/p5-WWW-Facebook-API/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/www/p5-WWW-Facebook-API/Makefile b/www/p5-WWW-Facebook-API/Makefile
index ad611c536531..f460fbebb6ad 100644
--- a/www/p5-WWW-Facebook-API/Makefile
+++ b/www/p5-WWW-Facebook-API/Makefile
@@ -7,6 +7,7 @@
PORTNAME= WWW-Facebook-API
PORTVERSION= 0.4.18
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,12 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Facebook API implementation in Perl
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
- ${SITE_PERL}/${PERL_ARCH}/Readonly.pm:${PORTSDIR}/devel/p5-Readonly \
- ${SITE_PERL}/JSON/Any.pm:${PORTSDIR}/converters/p5-JSON-Any \
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
-BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-Readonly>=0:${PORTSDIR}/devel/p5-Readonly \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
PERL_CONFIGURE= yes
@@ -54,4 +53,10 @@ MAN3= WWW::Facebook::API.3 \
WWW::Facebook::API::Users.3 \
WWW::Facebook::API::Video.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-version>=0:${PORTSDIR}/devel/p5-version
+.endif
+
+.include <bsd.port.post.mk>