aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-27 13:14:32 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-27 13:14:32 +0000
commit1c4c04cfddd7a7278ad8788dd777e63e1dfbd92b (patch)
treedabf5792fee54663daa6058107ad101db293d137 /www
parent92b591f201b18182c75285c6f33efe64e194b3c2 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-W3C-LogValidator/Makefile52
-rw-r--r--www/p5-W3C-LogValidator/distinfo2
-rw-r--r--www/p5-W3C-LogValidator/pkg-descr11
-rw-r--r--www/p5-W3C-LogValidator/pkg-plist18
5 files changed, 84 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6017fa1fbcc5..8af40cc8ae0f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -518,6 +518,7 @@
SUBDIR += p5-Template-Plugin-MP3
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-URI-Sequin
+ SUBDIR += p5-W3C-LogValidator
SUBDIR += p5-WWW-Automate
SUBDIR += p5-WWW-Babelfish
SUBDIR += p5-WWW-Curl
diff --git a/www/p5-W3C-LogValidator/Makefile b/www/p5-W3C-LogValidator/Makefile
new file mode 100644
index 000000000000..d3923972f25c
--- /dev/null
+++ b/www/p5-W3C-LogValidator/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: p5-W3C-LogValidator
+# Date created: Jun 24, 2004
+# Whom: toni.viemero@iki.fi
+#
+# $FreeBSD$
+#
+
+PORTNAME= W3C-LogValidator
+PORTVERSION= 0.3
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= W3C
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= toni.viemero@iki.fi
+COMMENT= A comprehensive validation tool for webmasters and web developers
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Config/General.pm:${PORTSDIR}/devel/p5-Config-General \
+ ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= W3C::LogValidator.3 \
+ W3C::LogValidator::Basic.3 \
+ W3C::LogValidator::CSSValidator.3 \
+ W3C::LogValidator::HTMLValidator.3 \
+ W3C::LogValidator::SurveyEngine.3 \
+ W3C::LogValidator::Output::HTML.3 \
+ W3C::LogValidator::Output::Mail.3 \
+ W3C::LogValidator::Output::Raw.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our ([^;=]+)/use vars qw($$1); $$1/;' \
+ ${WRKSRC}/lib/W3C/LogValidator.pm ${WRKSRC}/lib/W3C/LogValidator/*
+.endif
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/samples/logprocess.conf ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-W3C-LogValidator/distinfo b/www/p5-W3C-LogValidator/distinfo
new file mode 100644
index 000000000000..f9e088693717
--- /dev/null
+++ b/www/p5-W3C-LogValidator/distinfo
@@ -0,0 +1,2 @@
+MD5 (W3C-LogValidator-0.3.tar.gz) = 7ad415ce032cee875a85e59b69d85351
+SIZE (W3C-LogValidator-0.3.tar.gz) = 20404
diff --git a/www/p5-W3C-LogValidator/pkg-descr b/www/p5-W3C-LogValidator/pkg-descr
new file mode 100644
index 000000000000..45a2d065a538
--- /dev/null
+++ b/www/p5-W3C-LogValidator/pkg-descr
@@ -0,0 +1,11 @@
+Log Validator is a web server log analysis tool with focus on the quality
+of Web documents. Thanks to a modular, extensible design, the Log Validator
+can help Web authors find the most popular content on their web site that
+matches a particular criteria.
+
+The Log Validator was first written with Validation (HTML, etc.) in mind :
+it can thus help web content managers find and fix the most frequently
+accessed invalid documents on their Web site, acting as a comprehensive,
+step-by-step validation tool.
+
+WWW: http://www.w3.org/QA/Tools/LogValidator/
diff --git a/www/p5-W3C-LogValidator/pkg-plist b/www/p5-W3C-LogValidator/pkg-plist
new file mode 100644
index 000000000000..3ef16bcf626e
--- /dev/null
+++ b/www/p5-W3C-LogValidator/pkg-plist
@@ -0,0 +1,18 @@
+bin/logprocess.pl
+%%SITE_PERL%%/W3C/LogValidator.pm
+%%SITE_PERL%%/W3C/LogValidator/Basic.pm
+%%SITE_PERL%%/W3C/LogValidator/CSSValidator.pm
+%%SITE_PERL%%/W3C/LogValidator/Config.pm
+%%SITE_PERL%%/W3C/LogValidator/HTMLValidator.pm
+%%SITE_PERL%%/W3C/LogValidator/Output/HTML.pm
+%%SITE_PERL%%/W3C/LogValidator/Output/Mail.pm
+%%SITE_PERL%%/W3C/LogValidator/Output/Raw.pm
+%%SITE_PERL%%/W3C/LogValidator/SurveyEngine.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/W3C/LogValidator/.packlist
+%%PORTDOCS%%%%EXAMPLESDIR%%/logprocess.conf
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/W3C/LogValidator
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/W3C 2>/dev/null || true
+@dirrm %%SITE_PERL%%/W3C/LogValidator/Output
+@dirrm %%SITE_PERL%%/W3C/LogValidator
+@unexec rmdir %D/%%SITE_PERL%%/W3C 2>/dev/null || true