aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2015-06-28 17:07:06 +0000
committerMark Felder <feld@FreeBSD.org>2015-06-28 17:07:06 +0000
commit8e5f2302a7209cfa7e06bc370d7faac07ec838c1 (patch)
treec00642783dd248351dd48b1bf37a1e952c5e4d81 /www
parent074a83223e17568128c11447c5df1ba72c254505 (diff)
downloadports-8e5f2302a7209cfa7e06bc370d7faac07ec838c1.tar.gz
ports-8e5f2302a7209cfa7e06bc370d7faac07ec838c1.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/varnish-libvmod-header/Makefile16
-rw-r--r--www/varnish-libvmod-header/distinfo4
-rw-r--r--www/varnish-libvmod-header/files/patch-configure.ac27
-rw-r--r--www/varnish-libvmod-header/files/patch-src-Makefile.am13
-rw-r--r--www/varnish-libvmod-header/files/patch-src-vmod_header.c13
5 files changed, 10 insertions, 63 deletions
diff --git a/www/varnish-libvmod-header/Makefile b/www/varnish-libvmod-header/Makefile
index c8bc25e50ac4..84fa3306d9e0 100644
--- a/www/varnish-libvmod-header/Makefile
+++ b/www/varnish-libvmod-header/Makefile
@@ -2,29 +2,29 @@
# $FreeBSD$
PORTNAME= libvmod-header
-DISTVERSION= 0.3-5
-PORTREVISION= 1
+DISTVERSION= 0.31
+PORTREVISION= 0
CATEGORIES= www
-MASTER_SITES= http://anders.fupp.net/distfiles/
PKGNAMEPREFIX= varnish-
-#DISTNAME= KristianLyng-${PORTNAME}-${VMOD_HEADER_HASH}
-#DISTFILES= KristianLyng-${PORTNAME}-${DISTVERSION}-g${VMOD_HEADER_HASH}.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Varnish Module (vmod) for manipulation of duplicated headers
LICENSE= BSD2CLAUSE
-BUILD_DEPENDS= ${LOCALBASE}/include/varnish/varnishapi.h:${PORTSDIR}/www/varnish \
+BUILD_DEPENDS= varnish4>=4.0.2:${PORTSDIR}/www/varnish4 \
rst2man:${PORTSDIR}/textproc/py-docutils
-USES= autoreconf gmake libtool pkgconfig
+USES= autoreconf gmake libtool pkgconfig python:2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/varnish
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/varnish
PLIST_FILES= man/man3/vmod_header.3.gz lib/varnish/vmods/libvmod_header.so
-WRKSRC= ${WRKDIR}/${PORTNAME}-master
INSTALL_TARGET= install-strip
+USE_GITHUB= yes
+GH_ACCOUNT= varnish
+GH_TAGNAME= e87ac92
+
.include <bsd.port.mk>
diff --git a/www/varnish-libvmod-header/distinfo b/www/varnish-libvmod-header/distinfo
index ca345ae782ea..33ecfc276833 100644
--- a/www/varnish-libvmod-header/distinfo
+++ b/www/varnish-libvmod-header/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libvmod-header-0.3-5.tar.gz) = fb05c375830398f57e7585c5ae5518e08b5aa1357f46c9b251c0c27acfc6ae03
-SIZE (libvmod-header-0.3-5.tar.gz) = 10386
+SHA256 (varnish-libvmod-header-0.31-e87ac92_GH0.tar.gz) = e4d96cca480ffa50e682b2cf5a6e713864d98546cc6763c30b3645396d9ea43e
+SIZE (varnish-libvmod-header-0.31-e87ac92_GH0.tar.gz) = 10450
diff --git a/www/varnish-libvmod-header/files/patch-configure.ac b/www/varnish-libvmod-header/files/patch-configure.ac
deleted file mode 100644
index d6b5ee7ed884..000000000000
--- a/www/varnish-libvmod-header/files/patch-configure.ac
+++ /dev/null
@@ -1,27 +0,0 @@
---- configure.ac.orig 2011-08-12 15:36:55.000000000 +0200
-+++ configure.ac 2011-08-30 01:46:23.000000000 +0200
-@@ -39,22 +39,8 @@
- # Check for python
- AC_CHECK_PROGS(PYTHON, [python3 python3.1 python3.2 python2.7 python2.6 python2.5 python2 python], [AC_MSG_ERROR([Python is needed to build this vmod, please install python.])])
-
--# Varnish source tree
--AC_ARG_VAR([VARNISHSRC], [path to Varnish source tree (mandatory)])
--if test "x$VARNISHSRC" = x; then
-- AC_MSG_ERROR([No Varnish source tree specified])
--fi
--VARNISHSRC=`cd $VARNISHSRC && pwd`
--AC_CHECK_FILE([$VARNISHSRC/include/varnishapi.h],
-- [],
-- [AC_MSG_FAILURE(["$VARNISHSRC" is not a Varnish source directory])]
--)
--
--# Check that varnishtest is built in the varnish source directory
--AC_CHECK_FILE([$VARNISHSRC/bin/varnishtest/varnishtest],
-- [],
-- [AC_MSG_FAILURE([Can't find "$VARNISHSRC/bin/varnishtest/varnishtest". Please build your varnish source directory])]
--)
-+AC_CHECK_HEADERS([varnish/varnishapi.h], , AC_MSG_ERROR([Could not find varnish/varnishapi.h]))
-+AC_CHECK_PROGS(VARNISHTEST, varnishtest, [AC_MSG_ERROR([Could not find varnishtest binary])])
-
- # vmod installation dir
- AC_ARG_VAR([VMODDIR], [vmod installation directory @<:@LIBDIR/varnish/vmods@:>@])
diff --git a/www/varnish-libvmod-header/files/patch-src-Makefile.am b/www/varnish-libvmod-header/files/patch-src-Makefile.am
deleted file mode 100644
index a6cd1c57fa4d..000000000000
--- a/www/varnish-libvmod-header/files/patch-src-Makefile.am
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Makefile.am.orig 2011-08-31 00:29:01.000000000 +0200
-+++ src/Makefile.am 2011-08-31 00:29:52.000000000 +0200
-@@ -10,8 +10,8 @@
- vcc_if.h \
- vmod_header.c
-
--vcc_if.c vcc_if.h: $(VARNISHSRC)/lib/libvmod_std/vmod.py $(top_srcdir)/src/vmod_header.vcc
-- @PYTHON@ $(VARNISHSRC)/lib/libvmod_std/vmod.py $(top_srcdir)/src/vmod_header.vcc
-+vcc_if.c vcc_if.h: $(LOCALBASE)/share/varnish/vmod.py $(top_srcdir)/src/vmod_header.vcc
-+ @PYTHON@ $(LOCALBASE)/share/varnish/vmod.py $(top_srcdir)/src/vmod_header.vcc
-
- VMOD_TESTS = tests/*.vtc
- .PHONY: $(VMOD_TESTS)
diff --git a/www/varnish-libvmod-header/files/patch-src-vmod_header.c b/www/varnish-libvmod-header/files/patch-src-vmod_header.c
deleted file mode 100644
index c352ddf1cbb6..000000000000
--- a/www/varnish-libvmod-header/files/patch-src-vmod_header.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/vmod_header.c.orig 2011-08-31 00:58:34.000000000 +0200
-+++ src/vmod_header.c 2011-08-31 00:59:08.000000000 +0200
-@@ -30,8 +30,8 @@
- #include <pthread.h>
-
- #include "vrt.h"
--#include "bin/varnishd/cache.h"
--#include "include/vct.h"
-+#include "varnish/cache.h"
-+#include "vct.h"
-
- #include "vcc_if.h"
- #include "config.h"