aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorEygene Ryabinkin <rea@FreeBSD.org>2010-11-26 13:53:56 +0000
committerEygene Ryabinkin <rea@FreeBSD.org>2010-11-26 13:53:56 +0000
commitb0baa75cefff085d57ab71c6bc418517dd79ecd3 (patch)
tree3d267ab64c5ea6f081b4e36a3a1c64108dce56ed /www
parente5edc23e83d4de4b53f958f2bd60ba4a32726e7c (diff)
downloadports-b0baa75cefff085d57ab71c6bc418517dd79ecd3.tar.gz
ports-b0baa75cefff085d57ab71c6bc418517dd79ecd3.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/redmine-http-auth/Makefile20
-rw-r--r--www/redmine-http-auth/distinfo2
-rw-r--r--www/redmine-http-auth/pkg-descr3
-rw-r--r--www/redmine/bsd.redmine.mk80
5 files changed, 106 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb83244d4df8..bdf192a2f961 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1525,6 +1525,7 @@
SUBDIR += red5
SUBDIR += redmine
SUBDIR += redmine-basecamp
+ SUBDIR += redmine-http-auth
SUBDIR += rejik
SUBDIR += rekonq
SUBDIR += reportmagic
diff --git a/www/redmine-http-auth/Makefile b/www/redmine-http-auth/Makefile
new file mode 100644
index 000000000000..8e1893eccd43
--- /dev/null
+++ b/www/redmine-http-auth/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: redmine-http-auth
+# Date created: 2010-09-12
+# Whom: Eygene Ryabinkin <rea-fbsd@codelabs.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= http-auth
+PORTVERSION= 20100730
+CATEGORIES= www
+MASTER_SITES= http://dist.codelabs.ru/fbsd/
+DISTNAME= AdamLantos-redmine_http_auth-${GITREV}
+
+MAINTAINER= rea@FreeBSD.org
+COMMENT= HTTP authentication plugin for Redmine
+
+GITREV= df98baf
+REDMINE_PLUGIN_NAME= redmine_http_auth
+
+.include "${.CURDIR}/../../www/redmine/bsd.redmine.mk"
diff --git a/www/redmine-http-auth/distinfo b/www/redmine-http-auth/distinfo
new file mode 100644
index 000000000000..b4d0a3af95da
--- /dev/null
+++ b/www/redmine-http-auth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (AdamLantos-redmine_http_auth-df98baf.tar.gz) = a03b456005b8d3c07bc3c3aeaaaf3d3a37ce5c73a71d76f1d593791c98384686
+SIZE (AdamLantos-redmine_http_auth-df98baf.tar.gz) = 6930
diff --git a/www/redmine-http-auth/pkg-descr b/www/redmine-http-auth/pkg-descr
new file mode 100644
index 000000000000..93c492b6ebc1
--- /dev/null
+++ b/www/redmine-http-auth/pkg-descr
@@ -0,0 +1,3 @@
+HTTP authentication plugin for Redmine.
+
+WWW: http://github.com/AdamLantos/redmine_http_auth/
diff --git a/www/redmine/bsd.redmine.mk b/www/redmine/bsd.redmine.mk
new file mode 100644
index 000000000000..3468f4d74b8b
--- /dev/null
+++ b/www/redmine/bsd.redmine.mk
@@ -0,0 +1,80 @@
+# Module that simplifies installation of Redmine plugins.
+#
+# Date created: 2010-09-12
+# Whom: Eygene Ryabinkin <rea-fbsd@codelabs.ru>
+#
+# $FreeBSD$
+#
+# We're assuming standard plugin installation sequence that is described
+# in the http://www.redmine.org/wiki/redmine/Plugins
+#
+# Basically, we need the following variables to be defined:
+# - REDMINE_PLUGIN_NAME: the name of the plugin;
+# - WWWDIR: the location of the Redmine installation;
+# the default value is ${PREFIX}/www/redmine;
+# the directory must lie under ${PREFIX} or such configuration
+# will be IGNORE'd;
+# - WRKSRC must be set to the root directory of the plugin contents:
+# we will copy all objects in this directory to the plugin's
+# destination directory, excluding all files named *.orig.
+#
+# PLIST will be generated automatically, there is no need to worry
+# about it. But if you will need to use your own (even the standard
+# packaging list in ${PORTDIR}/pkg-plist), set the variable PLIST
+# pointing to that file.
+#
+# You can override the target 'do-build', but in this case, you should
+# remember that the target named 'redmine-plugin-plist' does the
+# automated generation of the PLIST: use it if you need.
+#
+#
+# Here is an example of a simple Makefile for Redmine plugin:
+# {{{
+# PORTNAME= me-the-plugin
+# PORTVERSION= 1.0
+# CATEGORIES= www
+# MASTER_SITES= http://cool.org.name/some/path/
+#
+# MAINTAINER= you@your.org
+# COMMENT= Another cool plugin for Redmine
+#
+# REDMINE_PLUGIN_NAME= redmine_http_auth
+#
+# .include "${.CURDIR}/../../www/redmine/bsd.redmine.mk"
+# }}}
+
+PKGNAMEPREFIX?= redmine-
+
+RUN_DEPENDS+= redmine>=0.9:${PORTSDIR}/www/redmine
+
+USE_RUBY= yes
+.if !defined(PLIST)
+PLIST= ${WRKDIR}/PLIST
+_GEN_PLIST= YesPlease
+.endif
+
+WWWDIR?= ${PREFIX}/www/redmine
+WWWDIR_REL= ${WWWDIR:S|^${PREFIX}/||}
+
+.if ${WWWDIR_REL} == ${WWWDIR}
+IGNORE= WWWDIR is not a child of PREFIX (${PREFIX})
+.endif
+
+.if !defined(do-build)
+do-build: redmine-plugin-plist
+ @${DO_NADA}
+.endif
+
+redmine-plugin-plist:
+.if defined(_GEN_PLIST)
+ cd ${WRKSRC} && ${FIND} . -type f | ${GREP} -v '\.orig$$' | ${SED} -e's|^\.|${WWWDIR_REL}/vendor/plugins/${REDMINE_PLUGIN_NAME}|' >> ${PLIST}
+ cd ${WRKSRC} && ${FIND} -d . -type d | ${SED} -e's|^\.|@dirrm ${WWWDIR_REL}/vendor/plugins/${REDMINE_PLUGIN_NAME}|' >> ${PLIST}
+.else
+ @${DO_NADA}
+.endif
+
+do-install:
+ ${MKDIR} "${WWWDIR}/vendor/plugins/${REDMINE_PLUGIN_NAME}"
+ ${TAR} -C "${WRKSRC}" -cf - --exclude '*.orig' . | ${TAR} -C "${WWWDIR}/vendor/plugins/${REDMINE_PLUGIN_NAME}" -xf -
+
+.include <bsd.port.mk>