aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-14 18:42:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-14 18:42:04 +0000
commitffb7170399b77f34a48875ad6468eb796f00aed3 (patch)
tree3a1e4c5d813ec945366f43d48f94fa325ba0ead9 /www
parentc60af5b21ccf5bfc632b51afe126bbc7dac29ddd (diff)
downloadports-ffb7170399b77f34a48875ad6468eb796f00aed3.tar.gz
ports-ffb7170399b77f34a48875ad6468eb796f00aed3.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/abyssws/Makefile2
-rw-r--r--www/awffull/Makefile8
-rw-r--r--www/cadaver/Makefile2
-rw-r--r--www/cas/Makefile8
-rw-r--r--www/gnome-web-photo/Makefile2
-rw-r--r--www/httpsqs/Makefile4
-rw-r--r--www/hypermail/Makefile4
-rw-r--r--www/links-hacked/Makefile10
-rw-r--r--www/mod_auth_openid/Makefile4
-rw-r--r--www/mod_dnssd/Makefile2
-rw-r--r--www/mod_gnutls/Makefile2
-rw-r--r--www/multiwatch/Makefile2
-rw-r--r--www/newsbeuter/Makefile4
-rw-r--r--www/oops/Makefile6
-rw-r--r--www/pecl-http/Makefile2
-rw-r--r--www/pecl-solr/Makefile4
-rw-r--r--www/pound/Makefile2
-rw-r--r--www/privoxy/Makefile2
-rw-r--r--www/py-bjoern/Makefile2
-rw-r--r--www/py-jswebkit/Makefile4
-rw-r--r--www/py-qt4-webkit/Makefile2
-rw-r--r--www/py-utidy/Makefile2
-rw-r--r--www/rejik/Makefile2
-rw-r--r--www/rubygem-ethon/Makefile2
-rw-r--r--www/sitecopy/Makefile2
-rw-r--r--www/surf/Makefile2
-rw-r--r--www/xapian-omega10/Makefile2
-rw-r--r--www/xombrero/Makefile8
28 files changed, 49 insertions, 49 deletions
diff --git a/www/abyssws/Makefile b/www/abyssws/Makefile
index 3b925d86e16c..94b408ac24cb 100644
--- a/www/abyssws/Makefile
+++ b/www/abyssws/Makefile
@@ -24,7 +24,7 @@ NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700043
-LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
+LIB_DEPENDS+= libc.so.6:${PORTSDIR}/misc/compat6x
.endif
pre-install:
diff --git a/www/awffull/Makefile b/www/awffull/Makefile
index 60ac2109524d..1dfec9d5ddde 100644
--- a/www/awffull/Makefile
+++ b/www/awffull/Makefile
@@ -11,9 +11,9 @@ MAINTAINER?= chad@wickdev.com
COMMENT= AWFFull is a webserver log analysis tool forked from Webalizer
BUILD_DEPENDS= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
- png15:${PORTSDIR}/graphics/png \
- pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS?= ja-awffull-[0-9]*
@@ -36,7 +36,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGEOIP}
-LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+=--enable-geoip
.else
CONFIGURE_ARGS+=--disable-geoip
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index a58d398904a8..da98e5290284 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= http://www.webdav.org/cadaver/ \
MAINTAINER= jpaetzel@FreeBSD.org
COMMENT= Commandline client for DAV
-LIB_DEPENDS= neon:${PORTSDIR}/www/neon29
+LIB_DEPENDS= libneon.so:${PORTSDIR}/www/neon29
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-netrc
diff --git a/www/cas/Makefile b/www/cas/Makefile
index 72f136c99dc4..93943f51cf7a 100644
--- a/www/cas/Makefile
+++ b/www/cas/Makefile
@@ -12,9 +12,9 @@ COMMENT= C++ Application Server, version 2
BROKEN= Fails to build
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
- pcre:${PORTSDIR}/devel/pcre \
- ctpp2:${PORTSDIR}/textproc/ctpp2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libctpp2.so:${PORTSDIR}/textproc/ctpp2
USES= cmake iconv
USE_LDCONFIG= yes
@@ -82,7 +82,7 @@ PLIST_SUB+= APACHE2X_MODULE="@comment "
.endif
.if ${PORT_OPTIONS:MBUILD_CURL_XMLRPC_CLIENT}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CMAKE_ARGS+= -DBUILD_CURL_XMLRPC_CLIENT=ON
PLIST_SUB+= CURL_XMLRPC_CLIENT=""
.else
diff --git a/www/gnome-web-photo/Makefile b/www/gnome-web-photo/Makefile
index a94ff2c4293e..f2d24728ded6 100644
--- a/www/gnome-web-photo/Makefile
+++ b/www/gnome-web-photo/Makefile
@@ -13,7 +13,7 @@ COMMENT= Tool to generate full-size image files and thumbnails
LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
-LIB_DEPENDS= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
USE_XZ= yes
USE_GNOME= gconf2 gnomeprefix
diff --git a/www/httpsqs/Makefile b/www/httpsqs/Makefile
index f1ec6576e534..cc610afe7f13 100644
--- a/www/httpsqs/Makefile
+++ b/www/httpsqs/Makefile
@@ -11,8 +11,8 @@ COMMENT= Simple Queue Service based on HTTP GET/POST protocol
LICENSE= BSD
-LIB_DEPENDS+= tokyocabinet:${PORTSDIR}/databases/tokyocabinet \
- event-2.0:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS+= libtokyocabinet.so:${PORTSDIR}/databases/tokyocabinet \
+ libevent-2.0.so:${PORTSDIR}/devel/libevent2
USES= pkgconfig
diff --git a/www/hypermail/Makefile b/www/hypermail/Makefile
index 5761768a8ff3..37d6da4b717c 100644
--- a/www/hypermail/Makefile
+++ b/www/hypermail/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A program to generate a cross-referenced HTML mail archive
-LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm \
- pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm \
+ libpcre.so:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-htmldir=${PREFIX}/share/doc/hypermail \
diff --git a/www/links-hacked/Makefile b/www/links-hacked/Makefile
index 5a12d9f37ed2..6f968713073e 100644
--- a/www/links-hacked/Makefile
+++ b/www/links-hacked/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= http://xray.sai.msu.ru/~karpov/links-hacked/downloads/ http://link
MAINTAINER= peter@vereshagin.org
COMMENT= Hacked version of a Links WWW browser
-LIB_DEPENDS+= execinfo:${PORTSDIR}/devel/libexecinfo \
- gdbm:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libgdbm.so:${PORTSDIR}/databases/gdbm
CONFLICTS= links-[0-9]*
@@ -36,9 +36,9 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSVGALIB} || ${PORT_OPTIONS:MX11} || ${PORT_OPTIONS:MDIRECTFB}
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libtiff.so:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+= --enable-graphics
.else
CONFIGURE_ARGS+= --disable-graphics --without-libjpeg --without-libtiff
diff --git a/www/mod_auth_openid/Makefile b/www/mod_auth_openid/Makefile
index a8514e0a798e..9eb6e5a87648 100644
--- a/www/mod_auth_openid/Makefile
+++ b/www/mod_auth_openid/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= An authentication module for the Apache 2 webserver with OpenID
-LIB_DEPENDS= opkele:${PORTSDIR}/devel/libopkele \
- sqlite3:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS= libopkele.so:${PORTSDIR}/devel/libopkele \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3
PLIST_FILES= ${APACHEMODDIR}/mod_auth_openid.so
diff --git a/www/mod_dnssd/Makefile b/www/mod_dnssd/Makefile
index b1fcab3aeb3c..f92f3c43012e 100644
--- a/www/mod_dnssd/Makefile
+++ b/www/mod_dnssd/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= An Apache module that provides DNS-SD capabilities
-LIB_DEPENDS= avahi-client.3:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= libavahi-client.so:${PORTSDIR}/net/avahi-app
USES= gmake pkgconfig
USE_APACHE= 22
diff --git a/www/mod_gnutls/Makefile b/www/mod_gnutls/Makefile
index 2747f78c1bb9..f5924e4b22e2 100644
--- a/www/mod_gnutls/Makefile
+++ b/www/mod_gnutls/Makefile
@@ -15,7 +15,7 @@ COMMENT= mod_gnutls uses the GnuTLS library to provide SSL, and TLS encryption f
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= gnutls.26:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
diff --git a/www/multiwatch/Makefile b/www/multiwatch/Makefile
index 364bad878152..637adf914496 100644
--- a/www/multiwatch/Makefile
+++ b/www/multiwatch/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://download.lighttpd.net/multiwatch/releases-1.x/
MAINTAINER= chris+freebsd@chrullrich.net
COMMENT= Spawn-fcgi helper for forking multiple workers
-LIB_DEPENDS= ev:${PORTSDIR}/devel/libev
+LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
GNU_CONFIGURE= yes
diff --git a/www/newsbeuter/Makefile b/www/newsbeuter/Makefile
index aa542b1539ab..2a6ae4bbac7e 100644
--- a/www/newsbeuter/Makefile
+++ b/www/newsbeuter/Makefile
@@ -13,8 +13,8 @@ COMMENT= An RSS feed reader for the text console
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= stfl:${PORTSDIR}/devel/stfl \
- curl:${PORTSDIR}/ftp/curl \
+LIB_DEPENDS= libstfl.so:${PORTSDIR}/devel/stfl \
+ libcurl.so:${PORTSDIR}/ftp/curl \
libjson.so:${PORTSDIR}/devel/json-c
OPTIONS_DEFINE= PODCAST
diff --git a/www/oops/Makefile b/www/oops/Makefile
index b2977e795d90..cf71272ac4e7 100644
--- a/www/oops/Makefile
+++ b/www/oops/Makefile
@@ -61,12 +61,12 @@ PGSQL_DESC= PostgreSQL auth support
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGIGABASE}
-LIB_DEPENDS+= gigabase_r.2:${PORTSDIR}/databases/gigabase
+LIB_DEPENDS+= libgigabase_r.so:${PORTSDIR}/databases/gigabase
CONFIGURE_ARGS+= --without-DB
.endif
.if ${PORT_OPTIONS:MDB4}
-LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
+LIB_DEPENDS+= libdb4.so:${PORTSDIR}/databases/db4
CONFIGURE_ARGS+= --without-GB
.endif
@@ -81,7 +81,7 @@ CONFIGURE_ARGS+= --with-PGSQL=${PREFIX}/pgsql
.endif
.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-regexp=pcre
.endif
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
index 82c3699c6262..dcecfd6a17ab 100644
--- a/www/pecl-http/Makefile
+++ b/www/pecl-http/Makefile
@@ -12,7 +12,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= miwi@FreeBSD.org
COMMENT= Extended HTTP Support
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
USE_PHP= yes
USE_PHPEXT= yes
diff --git a/www/pecl-solr/Makefile b/www/pecl-solr/Makefile
index 66437033eca0..f6d103477cf5 100644
--- a/www/pecl-solr/Makefile
+++ b/www/pecl-solr/Makefile
@@ -11,8 +11,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gaod@hychen.org
COMMENT= The Apache Solr PHP extension
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
USE_PHP= json
USE_PHPEXT= yes
diff --git a/www/pound/Makefile b/www/pound/Makefile
index 0eb945b22a15..01937d190a93 100644
--- a/www/pound/Makefile
+++ b/www/pound/Makefile
@@ -40,7 +40,7 @@ CONFIGURE_ARGS+= --enable-msdav
.endif
.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
CFLAGS+= "-I${LOCALBASE}/include"
CPPFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= "-L${LOCALBASE}/lib"
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 8b49b9e4108e..81adca403190 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -11,7 +11,7 @@ DISTNAME= privoxy-${PORTVERSION}-stable-src
MAINTAINER= fk@fabiankeil.de
COMMENT= Privoxy is a web proxy with advanced filtering capabilities
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
WRKSRC= ${WRKDIR}/privoxy-${PORTVERSION}-stable
diff --git a/www/py-bjoern/Makefile b/www/py-bjoern/Makefile
index 9c5f314a1366..cc36e50bc0ea 100644
--- a/www/py-bjoern/Makefile
+++ b/www/py-bjoern/Makefile
@@ -12,7 +12,7 @@ COMMENT= Fast Python WSGI server
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= ev:${PORTSDIR}/devel/libev
+LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
USE_PYTHON= 2
USE_PYDISTUTILS= yes
diff --git a/www/py-jswebkit/Makefile b/www/py-jswebkit/Makefile
index 267c81540037..7fcf972a8247 100644
--- a/www/py-jswebkit/Makefile
+++ b/www/py-jswebkit/Makefile
@@ -13,8 +13,8 @@ DISTNAME= python-${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= WebKit/JavaScriptCore Python bindings
-BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython
-LIB_DEPENDS= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
+BUILD_DEPENDS= libcython.so:${PORTSDIR}/lang/cython
+LIB_DEPENDS= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= pkgconfig
diff --git a/www/py-qt4-webkit/Makefile b/www/py-qt4-webkit/Makefile
index 7edb5ff81df5..3e66698ca556 100644
--- a/www/py-qt4-webkit/Makefile
+++ b/www/py-qt4-webkit/Makefile
@@ -44,7 +44,7 @@ ARGS= -b ${PREFIX}/bin \
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/www/py-utidy/Makefile b/www/py-utidy/Makefile
index 21db76696eef..504c07e695ac 100644
--- a/www/py-utidy/Makefile
+++ b/www/py-utidy/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Python interface to tidy-lib
# XXX Better depend on tidy or tidy-devel???
-LIB_DEPENDS= tidy-0.99.0:${PORTSDIR}/www/tidy-lib
+LIB_DEPENDS= libtidy-0.99.so:${PORTSDIR}/www/tidy-lib
USES= zip
USE_PYTHON= 2
diff --git a/www/rejik/Makefile b/www/rejik/Makefile
index 0b1e939f06b6..72b9a31053e5 100644
--- a/www/rejik/Makefile
+++ b/www/rejik/Makefile
@@ -15,7 +15,7 @@ COMMENT= A squid redirector used for blocking unwanted content
BROKEN= Fails to checksum
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= squid:${PORTSDIR}/www/squid
PLIST_SUB= INSTALL_DIR=${INSTALL_DIR}
diff --git a/www/rubygem-ethon/Makefile b/www/rubygem-ethon/Makefile
index 6005395cc357..bd53ee2cc177 100644
--- a/www/rubygem-ethon/Makefile
+++ b/www/rubygem-ethon/Makefile
@@ -11,7 +11,7 @@ COMMENT= Very lightweight libcurl wrapper
RUN_DEPENDS= rubygem-ffi>=1.3.0:${PORTSDIR}/devel/rubygem-ffi \
rubygem-mime-types>=1.18:${PORTSDIR}/misc/rubygem-mime-types
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/www/sitecopy/Makefile b/www/sitecopy/Makefile
index f7a5ee6a07a5..5cc6c98ea020 100644
--- a/www/sitecopy/Makefile
+++ b/www/sitecopy/Makefile
@@ -12,7 +12,7 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= sitecopy@oldach.net
COMMENT= Maintains remote websites, uses FTP or WebDAV to sync up w/ local copy
-LIB_DEPENDS= neon.27:${PORTSDIR}/www/neon29
+LIB_DEPENDS= libneon.so:${PORTSDIR}/www/neon29
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/www/surf/Makefile b/www/surf/Makefile
index 8ebc73707464..e7178bd5a478 100644
--- a/www/surf/Makefile
+++ b/www/surf/Makefile
@@ -13,7 +13,7 @@ COMMENT= Simple Web browser based on WebKit/Gtk+
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu
USE_CSTD= c99
diff --git a/www/xapian-omega10/Makefile b/www/xapian-omega10/Makefile
index 438ca450a3ce..9d382b2fd561 100644
--- a/www/xapian-omega10/Makefile
+++ b/www/xapian-omega10/Makefile
@@ -12,7 +12,7 @@ COMMENT= CGI search application built on Xapian
LICENSE= GPLv2
-LIB_DEPENDS= xapian:${PORTSDIR}/databases/xapian-core10
+LIB_DEPENDS= libxapian.so:${PORTSDIR}/databases/xapian-core10
USES= perl5
GNU_CONFIGURE= yes
diff --git a/www/xombrero/Makefile b/www/xombrero/Makefile
index eed52719c1eb..22b16b0e93a7 100644
--- a/www/xombrero/Makefile
+++ b/www/xombrero/Makefile
@@ -12,8 +12,8 @@ COMMENT= Minimalists vi-like web browser based on webkit and GTK+
LICENSE= ISCL
-LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
- soup-2.4:${PORTSDIR}/devel/libsoup
+LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
+ libsoup-2.4.so:${PORTSDIR}/devel/libsoup
USES= pkgconfig perl5
USE_PERL5= build
@@ -35,11 +35,11 @@ BROKEN= does not build due to missing arc4random_buf in libc
.if ${PORT_OPTIONS:MGTK2}
USE_GNOME= gtk20
-LIB_DEPENDS+= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS+= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
MAKE_ENV+= GTK_VERSION="gtk2"
.else # GTK3
USE_GNOME= gtk30
-LIB_DEPENDS+= webkitgtk-3.0:${PORTSDIR}/www/webkit-gtk3
+LIB_DEPENDS+= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3
MAKE_ENV+= GTK_VERSION="gtk3"
.endif