aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-05-28 12:36:05 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-05-28 12:36:05 +0000
commitdc44c65e8351b2443bd596b934c06e53110c3ece (patch)
treedf44d48455c5e496aad63806ef6999cf964f1e2c /www
parentea6e094c43c7391fda31bb597cce8d4c1e130a55 (diff)
downloadports-dc44c65e8351b2443bd596b934c06e53110c3ece.tar.gz
ports-dc44c65e8351b2443bd596b934c06e53110c3ece.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_fileiri/Makefile26
-rw-r--r--www/mod_fileiri/distinfo3
-rw-r--r--www/mod_fileiri/pkg-descr15
-rw-r--r--www/mod_fileiri/pkg-plist3
5 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 347fe3272882..60f2671b3386 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -401,6 +401,7 @@
SUBDIR += mod_extract_forwarded2
SUBDIR += mod_fastcgi
SUBDIR += mod_fcgid
+ SUBDIR += mod_fileiri
SUBDIR += mod_filter
SUBDIR += mod_geoip
SUBDIR += mod_geoip2
diff --git a/www/mod_fileiri/Makefile b/www/mod_fileiri/Makefile
new file mode 100644
index 000000000000..2c96c4f2c540
--- /dev/null
+++ b/www/mod_fileiri/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mod_fileiri
+# Date created: 2008/05/27
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_fileiri
+PORTVERSION= 1.15
+CATEGORIES= www
+MASTER_SITES= LOCAL/chinsan
+DIST_SUBDIR= apache2
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= A http IRIs module for Apache 2
+
+USE_APACHE= 20+
+PLIST_SUB= APACHE_DIR=${APACHEMODDIR}
+
+do-build:
+ cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -c -n fileiri ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_fileiri/distinfo b/www/mod_fileiri/distinfo
new file mode 100644
index 000000000000..b311ed4b4f48
--- /dev/null
+++ b/www/mod_fileiri/distinfo
@@ -0,0 +1,3 @@
+MD5 (apache2/mod_fileiri-1.15.tar.gz) = 1f948b9287a758b665a533bfe329279e
+SHA256 (apache2/mod_fileiri-1.15.tar.gz) = 103c211c3236420fb207133ee2c540c9ea6adabc803db1872e18918cf4cfbc59
+SIZE (apache2/mod_fileiri-1.15.tar.gz) = 6985
diff --git a/www/mod_fileiri/pkg-descr b/www/mod_fileiri/pkg-descr
new file mode 100644
index 000000000000..a98caac15ea8
--- /dev/null
+++ b/www/mod_fileiri/pkg-descr
@@ -0,0 +1,15 @@
+mod_fileiri implements http IRIs for directories/files, i.e.
+if accepts URIs with non-ASCII characters encoded in UTF-8 and
+converts them to the legacy encoding used in the file system
+(which can be specified per directory, or even finer if necessary
+(although that's a real hack)).
+
+What is more, it continues to accept requests in the legacy
+encoding specified, and redirects them to the correct UTF-8
+form, which then returns the actual document (without looping).
+
+There is also a backwards mode, which does redirects from
+URIs in a specified legacy encoding to UTF-8 if the directory/
+filenames are in UTF-8.
+
+WWW: http://www.w3.org/2003/06/mod_fileiri/
diff --git a/www/mod_fileiri/pkg-plist b/www/mod_fileiri/pkg-plist
new file mode 100644
index 000000000000..e06ed0ee93d3
--- /dev/null
+++ b/www/mod_fileiri/pkg-plist
@@ -0,0 +1,3 @@
+%%APACHE_DIR%%/mod_fileiri.so
+@exec %D/sbin/apxs -e -a -n fileiri %D/%F
+@unexec %D/sbin/apxs -e -A -n fileiri %D/%F