aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-11-30 11:20:35 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-11-30 11:20:35 +0000
commita32054e27e48a43f510d8492e6b3576631d7f78b (patch)
tree4f2575b21e1e56fb382ab5d276467a708cec2a64 /www
parentfcc2e35e3d253759b70e167ec3381bdff8af376d (diff)
downloadports-a32054e27e48a43f510d8492e6b3576631d7f78b.tar.gz
ports-a32054e27e48a43f510d8492e6b3576631d7f78b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/htmlcxx/Makefile5
-rw-r--r--www/htmlcxx/files/patch-css_syntax.y27
-rw-r--r--www/htmlcxx/pkg-plist5
-rw-r--r--www/webkit-gtk2/files/patch-Source_ThirdParty_ANGLE_src_compiler_glslang.y13
4 files changed, 39 insertions, 11 deletions
diff --git a/www/htmlcxx/Makefile b/www/htmlcxx/Makefile
index 9c50e4cde503..7ee8eb6cc1db 100644
--- a/www/htmlcxx/Makefile
+++ b/www/htmlcxx/Makefile
@@ -12,13 +12,12 @@ COMMENT= HTML and CSS APIs for C++
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/LGPL_V2
-BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
-
-USES= iconv libtool
+USES= bison iconv libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE=yes
diff --git a/www/htmlcxx/files/patch-css_syntax.y b/www/htmlcxx/files/patch-css_syntax.y
index e3c6863cf777..143e76298f83 100644
--- a/www/htmlcxx/files/patch-css_syntax.y
+++ b/www/htmlcxx/files/patch-css_syntax.y
@@ -1,9 +1,30 @@
---- css/css_syntax.y.orig 2012-09-19 15:27:03.000000000 +0800
-+++ css/css_syntax.y 2012-09-19 15:28:12.000000000 +0800
-@@ -1,5 +1,6 @@
+--- css/css_syntax.y.orig 2011-02-13 22:24:53 UTC
++++ css/css_syntax.y
+@@ -1,16 +1,17 @@
%{
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include "css_lex.h"
#include "parser.h"
+
+-#define YYPARSE_PARAM yyparam
+ #define YYERROR_VERBOSE 1
+ //#define YYDEBUG 1
+
+ %}
+
+ %pure_parser
++%parse-param { struct selector_list_t **yyparam }
+
+ %union {
+ char *lexeme;
+@@ -571,7 +572,7 @@ hexcolor
+
+ %%
+
+-int yyerror(char *s) {
++int yyerror(struct selector_list_t **yyparam, char *s) {
+ #if YYDEBUG
+ fprintf(stderr, "Error: %s\n", s);
+ #endif
diff --git a/www/htmlcxx/pkg-plist b/www/htmlcxx/pkg-plist
index e5af6fce728b..a2b68a80c112 100644
--- a/www/htmlcxx/pkg-plist
+++ b/www/htmlcxx/pkg-plist
@@ -23,8 +23,3 @@ lib/libhtmlcxx.so
lib/libhtmlcxx.so.3
lib/libhtmlcxx.so.3.1.0
share/htmlcxx/css/default.css
-@dirrm share/htmlcxx/css
-@dirrm share/htmlcxx
-@dirrm include/htmlcxx/html
-@dirrm include/htmlcxx/css
-@dirrm include/htmlcxx
diff --git a/www/webkit-gtk2/files/patch-Source_ThirdParty_ANGLE_src_compiler_glslang.y b/www/webkit-gtk2/files/patch-Source_ThirdParty_ANGLE_src_compiler_glslang.y
new file mode 100644
index 000000000000..99d78abc05c6
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-Source_ThirdParty_ANGLE_src_compiler_glslang.y
@@ -0,0 +1,13 @@
+Allow building with bison 3
+Obtained from http://trac.webkit.org/changeset/154109/trunk/Source/ThirdParty/ANGLE/src/compiler/glslang.y
+
+--- Source/ThirdParty/ANGLE/src/compiler/glslang.y.orig 2012-08-20 16:26:06 UTC
++++ Source/ThirdParty/ANGLE/src/compiler/glslang.y
+@@ -32,6 +32,7 @@ WHICH GENERATES THE GLSL ES PARSER (glsl
+ %expect 1 /* One shift reduce conflict because of if | else */
+ %pure-parser
+ %parse-param {TParseContext* context}
++%lex-param {YYLEX_PARAM}
+
+ %union {
+ struct {