aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-10-31 06:13:48 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-10-31 06:13:48 +0000
commitb987573bdca1d55a0ff381e5d6c3a01dc02693d6 (patch)
treed124d1c6ddb8f7f986981a43002e2a959aa5c7bc /www
parent9bac0e7cd8f5f90e97cfdc5167d74f9b2bcc2909 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/webserver/Makefile30
-rw-r--r--www/webserver/distinfo3
-rw-r--r--www/webserver/pkg-descr10
-rw-r--r--www/webserver/pkg-plist10
5 files changed, 54 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ba419c8dfbf5..9506ed138ac1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1073,6 +1073,7 @@
SUBDIR += webredirect
SUBDIR += webreport
SUBDIR += webresolve
+ SUBDIR += webserver
SUBDIR += webstats
SUBDIR += webstone
SUBDIR += webstone-ssl
diff --git a/www/webserver/Makefile b/www/webserver/Makefile
new file mode 100644
index 000000000000..16c4f25f59c3
--- /dev/null
+++ b/www/webserver/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: webserver
+# Date created: 29 Oct 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= webserver
+PORTVERSION= 1.1.0
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_GNUSTEP}
+MASTER_SITE_SUBDIR= libs
+DISTNAME= WebServer-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Framework for a GNUstep to act as HTTP or HTTPS server
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BASE= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET=
+LDCONFIG_DIRS= ${LOCALLIBDIR}
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+
+.include <bsd.port.mk>
diff --git a/www/webserver/distinfo b/www/webserver/distinfo
new file mode 100644
index 000000000000..c5820feb2ec5
--- /dev/null
+++ b/www/webserver/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebServer-1.1.0.tar.gz) = 80eb3531cb1088ded0ce524f6646bf58
+SHA256 (WebServer-1.1.0.tar.gz) = 821433041c35f2bc6914e549be496e4c0a320db5a3a6385a1af0ecd9425ce8e8
+SIZE (WebServer-1.1.0.tar.gz) = 21772
diff --git a/www/webserver/pkg-descr b/www/webserver/pkg-descr
new file mode 100644
index 000000000000..8e2249aaec29
--- /dev/null
+++ b/www/webserver/pkg-descr
@@ -0,0 +1,10 @@
+The WebServer class provides the framework for a GNUstep program to act
+as an HTTP or HTTPS server for simple applications.
+It does not attempt to be a general-purpose web server, but is rather
+intended to permit a program to easily handle requests from automated
+systems which are intended to control, monitor, or use the services
+provided by the program in which the class is embedded.
+The emphasis is on making it robust/reliable/simple, so you can rapidly
+develop software using it. It is a single-threaded, single-process
+system using asynchronous I/O, so you can easily run it under debug
+in gdb to fix any bugs in your delegate object.
diff --git a/www/webserver/pkg-plist b/www/webserver/pkg-plist
new file mode 100644
index 000000000000..069b6a6c2920
--- /dev/null
+++ b/www/webserver/pkg-plist
@@ -0,0 +1,10 @@
+Local/Library/Documentation/WebServer/WebServer.gsdoc
+Local/Library/Documentation/WebServer/WebServer.html
+Local/Library/Documentation/WebServer/WebServer.igsdoc
+Local/Library/Documentation/WebServer/dependencies
+Local/Library/Headers/WebServer/WebServer.h
+Local/Library/Libraries/libWebServer.so
+Local/Library/Libraries/libWebServer.so.%%MAJORVERSION%%.1
+Local/Library/Libraries/libWebServer.so.%%VERSION%%
+@dirrm Local/Library/Headers/WebServer
+@dirrm Local/Library/Documentation/WebServer