aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-05-04 21:41:30 +0000
committerAde Lovett <ade@FreeBSD.org>2001-05-04 21:41:30 +0000
commitbc47cccc84a1837da1919cf6c75785c9646d1761 (patch)
treef7a9d348554d6994c70ad84089b6b749b7ac60fd /www
parent7ce0c30d7530087588921aedd4971eec44d11823 (diff)
downloadports-bc47cccc84a1837da1919cf6c75785c9646d1761.tar.gz
ports-bc47cccc84a1837da1919cf6c75785c9646d1761.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/barque/Makefile9
-rw-r--r--www/comclear/Makefile17
-rw-r--r--www/encompass/Makefile8
-rw-r--r--www/mozilla+ipv6/Makefile4
-rw-r--r--www/mozilla-devel/Makefile3
-rw-r--r--www/mozilla-vendor/Makefile3
-rw-r--r--www/mozilla/Makefile3
-rw-r--r--www/p5-GtkHTML/Makefile3
-rw-r--r--www/screem-devel/Makefile9
-rw-r--r--www/screem/Makefile9
-rw-r--r--www/seamonkey/Makefile3
-rw-r--r--www/seamonkey2/Makefile3
-rw-r--r--www/viewml/Makefile5
13 files changed, 38 insertions, 41 deletions
diff --git a/www/barque/Makefile b/www/barque/Makefile
index 9ac1e2af4194..c46fc8d8c3f5 100644
--- a/www/barque/Makefile
+++ b/www/barque/Makefile
@@ -7,6 +7,7 @@
PORTNAME= barque
PORTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,12 +15,8 @@ DISTFILES= ${PORTNAME}-0.1-2.tar.gz
MAINTAINER= nakai@FreeBSD.org
-LIB_DEPENDS= gtkhtml.8:${PORTSDIR}/www/gtkhtml \
- bonobo.2:${PORTSDIR}/devel/bonobo \
- gconf-1.1:${PORTSDIR}/devel/gconf \
- gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
- ghttp.1:${PORTSDIR}/www/libghttp \
- glade.4:${PORTSDIR}/devel/libglade
+LIB_DEPENDS= gtkhtml.10:${PORTSDIR}/www/gtkhtml \
+ ghttp.1:${PORTSDIR}/www/libghttp
WRKSRC= ${WRKDIR}/${PORTNAME}-0.1-2
diff --git a/www/comclear/Makefile b/www/comclear/Makefile
index 2e1c53cde1ac..60ad81501fc5 100644
--- a/www/comclear/Makefile
+++ b/www/comclear/Makefile
@@ -7,19 +7,22 @@
PORTNAME= comclear
PORTVERSION= 1.1
-CATEGORIES= www
+PORTREVISION= 1
+CATEGORIES= www gtk
MASTER_SITES= http://www.neuro-tech.net/files/
MAINTAINER= roam@FreeBSD.org
-.if defined(WITH_GTK)
-BUILD_DEPENDS= ${X11BASE}/bin/gtk12-config:${PORTSDIR}/x11-toolkits/gtk12/
-CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk12-config
-.endif
-
+WANT_GTK= yes
USE_GMAKE= yes
USE_AUTOMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GTK)
+USE_GTK= yes
+.endif
+
# Do not install docs by default, see the ifdef'd post-install below.
post-configure:
${PERL} -pi.fbsd -e 's/^install-data-am:.*/install-data-am:/' ${WRKSRC}/Makefile
@@ -29,4 +32,4 @@ post-install:
cd ${WRKSRC} && ${GMAKE} install-docDATA
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/encompass/Makefile b/www/encompass/Makefile
index afcb392d4b65..3a316be6071a 100644
--- a/www/encompass/Makefile
+++ b/www/encompass/Makefile
@@ -7,6 +7,7 @@
PORTNAME= encompass
PORTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= http://dobey.free.fr/encompass/ \
http://zephyr.webhop.net/encompass/ \
@@ -14,12 +15,7 @@ MASTER_SITES= http://dobey.free.fr/encompass/ \
MAINTAINER= sobomax@FreeBSD.org
-LIB_DEPENDS= gtkhtml.8:${PORTSDIR}/www/gtkhtml \
- glibwww.1:${PORTSDIR}/www/glibwww \
- gconf-1.1:${PORTSDIR}/devel/gconf \
- gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
- gnomeprint.13:${PORTSDIR}/print/gnomeprint
-RUN_DEPENDS= ${X11BASE}/share/gnome/sounds/login.wav:${PORTSDIR}/audio/gnomeaudio
+LIB_DEPENDS= gtkhtml.10:${PORTSDIR}/www/gtkhtml
USE_GNOME= yes
USE_X_PREFIX= yes
diff --git a/www/mozilla+ipv6/Makefile b/www/mozilla+ipv6/Makefile
index 09acf516df68..a7a4e052c9be 100644
--- a/www/mozilla+ipv6/Makefile
+++ b/www/mozilla+ipv6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
PKGNAMESUFFIX= +ipv6
CATEGORIES= www ipv6
@@ -17,7 +17,7 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= sumikawa@FreeBSD.org
-LIB_DEPENDS= IDL.2:${PORTSDIR}/devel/ORBit \
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index c1bc8a68d316..c9bacfd2a754 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.8.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -15,7 +16,7 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= reg@FreeBSD.org
-LIB_DEPENDS= IDL.2:${PORTSDIR}/devel/ORBit \
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
diff --git a/www/mozilla-vendor/Makefile b/www/mozilla-vendor/Makefile
index c1bc8a68d316..c9bacfd2a754 100644
--- a/www/mozilla-vendor/Makefile
+++ b/www/mozilla-vendor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.8.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -15,7 +16,7 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= reg@FreeBSD.org
-LIB_DEPENDS= IDL.2:${PORTSDIR}/devel/ORBit \
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index c1bc8a68d316..c9bacfd2a754 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.8.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -15,7 +16,7 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= reg@FreeBSD.org
-LIB_DEPENDS= IDL.2:${PORTSDIR}/devel/ORBit \
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
diff --git a/www/p5-GtkHTML/Makefile b/www/p5-GtkHTML/Makefile
index d9c345d73e58..a967a3e5e939 100644
--- a/www/p5-GtkHTML/Makefile
+++ b/www/p5-GtkHTML/Makefile
@@ -7,6 +7,7 @@
PORTNAME= GtkHTML
PORTVERSION= 0.7005
+PORTREVISION= 1
CATEGORIES= www lang perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Gtk
@@ -16,7 +17,7 @@ DISTNAME= Gtk-Perl-${PORTVERSION}
MAINTAINER= vanilla@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gnome.pm:${PORTSDIR}/x11-toolkits/p5-Gnome
-LIB_DEPENDS= gtkhtml.8:${PORTSDIR}/www/gtkhtml
+LIB_DEPENDS= gtkhtml.10:${PORTSDIR}/www/gtkhtml
USE_GNOME= yes
PERL_CONFIGURE= yes
diff --git a/www/screem-devel/Makefile b/www/screem-devel/Makefile
index f1a4460143cc..af5acfbee3e4 100644
--- a/www/screem-devel/Makefile
+++ b/www/screem-devel/Makefile
@@ -7,18 +7,15 @@
PORTNAME= screem
PORTVERSION= 0.4.0
-CATEGORIES= www
+PORTREVISION= 1
+CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.screem.org/src/
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= glade.4:${PORTSDIR}/devel/libglade \
- guile.9:${PORTSDIR}/lang/guile \
- gtkhtml.8:${PORTSDIR}/www/gtkhtml \
- gnomeprint.13:${PORTSDIR}/print/gnomeprint \
- gnomevfs.0:${PORTSDIR}/devel/gnomevfs
+LIB_DEPENDS= gtkhtml.10:${PORTSDIR}/www/gtkhtml
USE_GMAKE= yes
USE_X_PREFIX= yes
diff --git a/www/screem/Makefile b/www/screem/Makefile
index f1a4460143cc..af5acfbee3e4 100644
--- a/www/screem/Makefile
+++ b/www/screem/Makefile
@@ -7,18 +7,15 @@
PORTNAME= screem
PORTVERSION= 0.4.0
-CATEGORIES= www
+PORTREVISION= 1
+CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.screem.org/src/
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= glade.4:${PORTSDIR}/devel/libglade \
- guile.9:${PORTSDIR}/lang/guile \
- gtkhtml.8:${PORTSDIR}/www/gtkhtml \
- gnomeprint.13:${PORTSDIR}/print/gnomeprint \
- gnomevfs.0:${PORTSDIR}/devel/gnomevfs
+LIB_DEPENDS= gtkhtml.10:${PORTSDIR}/www/gtkhtml
USE_GMAKE= yes
USE_X_PREFIX= yes
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index c1bc8a68d316..c9bacfd2a754 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.8.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -15,7 +16,7 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= reg@FreeBSD.org
-LIB_DEPENDS= IDL.2:${PORTSDIR}/devel/ORBit \
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index c1bc8a68d316..c9bacfd2a754 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.8.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -15,7 +16,7 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= reg@FreeBSD.org
-LIB_DEPENDS= IDL.2:${PORTSDIR}/devel/ORBit \
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
diff --git a/www/viewml/Makefile b/www/viewml/Makefile
index b2902419f89d..68cecbd3e6f9 100644
--- a/www/viewml/Makefile
+++ b/www/viewml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= viewml
PORTVERSION= 0.21
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.viewml.com/pub/viewml/
@@ -14,13 +15,13 @@ MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- wwwzip.1:${PORTSDIR}/www/libwww \
- Imlib.5:${PORTSDIR}/graphics/imlib
+ wwwzip.1:${PORTSDIR}/www/libwww
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_IMLIB= yes
USE_BISON= yes
CFLAGS+= -fpermissive -include /usr/include/sys/types.h \
-DPREFIX=\\\"${PREFIX}\\\"