aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-04-02 14:35:29 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-04-02 14:35:29 +0000
commitd8736ffd41aaf9986ffdb38a48f9a52fc303fcc7 (patch)
treefc637d3f5e36625adc75f333e91dbebac507c9ee /www
parenta3bcfdd3d6be82369921f78c15335c54fa2da0b5 (diff)
downloadports-d8736ffd41aaf9986ffdb38a48f9a52fc303fcc7.tar.gz
ports-d8736ffd41aaf9986ffdb38a48f9a52fc303fcc7.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-POE-Component-Server-PSGI/Makefile30
-rw-r--r--www/p5-POE-Component-Server-PSGI/distinfo3
-rw-r--r--www/p5-POE-Component-Server-PSGI/pkg-descr3
-rw-r--r--www/p5-POE-Component-Server-PSGI/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 05be73fa724d..d2411139f4b2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1077,6 +1077,7 @@
SUBDIR += p5-POE-Component-Client-UserAgent
SUBDIR += p5-POE-Component-Server-HTTP
SUBDIR += p5-POE-Component-Server-HTTPServer
+ SUBDIR += p5-POE-Component-Server-PSGI
SUBDIR += p5-POE-Component-Server-SOAP
SUBDIR += p5-POE-Component-Server-SimpleHTTP
SUBDIR += p5-POE-Filter-HTTP-Parser
diff --git a/www/p5-POE-Component-Server-PSGI/Makefile b/www/p5-POE-Component-Server-PSGI/Makefile
new file mode 100644
index 000000000000..8d14cd073a31
--- /dev/null
+++ b/www/p5-POE-Component-Server-PSGI/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: POE::Component::Server::PSGI
+# Date created: 02 Apr 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Server-PSGI
+PORTVERSION= 0.5
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to PSGI Server implementation for POE
+
+RUN_DEPENDS= \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-POE>0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Filter-HTTP-Parser>0:${PORTSDIR}/www/p5-POE-Filter-HTTP-Parser \
+ p5-namespace-autoclean>0:${PORTSDIR}/devel/p5-namespace-autoclean
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Server::PSGI.3 \
+ Plack::Server::POE.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-POE-Component-Server-PSGI/distinfo b/www/p5-POE-Component-Server-PSGI/distinfo
new file mode 100644
index 000000000000..d220095214b4
--- /dev/null
+++ b/www/p5-POE-Component-Server-PSGI/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-Server-PSGI-0.5.tar.gz) = d896d4e06a00970556bcb557375959d0
+SHA256 (POE-Component-Server-PSGI-0.5.tar.gz) = 607159bd4cd058d0d85b9d5f7dc76418b672ec2a740b8e2b907e97b5a38c30cf
+SIZE (POE-Component-Server-PSGI-0.5.tar.gz) = 10964
diff --git a/www/p5-POE-Component-Server-PSGI/pkg-descr b/www/p5-POE-Component-Server-PSGI/pkg-descr
new file mode 100644
index 000000000000..9cfb1d49ff7c
--- /dev/null
+++ b/www/p5-POE-Component-Server-PSGI/pkg-descr
@@ -0,0 +1,3 @@
+PSGI Server implementation for POE.
+
+WWW: http://search.cpan.org/dist/POE-Component-Server-PSGI/
diff --git a/www/p5-POE-Component-Server-PSGI/pkg-plist b/www/p5-POE-Component-Server-PSGI/pkg-plist
new file mode 100644
index 000000000000..bb8a00be2a03
--- /dev/null
+++ b/www/p5-POE-Component-Server-PSGI/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/PSGI/.packlist
+%%SITE_PERL%%/POE/Component/Server/PSGI.pm
+%%SITE_PERL%%/Plack/Server/POE.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/PSGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component