aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-11-29 18:22:32 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-11-29 18:22:32 +0000
commitedb7229dd444037f6015d4a7d1c93eade4ed41f0 (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /www
parentb134ca1eb84846189b4cdfa7ab624072ad1aebb6 (diff)
downloadports-edb7229dd444037f6015d4a7d1c93eade4ed41f0.tar.gz
ports-edb7229dd444037f6015d4a7d1c93eade4ed41f0.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/cssed/Makefile4
-rw-r--r--www/py-formencode/Makefile4
-rw-r--r--www/rekonq/Makefile2
-rw-r--r--www/sarg/Makefile13
4 files changed, 11 insertions, 12 deletions
diff --git a/www/cssed/Makefile b/www/cssed/Makefile
index 9fce323b1a41..b25369273a3e 100644
--- a/www/cssed/Makefile
+++ b/www/cssed/Makefile
@@ -10,14 +10,14 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Application to help CSS style sheets creation and maintenance
-USES= dos2unix pathfix pkgconfig
+USES= dos2unix gettext pathfix pkgconfig
DOS2UNIX_FILES= scintilla/gtk/ScintillaGTK.cxx
USE_GNOME= gtk20 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-plugin-headers
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
DESKTOP_ENTRIES="CSSED" "CSS Editor" "${DATADIR}/pixmaps/cssed-icon.png" \
"${PORTNAME}" "GTK;Development;WebDevelopment;TextEditor;" ""
diff --git a/www/py-formencode/Makefile b/www/py-formencode/Makefile
index 42b151821bbe..b6601ab02d81 100644
--- a/www/py-formencode/Makefile
+++ b/www/py-formencode/Makefile
@@ -3,7 +3,7 @@
PORTNAME= formencode
PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ LICENSE= PSFL
OPTIONS_DEFINE= DOCS
-USES= gettext:run python:2 zip
+USES= gettext-runtime:run python:2 zip
USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
diff --git a/www/rekonq/Makefile b/www/rekonq/Makefile
index 9aaf1aaa7415..2f5b45c08ee4 100644
--- a/www/rekonq/Makefile
+++ b/www/rekonq/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTVERSION:C,\..*,.0,}/
MAINTAINER= makc@FreeBSD.org
COMMENT= Lightweight KDE browser based on WebKit
-USES= cmake:outsource tar:xz
+USES= cmake:outsource gettext tar:xz
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USE_QT4= script webkit \
moc_build qmake_build rcc_build uic_build
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index dc0d522ad561..23b846fa94e0 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -14,22 +14,21 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS_DEFINE= GD PHP NLS PCRE LDAP ICONV
OPTIONS_DEFAULT=GD PHP NLS PCRE LDAP ICONV
+OPTIONS_SUB= yes
PHP_DESC= Install PHP for reporting generating
USES= gmake
-USE_AUTOTOOLS= autoconf aclocal
-OPTIONS_SUB= yes
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= CPPFLAGS=-I${LOCALBASE}/include \
- --sysconfdir="${ETCDIR}" \
+CONFIGURE_ARGS= --sysconfdir="${ETCDIR}" \
--enable-fontdir="${ETCDIR}/fonts" \
--enable-imagedir="${ETCDIR}/images"
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
NLS_USES= gettext
-NLS_LDFLAGS= -lintl
NLS_CONFIGURE_ENABLE= nls
+NLS_LIBS= -lintl
GD_CONFIGURE_WITH= gd
GD_LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
PHP_CONFIGURE_ON= --enable-sargphp="${ETCDIR}"
@@ -44,6 +43,6 @@ ICONV_LDFLAGS= ${ICONV_LIB}
post-patch:
@${REINPLACE_CMD} -e '/test .*==/ s/==/=/' \
- ${WRKSRC}/configure.in
+ ${WRKSRC}/configure
.include <bsd.port.mk>