aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-23 23:14:22 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-23 23:14:22 +0000
commitf192d86d173d537a6bda70ef3ecb3cb7d3b7d67f (patch)
treeaf19bfd0e1a74e7569df4c50636062feaaf9d606 /www
parent333471e43cb3d8d03a22e5ed36c8cd480d7ecd32 (diff)
downloadports-f192d86d173d537a6bda70ef3ecb3cb7d3b7d67f.tar.gz
ports-f192d86d173d537a6bda70ef3ecb3cb7d3b7d67f.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-SRU/Makefile52
-rw-r--r--www/p5-SRU/distinfo3
-rw-r--r--www/p5-SRU/pkg-descr56
-rw-r--r--www/p5-SRU/pkg-plist25
5 files changed, 137 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ba7df0e137b4..f68fa1ec4e5e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -682,6 +682,7 @@
SUBDIR += p5-ParallelUA
SUBDIR += p5-PodToHTML
SUBDIR += p5-RTx-Statistics
+ SUBDIR += p5-SRU
SUBDIR += p5-Sledge
SUBDIR += p5-Sledge-Plugin-CacheContent
SUBDIR += p5-Sledge-Plugin-Download
diff --git a/www/p5-SRU/Makefile b/www/p5-SRU/Makefile
new file mode 100644
index 000000000000..b79d40367f3e
--- /dev/null
+++ b/www/p5-SRU/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: SRU
+# Date created: 23 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SRU
+PORTVERSION= 0.93
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/B/BR/BRICAS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Search and Retrieval by URL
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/CQL/Parser.pm:${PORTSDIR}/textproc/p5-CQL-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Catalyst::Plugin::SRU.3 \
+ SRU.3 \
+ SRU::Request.3 \
+ SRU::Request::Explain.3 \
+ SRU::Request::Scan.3 \
+ SRU::Request::SearchRetrieve.3 \
+ SRU::Response.3 \
+ SRU::Response::Diagnostic.3 \
+ SRU::Response::Explain.3 \
+ SRU::Response::Record.3 \
+ SRU::Response::Scan.3 \
+ SRU::Response::SearchRetrieve.3 \
+ SRU::Response::Term.3 \
+ SRU::Server.3 \
+ SRU::Utils.3 \
+ SRU::Utils::XML.3 \
+ SRU::Utils::XMLTest.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-SRU/distinfo b/www/p5-SRU/distinfo
new file mode 100644
index 000000000000..92d8fb33c153
--- /dev/null
+++ b/www/p5-SRU/distinfo
@@ -0,0 +1,3 @@
+MD5 (SRU-0.93.tar.gz) = 83143d0539b3f5f21665da0f424d1751
+SHA256 (SRU-0.93.tar.gz) = 9587a8983a99c48e51d25c1457df803772602581df1f682e754ee03472aa0eb1
+SIZE (SRU-0.93.tar.gz) = 18919
diff --git a/www/p5-SRU/pkg-descr b/www/p5-SRU/pkg-descr
new file mode 100644
index 000000000000..dc0e39f3add9
--- /dev/null
+++ b/www/p5-SRU/pkg-descr
@@ -0,0 +1,56 @@
+The SRU package provides a framework for working with the Search and
+Retrieval by URL (SRU) protocol developed by the Library of Congress. SRU
+defines a web service for searching databases containing metadata and
+objects. SRU often goes under the name SRW which is a SOAP version of the
+protocol. You can think of SRU as a RESTful version of SRW, since all the
+requests are simple URLs instead of XML documents being sent via some sort
+of transport layer.
+
+You might be interested in SRU if you want to provide a generic API for
+searching a data repository and a mechanism for returning metadata
+records. SRU defines three verbs: explain, scan and searchRetrieve which
+define the requests and responses in a SRU interaction.
+
+This set of modules attempts to provide a framework for building an SRU
+service. The distribution is made up of two sets of Perl modules: modules
+in the SRU::Request::* namespace which represent the three types of
+requests; and modules in the SRU::Response::* namespace which represent
+the various responses.
+
+Typical usage is that a request object is created using a factory method
+in the SRU::Request module. The factory is given either a URI or a CGI
+object for the HTTP request. SRU::Request will look at the URI and build
+the appropriate request object: SRU::Request::Explain, SRU::Request::Scan
+or SRU::Request::SearchRetrieve.
+
+Once you've got a request object you can build a response object by using
+the factory method newFromRequest() in SRU::Request. This method will
+examine the request and build the corresponding result object which you
+can then populate with result data appropriately. When you are finished
+populating the response object with results you can call asXML() on it to
+get the full XML for your response.
+
+To understand the meaning of the various requests and their responses
+you'll want to read the docs at the Library of Congress. A good place to
+start is SRW/U In Five Hundred Words
+http://www.loc.gov/z3950/agency/zing/srw/brief.html For more information
+about working with the various request and response objects in this
+distribution see the POD in the individual packages:
+
+ * SRU::Request
+ * SRU::Request::Explain
+ * SRU::Request::Scan
+ * SRU::Request::SearchRetrieve
+ * SRU::Response
+ * SRU::Response::Explain
+ * SRU::Response::Scan
+ * SRU::Response::SearchRetrieve
+ * SRU::Server
+
+Questions and comments are more than welcome. This software was developed
+as part of a National Science Foundation grant for building distributed
+library systems in the Ockham Project. More about Ockham can be found at
+http://www.ockham.org.
+
+WWW: http://search.cpan.org/dist/SRU
+Author: Ed Summers <ehs@pobox.com>
diff --git a/www/p5-SRU/pkg-plist b/www/p5-SRU/pkg-plist
new file mode 100644
index 000000000000..278f9b1280fc
--- /dev/null
+++ b/www/p5-SRU/pkg-plist
@@ -0,0 +1,25 @@
+%%SITE_PERL%%/Catalyst/Plugin/SRU.pm
+%%SITE_PERL%%/SRU.pm
+%%SITE_PERL%%/SRU/Request.pm
+%%SITE_PERL%%/SRU/Request/Explain.pm
+%%SITE_PERL%%/SRU/Request/Scan.pm
+%%SITE_PERL%%/SRU/Request/SearchRetrieve.pm
+%%SITE_PERL%%/SRU/Response.pm
+%%SITE_PERL%%/SRU/Response/Diagnostic.pm
+%%SITE_PERL%%/SRU/Response/Explain.pm
+%%SITE_PERL%%/SRU/Response/Record.pm
+%%SITE_PERL%%/SRU/Response/Scan.pm
+%%SITE_PERL%%/SRU/Response/SearchRetrieve.pm
+%%SITE_PERL%%/SRU/Response/Term.pm
+%%SITE_PERL%%/SRU/Server.pm
+%%SITE_PERL%%/SRU/Utils.pm
+%%SITE_PERL%%/SRU/Utils/XML.pm
+%%SITE_PERL%%/SRU/Utils/XMLTest.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SRU/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SRU
+@dirrm %%SITE_PERL%%/SRU/Utils
+@dirrm %%SITE_PERL%%/SRU/Response
+@dirrm %%SITE_PERL%%/SRU/Request
+@dirrmtry %%SITE_PERL%%/SRU
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst