aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-03-28 02:51:39 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-03-28 02:51:39 +0000
commit015031dd1e181d86d58c2664e495f065d45bf8b6 (patch)
treeeda845b1d2f43990ecb1a0325ba07d6ac8ecfde1 /www
parent197cdaaff42d2ee5057a9103e05281b50359d7dd (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/plexwatchweb/Makefile30
-rw-r--r--www/plexwatchweb/distinfo2
-rw-r--r--www/plexwatchweb/pkg-descr3
-rw-r--r--www/plexwatchweb/pkg-plist101
5 files changed, 137 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a77c1a9e6a64..86e03331cc2f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1468,6 +1468,7 @@
SUBDIR += piwigo
SUBDIR += piwik
SUBDIR += planet
+ SUBDIR += plexwatchweb
SUBDIR += pligg
SUBDIR += plone
SUBDIR += plugger
diff --git a/www/plexwatchweb/Makefile b/www/plexwatchweb/Makefile
new file mode 100644
index 000000000000..803ba52a2057
--- /dev/null
+++ b/www/plexwatchweb/Makefile
@@ -0,0 +1,30 @@
+# Created by: ultima <ultima1252@gmail.com>
+# $FreeBSD$
+
+PORTNAME= plexWatchWeb
+PORTVERSION= 1.5.4.2
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+
+MAINTAINER= ultima1252@gmail.com
+COMMENT= Web front-end for plexWatch
+
+RUN_DEPENDS= multimedia/plexwatch>=0.1.6:${PORTSDIR}/multimedia/plexwatch
+
+USE_PHP= curl json session simplexml sqlite3
+
+USERS= ${WWWOWN}
+GROUPS= ${WWWGRP}
+
+USE_GITHUB= yes
+GH_ACCOUNT= ecleese
+GH_TAGNAME= 0d05556
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}/config
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}/config
+ ${RM} -r ${WRKSRC}/config
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WWWDIR}/)
+
+.include <bsd.port.mk>
diff --git a/www/plexwatchweb/distinfo b/www/plexwatchweb/distinfo
new file mode 100644
index 000000000000..f51a921d599f
--- /dev/null
+++ b/www/plexwatchweb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ecleese-plexWatchWeb-v1.5.4.2-0d05556_GH0.tar.gz) = 4f5eec9d6d4d5b172a03b84d74e192d73016b49ff75cc1ecf417990b73afdef1
+SIZE (ecleese-plexWatchWeb-v1.5.4.2-0d05556_GH0.tar.gz) = 1196268
diff --git a/www/plexwatchweb/pkg-descr b/www/plexwatchweb/pkg-descr
new file mode 100644
index 000000000000..a886cdeda91f
--- /dev/null
+++ b/www/plexwatchweb/pkg-descr
@@ -0,0 +1,3 @@
+A web front-end for plexWatch
+
+WWW: https://github.com/ecleese/plexWatchWeb
diff --git a/www/plexwatchweb/pkg-plist b/www/plexwatchweb/pkg-plist
new file mode 100644
index 000000000000..1b83b3ba4b17
--- /dev/null
+++ b/www/plexwatchweb/pkg-plist
@@ -0,0 +1,101 @@
+%%WWWDIR%%/README.md
+%%WWWDIR%%/change.log
+%%WWWDIR%%/charts.php
+%%WWWDIR%%/css/font-awesome.min.css
+%%WWWDIR%%/css/plexwatch-tables.css
+%%WWWDIR%%/css/plexwatch.css
+%%WWWDIR%%/css/xcharts.css
+%%WWWDIR%%/font/FontAwesome.otf
+%%WWWDIR%%/font/fontawesome-webfont.eot
+%%WWWDIR%%/font/fontawesome-webfont.svg
+%%WWWDIR%%/font/fontawesome-webfont.ttf
+%%WWWDIR%%/font/fontawesome-webfont.woff
+%%WWWDIR%%/history.php
+%%WWWDIR%%/images/background.png
+%%WWWDIR%%/images/chevron.png
+%%WWWDIR%%/images/favicon.ico
+%%WWWDIR%%/images/glyphicons-halflings-white.png
+%%WWWDIR%%/images/glyphicons-halflings.png
+%%WWWDIR%%/images/glyphicons.png
+%%WWWDIR%%/images/gravatar-default-80x80.png
+%%WWWDIR%%/images/gravatar-default-80x80_old.png
+%%WWWDIR%%/images/gravatar-default.png
+%%WWWDIR%%/images/gravatar-default_old.png
+%%WWWDIR%%/images/icon_ipad.png
+%%WWWDIR%%/images/icon_ipad@2x.png
+%%WWWDIR%%/images/icon_iphone.png
+%%WWWDIR%%/images/icon_iphone@2x.png
+%%WWWDIR%%/images/logo-plexWatch-welcome.png
+%%WWWDIR%%/images/logo-plexWatch-welcome_old.png
+%%WWWDIR%%/images/logo-plexwatch.png
+%%WWWDIR%%/images/logo-plexwatch@2x.png
+%%WWWDIR%%/images/logo-plexwatch_old.png
+%%WWWDIR%%/images/logo-plexwatch_old@2x.png
+%%WWWDIR%%/images/platforms/android.png
+%%WWWDIR%%/images/platforms/atv.png
+%%WWWDIR%%/images/platforms/chrome.png
+%%WWWDIR%%/images/platforms/chromecast.png
+%%WWWDIR%%/images/platforms/default.png
+%%WWWDIR%%/images/platforms/firefox.png
+%%WWWDIR%%/images/platforms/gtv.png
+%%WWWDIR%%/images/platforms/ie.png
+%%WWWDIR%%/images/platforms/ios.png
+%%WWWDIR%%/images/platforms/opera.png
+%%WWWDIR%%/images/platforms/pht.png
+%%WWWDIR%%/images/platforms/platform-android.png
+%%WWWDIR%%/images/platforms/platform-appletv.png
+%%WWWDIR%%/images/platforms/platform-atv.png
+%%WWWDIR%%/images/platforms/platform-chrome.png
+%%WWWDIR%%/images/platforms/platform-default.png
+%%WWWDIR%%/images/platforms/platform-firefox.png
+%%WWWDIR%%/images/platforms/platform-ie.png
+%%WWWDIR%%/images/platforms/platform-ios.png
+%%WWWDIR%%/images/platforms/platform-plex-ht.png
+%%WWWDIR%%/images/platforms/platform-roku.png
+%%WWWDIR%%/images/platforms/platform-safari.png
+%%WWWDIR%%/images/platforms/platform-xbmc.png
+%%WWWDIR%%/images/platforms/pmh.png
+%%WWWDIR%%/images/platforms/pms.png
+%%WWWDIR%%/images/platforms/roku.png
+%%WWWDIR%%/images/platforms/safari.png
+%%WWWDIR%%/images/platforms/samsung.png
+%%WWWDIR%%/images/platforms/wiiu.png
+%%WWWDIR%%/images/platforms/win8.png
+%%WWWDIR%%/images/platforms/wp.png
+%%WWWDIR%%/images/platforms/xbmc.png
+%%WWWDIR%%/images/poster.png
+%%WWWDIR%%/images/star-16.png
+%%WWWDIR%%/images/star-32.png
+%%WWWDIR%%/images/star-gray-16.png
+%%WWWDIR%%/images/star-gray-32.png
+%%WWWDIR%%/includes/current_activity.php
+%%WWWDIR%%/includes/current_activity_header.php
+%%WWWDIR%%/includes/functions.php
+%%WWWDIR%%/includes/img.php
+%%WWWDIR%%/includes/myplex.php
+%%WWWDIR%%/includes/process_settings.php
+%%WWWDIR%%/includes/recently_added.php
+%%WWWDIR%%/includes/timeago.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/info.php
+%%WWWDIR%%/js/bootstrap.js
+%%WWWDIR%%/js/bootstrap.min.js
+%%WWWDIR%%/js/cpufunctions.js
+%%WWWDIR%%/js/d3.v3.js
+%%WWWDIR%%/js/jquery-2.0.3.js
+%%WWWDIR%%/js/jquery-2.0.3.min.js
+%%WWWDIR%%/js/jquery-sortable.js
+%%WWWDIR%%/js/jquery-ui.js
+%%WWWDIR%%/js/jquery.dataTables.js
+%%WWWDIR%%/js/jquery.dataTables.min.js
+%%WWWDIR%%/js/jquery.dataTables.plugin.bootstrap_pagination.js
+%%WWWDIR%%/js/jquery.dataTables.plugin.date_sorting.js
+%%WWWDIR%%/js/jquery.rateit.js
+%%WWWDIR%%/js/jquery.rateit.min.js
+%%WWWDIR%%/js/jquery.ui.sortable.js
+%%WWWDIR%%/js/xcharts.min.js
+%%WWWDIR%%/settings.php
+%%WWWDIR%%/stats.php
+%%WWWDIR%%/user.php
+%%WWWDIR%%/users.php
+@dir(%%WWWOWN%%,%%WWWGRP%%,755) %%WWWDIR%%/config