aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-02 20:07:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-02 20:07:31 +0000
commit2a56e34bee4ec2f707f511b69b96c0b8235ce094 (patch)
treedb09bb3cea198bacf92b46e04f8737ed92a1661c /www
parent8584f373b2b39664b1f7c35fe40485a19d069930 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-http-form_data/Makefile18
-rw-r--r--www/rubygem-http-form_data/distinfo2
-rw-r--r--www/rubygem-http-form_data/pkg-descr5
4 files changed, 26 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 888739f25119..c6644d180cbc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1829,6 +1829,7 @@
SUBDIR += rubygem-html2haml
SUBDIR += rubygem-http
SUBDIR += rubygem-http-cookie
+ SUBDIR += rubygem-http-form_data
SUBDIR += rubygem-http_router
SUBDIR += rubygem-httparty
SUBDIR += rubygem-httpclient
diff --git a/www/rubygem-http-form_data/Makefile b/www/rubygem-http-form_data/Makefile
new file mode 100644
index 000000000000..9a85a6e4773e
--- /dev/null
+++ b/www/rubygem-http-form_data/Makefile
@@ -0,0 +1,18 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= http-form_data
+PORTVERSION= 1.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Build form data request bodies
+
+LICENSE= MIT
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-http-form_data/distinfo b/www/rubygem-http-form_data/distinfo
new file mode 100644
index 000000000000..66a23ce27fbf
--- /dev/null
+++ b/www/rubygem-http-form_data/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/http-form_data-1.0.0.gem) = 162988c19ae156541561889d064c7d7db15adc4190d4ddd31471f2741e3da7b0
+SIZE (rubygem/http-form_data-1.0.0.gem) = 13824
diff --git a/www/rubygem-http-form_data/pkg-descr b/www/rubygem-http-form_data/pkg-descr
new file mode 100644
index 000000000000..48f6bef16796
--- /dev/null
+++ b/www/rubygem-http-form_data/pkg-descr
@@ -0,0 +1,5 @@
+HTTP::FormData is utility-belt to build form data request bodies. It provides
+support for 'application/x-www-form-urlencoded' and 'multipart/form-data' types.
+
+WWW: https://github.com/httprb/form_data.rb
+RG: https://rubygems.org/gems/http-form_data