aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-11-29 18:29:50 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-11-29 18:29:50 +0000
commit62ea911739727f8586c5964dbbfc7cb63f8110c3 (patch)
treebe2e883e7687efb3f37e97ae5006d96963af8fdb /www
parentef657c5b841e6721b59f4e00b80b238f8e81f4ff (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile7
-rw-r--r--www/nginx-devel/distinfo4
-rw-r--r--www/nginx-devel/files/nginx.8.in201
3 files changed, 4 insertions, 208 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 932553d4fe37..e1b55467aa0a 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.8.53
-PORTREVISION= 1
+PORTVERSION= 0.9.0
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -94,8 +93,6 @@ USE_RC_SUBR= nginx.sh
SUB_LIST+= WWWOWN=${WWWOWN}
.if !defined(NO_INSTALL_MANPAGES)
MAN8= nginx.8
-SUB_FILES+= nginx.8
-SUB_LIST+= NGINX_ERRORLOG=${NGINX_ERRORLOG} NGINX_RUNDIR=${NGINX_RUNDIR}
.endif
HAS_CONFIGURE= yes
@@ -516,7 +513,7 @@ post-install:
${ECHO_CMD} @dirrm ${SITE_PERL_REL}/${PERL_ARCH}/auto/nginx >> ${TMPPLIST}
.endif
.if !defined(NO_INSTALL_MANPAGES)
- @${INSTALL_MAN} ${WRKDIR}/nginx.8 ${MAN8PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/objs/nginx.8 ${MAN8PREFIX}/man/man8
.endif
.include <bsd.port.post.mk>
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index b1e7f7a66bf5..f8dde87ac1c3 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-0.8.53.tar.gz) = 8ab8a87beb555d9ea09fe61d0de86a71ea4e90ef7970df0d38f7acfb9bed6dcf
-SIZE (nginx-0.8.53.tar.gz) = 649835
+SHA256 (nginx-0.9.0.tar.gz) = 2ca03831e74d1ec79368cb262a21dba261f807d8c66668057cc6b85df2a9b551
+SIZE (nginx-0.9.0.tar.gz) = 653299
SHA256 (nginx_accept_language_module.tar.gz) = 7a4c2d42a83c5b6efd2b7b13ad232850b6ab0ca4261df6b46fb7d2d2738b1c0a
SIZE (nginx_accept_language_module.tar.gz) = 3299
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
diff --git a/www/nginx-devel/files/nginx.8.in b/www/nginx-devel/files/nginx.8.in
deleted file mode 100644
index 8c3437b4e5b6..000000000000
--- a/www/nginx-devel/files/nginx.8.in
+++ /dev/null
@@ -1,201 +0,0 @@
-.\"
-.\" Copyright (c) 2010 Sergey A. Osokin
-.\" All rights reserved.
-.\"
-.\" Redistribution and use in source and binary forms, with or without
-.\" modification, are permitted provided that the following conditions
-.\" are met:
-.\" 1. Redistributions of source code must retain the above copyright
-.\" notice, this list of conditions and the following disclaimer.
-.\" 2. Redistributions in binary form must reproduce the above copyright
-.\" notice, this list of conditions and the following disclaimer in the
-.\" documentation and/or other materials provided with the distribution.
-.\"
-.\" THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
-.\" ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-.\" IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-.\" ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
-.\" FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-.\" DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
-.\" OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-.\" HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-.\" LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
-.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-.\" SUCH DAMAGE.
-.\"
-.\"
-.Dd November 14, 2010
-.Dt NGINX 8
-.Os
-.Sh NAME
-.Nm nginx
-.Nd "HTTP and reverse proxy server, mail proxy server"
-.Sh SYNOPSIS
-.Nm
-.Op Fl hqtvV?
-.Op Fl c Ar file
-.Op Fl g Ar directives
-.Op Fl p Ar prefix
-.Op Fl s Ar signal
-.Sh DESCRIPTION
-The
-.Nm
-(spelled
-.Dq engine x )
-is an HTTP and reverse proxy server, as well as a mail proxy server.
-The
-.Nm
-is known for its high performance, stability, rich feature set, simple
-configuration, and low resource consumption.
-.Pp
-The options are as follows:
-.Bl -tag -width ".Fl d Ar directives"
-.It Fl ?\& | h
-Print help.
-.It Fl c Ar file
-Use an alternative configuration
-.Ar file .
-.It Fl g Ar directives
-Set global configuration directives.
-See
-.Sx EXAMPLES
-for details.
-.It Fl p Ar prefix
-Set prefix path.
-Default value is
-.Pa %%PREFIX%%/etc/nginx .
-.It Fl q
-Suppress non-error messages during configuration testing.
-.It Fl s Ar signal
-Send signal to the master process.
-The argument
-.Ar signal
-can be one of:
-.Cm stop , quit , reopen , reload .
-The following table shows the corresponding system signals.
-.Pp
-.Bl -tag -width ".It Cm reopen" -compact
-.It Cm stop
-.Dv SIGTERM
-.It Cm quit
-.Dv SIGQUIT
-.It Cm reopen
-.Dv SIGUSR1
-.It Cm reload
-.Dv SIGHUP
-.El
-.It Fl t
-Don't run, just test the configuration file.
-The
-.Nm
-checks configuration for correct syntax and then tries to open files
-referred in configuration.
-.It Fl v
-Print
-.Nm
-version.
-.It Fl V
-Print
-.Nm
-version, compiler version and
-.Pa configure
-script parameters.
-.El
-.Sh SIGNALS
-The master process of
-.Nm
-can handle the following signals.
-.Pp
-.Bl -tag -width ".It Dv SIGINT , SIGTERM" -compact
-.It Dv SIGINT , SIGTERM
-Shut down quickly.
-.It Dv SIGHUP
-Reload configuration, start the new worker process with a new
-configuration, gracefully shut down old worker processes.
-.It Dv SIGQUIT
-Shut down gracefully.
-.It Dv SIGUSR1
-Reopen log files.
-.It Dv SIGUSR2
-Upgrade
-.Nm
-executable on the fly.
-.It Dv SIGWINCH
-Shut down gracefully worker processes.
-.El
-.Pp
-While there's no need to explicitly control worker processes normally,
-they support some signals, too:
-.Pp
-.Bl -tag -width ".It Dv SIGINT , SIGTERM" -compact
-.It Dv SIGTERM
-Shut down quickly.
-.It Dv SIGQUIT
-Shut down gracefully.
-.It Dv SIGUSR1
-Reopen log files.
-.El
-.Sh DEBUGGING LOG
-To enable a debugging log, reconfigure
-.Nm
-to build with debugging:
-.Pp
-.Dl "./configure --with-debug ..."
-.Pp
-and then set the
-.Cm debug
-level of the
-.Va error_log :
-.Pp
-.Dl "error_log /path/to/log debug;"
-.Pp
-It is also possible to enable the debugging for some IP address:
-.Bd -literal -offset indent
-events {
- debug_connection 127.0.0.1;
-}
-.Ed
-.Sh FILES
-.Bl -tag -width indent -compact
-.It Pa %%NGINX_RUNDIR%%/nginx/nginx.pid
-Contains the process ID of the
-.Nm
-listening for connections.
-The content of this file is not sensitive; it can be world-readable.
-.It Pa %%PREFIX%%/etc/nginx/nginx.conf
-Main configuration file.
-.It Pa %%NGINX_ERRORLOG%%
-Error log file.
-.El
-.Sh EXIT STATUS
-Exit status is 0 on success, or 1 if the command fails.
-.Sh EXAMPLES
-.Bd -literal
-nginx -t -c ~/mynginx.conf -g "pid %%NGINX_RUNDIR%%/mynginx.pid; worker_processes 2;"
-.Ed
-Test configuration file
-.Pa ~/mynginx.conf
-with global directives for PID and quantity of worker processes.
-.Sh SEE ALSO
-.Xr nginx.conf 5
-.Sh HISTORY
-Development of
-.Nm
-started in 2002, with the first public release in 2004.
-.Sh AUTHORS
-.An Igor Sysoev Aq igor@sysoev.ru
-.Pp
-Documentation available on
-.Pa http://nginx.org/
-and
-.Pa http://sysoev.ru/nginx/ .
-.Pp
-This manual page was written by
-.An Sergey A. Osokin Aq osa@FreeBSD.org.ru
-as a result of compilation of many
-.Nm
-documents all over the world.
-.Sh BUGS
-Report to mailing list
-.Aq Li nginx@nginx.org
-if you found one.