aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-11-06 08:26:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-11-06 08:26:13 +0000
commit71b663bea7423a770df48011626809625e4d7dfa (patch)
tree6950f5fcae4f2601f9783291175460e2070666f2 /www
parent85294c207bbde70e9a35b97adaa1b3c6b99a489c (diff)
downloadports-71b663bea7423a770df48011626809625e4d7dfa.tar.gz
ports-71b663bea7423a770df48011626809625e4d7dfa.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/epiphany/Makefile2
-rw-r--r--www/epiphany/files/patch-src_ephy-dbus.c51
2 files changed, 52 insertions, 1 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 543f1a2d2fcb..bdfa553f7b63 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -8,7 +8,7 @@
PORTNAME= epiphany
PORTVERSION= 2.16.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/www/epiphany/files/patch-src_ephy-dbus.c b/www/epiphany/files/patch-src_ephy-dbus.c
new file mode 100644
index 000000000000..15b54801a41d
--- /dev/null
+++ b/www/epiphany/files/patch-src_ephy-dbus.c
@@ -0,0 +1,51 @@
+===================================================================
+RCS file: /cvs/gnome/epiphany/src/ephy-dbus.c,v
+retrieving revision 1.16.2.2
+retrieving revision 1.16.2.3
+diff -u -r1.16.2.2 -r1.16.2.3
+--- src/ephy-dbus.c 2006/09/13 11:48:50 1.16.2.2
++++ src/ephy-dbus.c 2006/10/18 18:54:30 1.16.2.3
+@@ -16,7 +16,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ *
+- * $Id: ephy-dbus.c,v 1.16.2.2 2006/09/13 11:48:50 chpe Exp $
++ * $Id: ephy-dbus.c,v 1.16.2.3 2006/10/18 18:54:30 chpe Exp $
+ */
+
+ #include "config.h"
+@@ -301,16 +301,6 @@
+ return TRUE;
+ }
+
+-static void
+-ephy_dbus_disconnect_bus (DBusGConnection *bus)
+-{
+- if (bus != NULL) {
+- dbus_connection_close
+- (dbus_g_connection_get_connection (bus));
+- dbus_g_connection_unref (bus);
+- }
+-}
+-
+ /* Public methods */
+
+ static void
+@@ -337,7 +327,7 @@
+ dbus_connection_remove_filter
+ (dbus_g_connection_get_connection (priv->session_bus),
+ session_filter_func, dbus);
+- ephy_dbus_disconnect_bus (priv->session_bus);
++ dbus_g_connection_unref (priv->session_bus);
+ priv->session_bus = NULL;
+ }
+
+@@ -346,7 +336,7 @@
+ dbus_connection_remove_filter
+ (dbus_g_connection_get_connection (priv->system_bus),
+ system_filter_func, dbus);
+- ephy_dbus_disconnect_bus (priv->system_bus);
++ dbus_g_connection_unref (priv->system_bus);
+ priv->system_bus = NULL;
+ }
+ }