aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-05-23 20:35:01 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-05-23 20:35:01 +0000
commitc86e9d97241f251304781abec881b7b5a934f12a (patch)
tree6a64949cd1d37fc2302e761cd239d30738f2b760 /www
parent1b68d5eb0ccf36adc2ddc3545e89811c794dec49 (diff)
downloadports-c86e9d97241f251304781abec881b7b5a934f12a.tar.gz
ports-c86e9d97241f251304781abec881b7b5a934f12a.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/c-icap/Makefile1
-rw-r--r--www/calendarserver/Makefile2
-rw-r--r--www/dillo2/Makefile2
-rw-r--r--www/e2guardian/Makefile2
-rw-r--r--www/emacs-w3m/Makefile2
-rw-r--r--www/gatling/Makefile2
-rw-r--r--www/hiawatha/Makefile2
-rw-r--r--www/hs-http-server/Makefile1
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/links/Makefile2
-rw-r--r--www/lynx-current/Makefile2
-rw-r--r--www/mod_musicindex/Makefile2
-rw-r--r--www/neon/Makefile2
-rw-r--r--www/nginx-devel/Makefile2
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/privoxy/Makefile2
-rw-r--r--www/roundup/Makefile2
-rw-r--r--www/sarg/Makefile2
-rw-r--r--www/squid-devel/Makefile4
-rw-r--r--www/squid/Makefile4
-rw-r--r--www/tengine/Makefile2
21 files changed, 21 insertions, 23 deletions
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index b10c226fc796..c654bb25832c 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -38,7 +38,6 @@ PLIST_SUB= LOG_DIR=${LOG_DIR} RUN_DIR=${RUN_DIR} \
SUB_LIST= RUN_DIR=${RUN_DIR} CICAP_USER=${CICAP_USER}
OPTIONS_DEFINE= BDB IPV6 LDAP PERL POSIXSEM LARGE_FILES MEMCACHE
-OPTIONS_DEFAULT= IPV6
OPTIONS_SUB= yes
LARGE_FILES_DESC= Enable large files support
POSIXSEM_DESC= Use POSIX Semaphores instead of SYSV IPC
diff --git a/www/calendarserver/Makefile b/www/calendarserver/Makefile
index 382bd50fbeeb..3acd13f8f7f0 100644
--- a/www/calendarserver/Makefile
+++ b/www/calendarserver/Makefile
@@ -31,7 +31,7 @@ RUN_DEPENDS= bash:shells/bash \
OPTIONS_DEFINE= EXAMPLES DOCS
EXAMPLES_DESC= Install configuration examples
DOCS_DESC= Install additional documentation
-OPTIONS_DEFAULT= EXAMPLES DOCS
+
.include <bsd.port.options.mk>
USES= shebangfix pgsql python \
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index cc7525fc954d..8abd94783983 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -25,7 +25,7 @@ CONFLICTS= dillo-i18n-[0-9]* \
dillo-0*
OPTIONS_DEFINE= COOKIES HYPHENATION IPV6 SSL THREADS DOCS
-OPTIONS_DEFAULT= COOKIES HYPHENATION IPV6 SSL THREADS
+OPTIONS_DEFAULT= COOKIES HYPHENATION SSL THREADS
COOKIES_DESC= Cookie support
HYPHENATION_DESC= Hyphenation file(s) for HYPHENATION_LANGS
diff --git a/www/e2guardian/Makefile b/www/e2guardian/Makefile
index d2eca9f55dcb..e409aa3d7c80 100644
--- a/www/e2guardian/Makefile
+++ b/www/e2guardian/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--enable-fancydm
OPTIONS_DEFINE= APACHE TRICKLE CLISCAN CLAMD ICAP KAV NTLM DNS EMAIL DEBUG SSL DOCS
-OPTIONS_DEFAULT=TRICKLE DOCS 1024
+OPTIONS_DEFAULT=TRICKLE 1024
OPTIONS_SUB= yes
APACHE_DESC= Enable Apache support for access denied page
diff --git a/www/emacs-w3m/Makefile b/www/emacs-w3m/Makefile
index 81f874453eb7..0c7fbbc22725 100644
--- a/www/emacs-w3m/Makefile
+++ b/www/emacs-w3m/Makefile
@@ -46,7 +46,7 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
DOCSDIR_JA= ${PREFIX}/share/doc/ja/${PORTNAME}
OPTIONS_DEFINE= DOCS OCTET_VIEWER SHIMBUN
-OPTIONS_DEFAULT= DOCS OCTET_VIEWER SHIMBUN
+OPTIONS_DEFAULT= OCTET_VIEWER SHIMBUN
OCTET_VIEWER_DESC= Octet stream viewer support
SHIMBUN_DESC= Build and/or install Shimbun
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index 05aa81f28d90..35f5bea415bb 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -35,7 +35,7 @@ PORTEXAMPLES= run-gatling cgi acc getlinks hcat hitprofile matchiprange \
OPTIONS_DEFINE= BENCHMARKS SMB TLS ZLIB OPTIMIZED_CFLAGS DOCS EXAMPLES DEBUG
OPTIONS_SUB= yes
-OPTIONS_DEFAULT= BENCHMARKS SMB TLS ZLIB OPTIMIZED_CFLAGS DOCS EXAMPLES
+OPTIONS_DEFAULT= BENCHMARKS SMB TLS ZLIB OPTIMIZED_CFLAGS
BENCHMARKS_DESC= Install some benchmark programs
TLS_DESC= Build and install tlsgatling
ZLIB_DESC= Compress outgoing data
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index 6f9204a88763..2846bfddc0c5 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -28,7 +28,7 @@ CMAKE_ARGS= -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
OPTIONS_DEFINE= CACHE DOCS IPV6 MONITOR RPROXY SSL TOMAHAWK TOOLKIT XSLT
-OPTIONS_DEFAULT= CACHE IPV6 RPROXY SSL TOOLKIT XSLT DOCS
+OPTIONS_DEFAULT= CACHE RPROXY SSL TOOLKIT XSLT
CACHE_DESC= Enable cache support
MONITOR_DESC= Enable Hiawatha Monitor
diff --git a/www/hs-http-server/Makefile b/www/hs-http-server/Makefile
index ed4a37a16d53..9f9bfe0f9be0 100644
--- a/www/hs-http-server/Makefile
+++ b/www/hs-http-server/Makefile
@@ -17,7 +17,6 @@ INSTALL_PORTEXAMPLES= cd ${WRKSRC}/example && \
${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
OPTIONS_DEFINE= EXAMPLES
-OPTIONS_DEFAULT= EXAMPLES
FLAGS_ENABLE= network-uri
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 3c2ab5bcaf35..d0662bc0e2a4 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -36,7 +36,7 @@ USE_RC_SUBR= lighttpd
OPTIONS_DEFINE= ATTR BZIP2 DOCS FAM GDBM IPV6 LIBEV LUA MEMCACHE MYSQL MYSQLAUTH \
NODELAY LDAP OPENSSL SPAWNFCGI VALGRIND WEBDAV
-OPTIONS_DEFAULT= IPV6 OPENSSL
+OPTIONS_DEFAULT= OPENSSL
ATTR_DESC= extended attributes support
BZIP2_DESC= bzip2 support (mod_compress)
diff --git a/www/links/Makefile b/www/links/Makefile
index 6c1493447552..9c4ba0070d36 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -34,7 +34,7 @@ TRANS_DESC= Hack for background transparency
UTF8_DESC= UTF-8 support
X11_DESC= X11 graphics support
-OPTIONS_DEFAULT= IPV6 UTF8 X11
+OPTIONS_DEFAULT= UTF8 X11
PLIST_FILES= bin/links man/man1/links.1.gz
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 81939c43f8b3..3b84e9a7e92a 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -47,7 +47,7 @@ L_HELP= ${PREFIX}/share/lynx_help
DOCSDIR= ${L_DOC}
OPTIONS_DEFINE= IDN NLS DOCS
-OPTIONS_DEFAULT=IDN NLS
+OPTIONS_DEFAULT=IDN
OPTIONS_SUB= yes
NLS_USES= gettext
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index 89d6d0ee299c..2716e4c7ac70 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -17,7 +17,7 @@ USES= libarchive
USE_APACHE= 22
OPTIONS_DEFINE= NLS FLAC MP3 MP4 VORBIS LIBARCHIVE FILECACHE MYSQLCACHE
-OPTIONS_DEFAULT=NLS MP3 LIBARCHIVE FILECACHE
+OPTIONS_DEFAULT=MP3 LIBARCHIVE FILECACHE
LIBARCHIVE_DESC= Archive downloading support
FILECACHE_DESC= Flat file caching support
diff --git a/www/neon/Makefile b/www/neon/Makefile
index 1ca0f8ac0fd0..19f292b4ac81 100644
--- a/www/neon/Makefile
+++ b/www/neon/Makefile
@@ -17,7 +17,7 @@ GNU_CONFIGURE= yes
OPTIONS_SUB= yes
OPTIONS_DEFINE= CA_BUNDLE DOCS GSSAPI NLS OPENSSL PROXY
-OPTIONS_DEFAULT= CA_BUNDLE EXPAT GSSAPI NLS OPENSSL
+OPTIONS_DEFAULT= CA_BUNDLE EXPAT GSSAPI OPENSSL
OPTIONS_SINGLE= XML
OPTIONS_SINGLE_XML= EXPAT LIBXML
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 279678e3ad81..c34b68370a96 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -125,7 +125,7 @@ OPTIONS_DEFINE= \
XRID_HEADER \
XSS
-OPTIONS_DEFAULT=DSO IPV6 FILE_AIO HTTP HTTP_ADDITION HTTP_AUTH_REQ HTTP_CACHE \
+OPTIONS_DEFAULT=DSO FILE_AIO HTTP HTTP_ADDITION HTTP_AUTH_REQ HTTP_CACHE \
HTTP_DAV HTTP_FLV HTTP_GZIP_STATIC HTTP_GUNZIP_FILTER \
HTTP_MP4 HTTP_RANDOM_INDEX HTTP_REALIP HTTP_SECURE_LINK \
HTTP_SLICE HTTP_REWRITE HTTP_SSL HTTP_STATUS HTTP_SUB \
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index e9d01ae6d0c7..4c3bebd5eabb 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -125,7 +125,7 @@ OPTIONS_DEFINE= \
XRID_HEADER \
XSS
-OPTIONS_DEFAULT=DSO IPV6 FILE_AIO HTTP HTTP_ADDITION HTTP_AUTH_REQ HTTP_CACHE \
+OPTIONS_DEFAULT=DSO FILE_AIO HTTP HTTP_ADDITION HTTP_AUTH_REQ HTTP_CACHE \
HTTP_DAV HTTP_FLV HTTP_GZIP_STATIC HTTP_GUNZIP_FILTER \
HTTP_MP4 HTTP_RANDOM_INDEX HTTP_REALIP HTTP_SECURE_LINK \
HTTP_SLICE HTTP_REWRITE HTTP_SSL HTTP_STATUS HTTP_SUB \
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 0dd980022c1c..286523349883 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -45,7 +45,7 @@ FORCE_DESC= Support bypassing of blocks
PRIVOXY_TOOLS_DESC= Install Privoxy-Log-Parser, uagen, etc.
TOGGLE_DESC= Support for remote toggling
-OPTIONS_DEFAULT= EDITOR DOCS FORCE TOGGLE PRIVOXY_TOOLS
+OPTIONS_DEFAULT= EDITOR FORCE TOGGLE PRIVOXY_TOOLS
OPTIONS_SUB= yes
diff --git a/www/roundup/Makefile b/www/roundup/Makefile
index da337e19386e..225c42817db7 100644
--- a/www/roundup/Makefile
+++ b/www/roundup/Makefile
@@ -16,7 +16,7 @@ CPE_VENDOR= roundup-tracker
USE_PYTHON= distutils
OPTIONS_DEFINE= SQLITE PGSQL MYSQL NLS
-OPTIONS_DEFAULT=SQLITE NLS
+OPTIONS_DEFAULT=SQLITE
.include <bsd.port.options.mk>
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 6fcfc67bab9b..e997809b4014 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS_DEFINE= GD PHP NLS PCRE LDAP ICONV
-OPTIONS_DEFAULT=GD PHP NLS PCRE LDAP ICONV
+OPTIONS_DEFAULT=GD PHP PCRE LDAP ICONV
OPTIONS_SUB= yes
PHP_DESC= Install PHP for reporting generating
diff --git a/www/squid-devel/Makefile b/www/squid-devel/Makefile
index e3ca5ca085fe..f9f6f9833917 100644
--- a/www/squid-devel/Makefile
+++ b/www/squid-devel/Makefile
@@ -55,8 +55,8 @@ OPTIONS_DEFINE= ARP_ACL CACHE_DIGESTS DEBUG DELAY_POOLS ECAP ESI \
OPTIONS_SINGLE= GSSAPI
OPTIONS_SINGLE_GSSAPI= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
-OPTIONS_DEFAULT=ARP_ACL AUTH_NIS CACHE_DIGESTS DELAY_POOLS DOCS EXAMPLES FOLLOW_XFF \
- FS_AUFS FS_DISKD FS_ROCK HTCP ICAP ICMP IDENT IPV6 KQUEUE LARGEFILE \
+OPTIONS_DEFAULT=ARP_ACL AUTH_NIS CACHE_DIGESTS DELAY_POOLS FOLLOW_XFF \
+ FS_AUFS FS_DISKD FS_ROCK HTCP ICAP ICMP IDENT KQUEUE LARGEFILE \
LAX_HTTP SNMP SSL SSL_CRTD TP_IPFW VIA_DB WCCP WCCPV2 GSSAPI_BASE
ARP_ACL_CONFIGURE_ENABLE= eui
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 665aa4d3683d..6e75ecc24ca0 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -58,8 +58,8 @@ OPTIONS_DEFINE= ARP_ACL CACHE_DIGESTS DEBUG DELAY_POOLS ECAP ESI \
OPTIONS_SINGLE= GSSAPI
OPTIONS_SINGLE_GSSAPI= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
-OPTIONS_DEFAULT=ARP_ACL AUTH_NIS CACHE_DIGESTS DELAY_POOLS DOCS EXAMPLES FOLLOW_XFF \
- FS_AUFS FS_DISKD FS_ROCK HTCP ICAP ICMP IDENT IPV6 KQUEUE LARGEFILE \
+OPTIONS_DEFAULT=ARP_ACL AUTH_NIS CACHE_DIGESTS DELAY_POOLS FOLLOW_XFF \
+ FS_AUFS FS_DISKD FS_ROCK HTCP ICAP ICMP IDENT KQUEUE LARGEFILE \
LAX_HTTP SNMP SSL SSL_CRTD TP_IPFW VIA_DB WCCP WCCPV2 GSSAPI_BASE
ARP_ACL_CONFIGURE_ENABLE= eui
diff --git a/www/tengine/Makefile b/www/tengine/Makefile
index 270ebae6b293..edd4c211ed4b 100644
--- a/www/tengine/Makefile
+++ b/www/tengine/Makefile
@@ -94,7 +94,7 @@ OPTIONS_DEFINE= \
XRID_HEADER \
XSS
-OPTIONS_DEFAULT= IPV6 HTTP HTTP_CACHE HTTP_REWRITE HTTP_STATUS WWW
+OPTIONS_DEFAULT= HTTP HTTP_CACHE HTTP_REWRITE HTTP_STATUS WWW
DEBUGLOG_DESC= Enable debug log (--with-debug)
FILE_AIO_DESC= Enable file aio